EDIT: Advanced Ping Template Version 1.3 for Cacti 0.8.6g

Templates, scripts for templates, scripts and requests for templates.

Moderators: Moderators, Developers

Post Reply
Author
Message
Jey
Posts: 41
Joined: Wed Aug 22, 2007 8:01 am

#331 Post by Jey » Thu Feb 28, 2008 10:52 am

After install (replace ss_fping.php) and importe XML, I haven't graph.

I don't find...

When I add a graph, I have nothing in :
Data Source [avg]
Data Source [dev]
Data Source [loss]
Data Source [max]
Data Source [min]

Ex :
Image

No tutorial in the first post :(
(sorry for my english)




EDIT :
under Windows
apache_2.2.8-win32-x86-no_ssl.msi
php-5.2.5-Win32.zip
mysql-5.0.51a-win32
net-snmp-5.4.1-3.win32.exe
cacti-0.8.7b.zip
rrdtool-1.2.15-cygwin-1.5.20.zip
Last edited by Jey on Thu Feb 28, 2008 11:09 am, edited 1 time in total.

Jey
Posts: 41
Joined: Wed Aug 22, 2007 8:01 am

#332 Post by Jey » Thu Feb 28, 2008 10:56 am

And I have this :
Image

Also I have set detection with ICMP Ping, and host is Alive.

Jey
Posts: 41
Joined: Wed Aug 22, 2007 8:01 am

#333 Post by Jey » Thu Feb 28, 2008 12:21 pm

It's Ok.

After Add a new device, I don't "create a graph" by the link on top of the page (after re-enter on the new device).

Thanks for your work !

Jey
Posts: 41
Joined: Wed Aug 22, 2007 8:01 am

#334 Post by Jey » Fri Feb 29, 2008 3:52 am

Image


What are the black/grey pixels ?

Green line = latency, but en top ...

Mike6733
Posts: 4
Joined: Mon Mar 03, 2008 9:25 am

#335 Post by Mike6733 » Mon Mar 03, 2008 12:33 pm

I recently upgraded my winXP test box to 0.8.7 and spine. The ss_fping.php script will only work if the poller user id has administrator priviliges! I'm sure it's really some other persmission which is needed by the script.

How do you debug script_server imbeded scripts?

Is this something new with 0.8.7?

Thanks
Mike

ben_c
Cacti User
Posts: 203
Joined: Mon May 14, 2007 8:12 pm
Location: Melbourne, Australia.

#336 Post by ben_c » Mon Mar 10, 2008 6:54 pm

Anyone running 0.8.7, don't replace the standard ss_fping.php, just use the stock one already installed. Running the poller as root is the only way to get ICMP ping working, otherwise look at the permissions suggestions a few pages back if you cant do that.

Mike6733
Posts: 4
Joined: Mon Mar 03, 2008 9:25 am

#337 Post by Mike6733 » Tue Mar 11, 2008 6:23 am

Windows does care about security with ping.php!

It turns out that Windows has decided to enforce a higher level of security for the ping.php code.

Either the userid for the poller must have administrative priviledge or the following registry key must be set to 1:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Tcpip\Parameters\AllowUserRawAccess

Can I offer some code updates to help with future debugging?

fozzy99999
Posts: 3
Joined: Mon Mar 24, 2008 2:12 pm

#338 Post by fozzy99999 » Mon Mar 24, 2008 2:19 pm

Kinda noob to Advance Ping. I have modified my CDEFs from the original to change the latency percentages I am looking for, but now I would like to modify the way it shows periods of latency to change the color of the horizontal line from green to the color that represents the latency percentage. My users seem to be confused by the AREA blocks and are familiar with smokeping graphs.

Not looking for step by step howto but just a kick in the right direction would be apreciated
Attachments
Google_last_10800.png
Google_last_10800.png (32.78 KiB) Viewed 10250 times

User avatar
chrisgapske
Cacti User
Posts: 278
Joined: Tue May 22, 2007 7:56 am
Location: Pensacola, Fl - Padacuh, Ky-Alpena, MI-Gulf Shores,AL

#339 Post by chrisgapske » Mon Mar 31, 2008 9:27 am

I just upgraded to Cacti 8.7b and I not get errors with ssfping.

Devices that I could ping before now I can't ping.

Log File [Total Lines: 835 - All Items Shown]

03/31/2008 08:20:25 AM - CMDPHP: Poller[0] Host[59] DS[1321] SERVER: /var/www/html/scripts/ss_fping.php ss_fping IMGNOC-0-d-da-3-ad-c6.dhcp.fiber.local 20 ICMP , output: min:0.4400 avg:0.7440 max:2.4500 dev:0.4016 loss:0.0000
03/31/2008 08:20:25 AM - CMDPHP: Poller[0] Host[58] DS[1270] SERVER: /var/www/html/scripts/ss_fping.php ss_fping IMGNOC-0-d-da-1-c-af.dhcp.fiber.local 20 ICMP , output: min:0.7300 avg:1.2010 max:4.5900 dev:0.7953 loss:0.0000
03/31/2008 08:20:25 AM - CMDPHP: Poller[0] Host[57] DS[1262] SERVER: /var/www/html/scripts/ss_fping.php ss_fping IMGNOC-0-d-da-1-d-56.dhcp.fiber.local 20 ICMP , output: min:U avg:U max:U dev:U loss:100.00
03/31/2008 08:20:25 AM - CMDPHP: Poller[0] Host[56] DS[1306] SERVER: /var/www/html/scripts/ss_fping.php ss_fping IMGNOC-0-d-da-1-d-38.dhcp.fiber.local 20 ICMP , output: min:0.7000 avg:0.7370 max:0.7400 dev:0.0090 loss:0.0000
03/31/2008 08:20:25 AM - CMDPHP: Poller[0] Host[55] DS[1269] SERVER: /var/www/html/scripts/ss_fping.php ss_fping IMGNOC-0-d-da-1-c-ee.dhcp.fiber.local 20 ICMP , output: min:0.7000 avg:0.7415 max:0.8500 dev:0.0332 loss:0.0000
03/31/2008 08:20:25 AM - CMDPHP: Poller[0] Host[53] DS[1260] SERVER: /var/www/html/scripts/ss_fping.php ss_fping IMGNOC-0-d-da-1-c-ae.dhcp.fiber.local 20 ICMP , output: min:0.7000 avg:0.7355 max:0.7500 dev:0.0116 loss:0.0000
03/31/2008 08:20:25 AM - CMDPHP: Poller[0] Host[52] DS[1256] SERVER: /var/www/html/scripts/ss_fping.php ss_fping IMGNOC-0-d-da-1-c-a2.dhcp.fiber.local 20 ICMP , output: min:0.7000 avg:0.7345 max:0.7500 dev:0.0107 loss:0.0000
03/31/2008 08:20:24 AM - CMDPHP: Poller[0] Host[51] DS[1200] SERVER: /var/www/html/scripts/ss_fping.php ss_fping IMGNOC-0-d-da-1-c-9a.dhcp.fiber.local 20 ICMP , output: min:U avg:U max:U dev:U loss:100.00
03/31/2008 08:20:24 AM - CMDPHP: Poller[0] Host[50] DS[1267] SERVER: /var/www/html/scripts/ss_fping.php ss_fping IMGNOC-0-c-25-15-5-2f.dhcp.fiber.local 20 ICMP , output: min:0.4300 avg:0.4840 max:0.5100


Some Devices will ping some will not from php ss_fping.php..

The same devices that will not ping are pingable from a command line.

[[email protected] scripts]# ping IMGNOC-0-d-da-1-c-9a.dhcp.fiber.local
PING IMGNOC-0-d-da-1-c-9a.dhcp.fiber.local (10.0.255.252) 56(84) bytes of data.
64 bytes from 10.0.255.252: icmp_seq=1 ttl=154 time=0.661 ms
64 bytes from 10.0.255.252: icmp_seq=2 ttl=154 time=0.675 ms
64 bytes from 10.0.255.252: icmp_seq=3 ttl=154 time=0.815 ms


The only diffrence is that I updated from 0.8.7a to 0.8.7b.

toseeme
Posts: 6
Joined: Mon Jan 21, 2008 1:06 am
Location: shanghai- china

#340 Post by toseeme » Wed Apr 02, 2008 8:52 pm

I have no destination address .
I copied ping.php to cacti/lib/.and ss-fping.pnp to cacti/scripts.
but I do not know why it have no this item.

pls compare with these two pic.
what can I do?
Attachments
20080403094122360.png
smokepinglike 1.0
20080403094122360.png (18.97 KiB) Viewed 9994 times
20080403094335685.png
advance ping 1.3
20080403094335685.png (30.53 KiB) Viewed 9994 times

NetAdmin
Cacti User
Posts: 95
Joined: Wed Aug 30, 2006 8:45 pm

Graph Items aren't displaying proper values

#341 Post by NetAdmin » Fri Apr 11, 2008 1:01 pm

Can't figure out why the values displayed on the graph are different from the actual value in the data source. Attached graph shows a value of 16.14 ms for AVG latency, when in fact the actual data source shows a value of: Data Source Item [avg] - Current value: [13.2409], according to threshold and weathermap, both of which are pulling from the same data source.

Appreciate anyone's help with this.

Thanks!
Attachments
Latency-Graph.PNG
Latency-Graph.PNG (19.54 KiB) Viewed 9744 times

atrias
Posts: 25
Joined: Sat Dec 29, 2007 8:01 am

#342 Post by atrias » Sat Apr 12, 2008 12:01 pm

I have smokeping and advanced ping graphs for the same IP

Image Image

as you can see tha smokeping graph "cuts" the very high "smokes" but advanced ping graphs them

the smokeping graph is "easier/clearer" to read and better for presenting to the customers :wink:

is there any way for me to "cut" the high smokes from advanced ping??

i use cacti 0.8.7b and spine poller

i would appreciate any answer

thnk u

ManyX
Posts: 3
Joined: Tue Apr 29, 2008 9:02 am

#343 Post by ManyX » Tue Apr 29, 2008 9:10 am

Hello

I have problem with ss_fping.php when I run ss_fping.php

asd:/# php ss_fping.php 10.0.1.1 20 ICMP

I have error:

Fatal error: Call to undefined function: read_config_option() in /usr/share/cacti/site/scripts/ss_fping.php on line 38


Cacti Version 0.8.7b
PHP Version 5.2.0-8+etch10

Anyone help

zeki
Cacti User
Posts: 91
Joined: Fri Feb 09, 2007 10:55 pm
Location: So. Cal
Contact:

Re: I tried that

#344 Post by zeki » Thu May 01, 2008 5:58 am

i have the same problem have you found a solution yet?

update! i ran rebuild poller cache and it is working now :o
abdulcc wrote:11/13/2007 07:00:52 PM - CMDPHP: Poller[0] Host[44] DS[3216] SERVER: /var/www/html/cacti/scripts/ss_fping.php 64.233.183.104 10 ICMP , output: U
11/13/2007 07:00:52 PM - CMDPHP: Poller[0] Host[43] DS[3215] SERVER: /var/www/html/cacti/scripts/ss_fping.php 217.12.3.11 10 ICMP , output: U
11/13/2007 07:00:52 PM - CMDPHP: Poller[0] Host[41] DS[3210] SERVER: /var/www/html/cacti/scripts/ss_fping.php 213.136.100.241 10 ICMP , output: U
11/13/2007 07:00:49 PM - CMDPHP: Poller[0] Host[38] DS[3209] SERVER: /var/www/html/cacti/scripts/ss_fping.php 196.207.224.161 10 ICMP , output: U
11/13/2007 07:00:49 PM - CMDPHP: Poller[0] Host[38] DS[3208] SERVER: /var/www/html/cacti/scripts/ss_fping.php 196.207.224.161 20 ICMP 20, output: U

This is what I get

ManyX
Posts: 3
Joined: Tue Apr 29, 2008 9:02 am

#345 Post by ManyX » Thu May 01, 2008 3:55 pm

sorry I dont understund your mind

Post Reply