Monitoring Exchange 2003 from Linux Cacti

Templates, scripts for templates, scripts and requests for templates.

Moderators: Moderators, Developers

Post Reply
Author
Message
argon0
Cacti User
Posts: 443
Joined: Fri Mar 12, 2004 1:22 pm

#106 Post by argon0 » Wed Feb 18, 2009 4:34 am

Didn't realise there were two implementations, can you post a link to the one you got to work?

TVM
[size=50]No longer a n00by but[/size] not yet an 0ldby

Now Head of Technology at RSCH, back to the prickly subject of Monitorring....

mcutting
Cacti Guru User
Posts: 1874
Joined: Mon Oct 16, 2006 5:57 am
Location: United Kingdom
Contact:

#107 Post by mcutting » Wed Feb 18, 2009 4:38 am

Cacti Version 0.8.8b
Cacti OS Ubuntu LTS
RRDTool Version RRDTool 1.4.7
Poller Information
Type SPINE 0.8.8b

argon0
Cacti User
Posts: 443
Joined: Fri Mar 12, 2004 1:22 pm

#108 Post by argon0 » Wed Feb 18, 2009 4:59 am

Do you know if this is the same version as in CactiEZ?
[size=50]No longer a n00by but[/size] not yet an 0ldby

Now Head of Technology at RSCH, back to the prickly subject of Monitorring....

mcutting
Cacti Guru User
Posts: 1874
Joined: Mon Oct 16, 2006 5:57 am
Location: United Kingdom
Contact:

#109 Post by mcutting » Wed Feb 18, 2009 5:18 am

No, it's not. I couldn't get this version to work. I am now using Ubuntu full-time for my production Cacti server, and just used

apt-get install wmi-client

Works a treat.
Cacti Version 0.8.8b
Cacti OS Ubuntu LTS
RRDTool Version RRDTool 1.4.7
Poller Information
Type SPINE 0.8.8b

Stolly
Posts: 4
Joined: Tue Jun 30, 2009 9:19 am

#110 Post by Stolly » Fri Jul 10, 2009 9:37 am

Hmmm the wmi-client package has been taken out of Ubuntu Jaunty since apparently it had some bugs....

Do i HAVE to have this package installed for exchange monitoring to work ?

Stolly
Posts: 4
Joined: Tue Jun 30, 2009 9:19 am

#111 Post by Stolly » Mon Jul 13, 2009 9:45 am

To answer my own question...

No i didn't need to have the WMI-Plugin package installed, it works without it.

My problem was that the nslclient port specified as default in the scripts didn't match what my nsclient installs was using as default.

gatorfreak
Posts: 16
Joined: Fri Mar 27, 2009 11:09 am

#112 Post by gatorfreak » Thu Jul 30, 2009 9:34 am

I just ran into the problem that package wmi-client isn't available for Ubuntu 9.04. Using CactiWMI 0.0.6 and in wmi.php is:

Code: Select all

// general configuration
$wmiexe = '/usr/local/bin/wmic'; // executable for the wmic command
That doesn't exist. Don't I need to give it a path to an executable for it to work?

ruffsense
Posts: 18
Joined: Tue Jan 11, 2011 5:28 am

Re: Monitoring Exchange 2003 from Linux Cacti

#113 Post by ruffsense » Thu Mar 10, 2011 10:14 am

When i run this script command base it works.

I cant seem to get the $ARGV[0] to work. Where is this argument?

/usr/lib64/nagios/plugins/check_nt -H 10.0.*.* -p 12489 -v COUNTER -l "\\MSExchangeIS\\User Count" <- Then it works .

when i do this: ./exchange_users_script.pl <- It doesn't (can someone please help me out)

neuraltek
Posts: 1
Joined: Mon Mar 28, 2011 2:53 pm

Re: Monitoring Exchange 2003 from Linux Cacti

#114 Post by neuraltek » Mon Mar 28, 2011 3:00 pm

Anyone tried to do this in a HMC clustered Exchange 2003 environment?

My information store, SMTP servers and frontend exchange boxes (i.e. web, MAPI, RPC/https) are hosted on different hosts. The following is what it looks like:

2 Backend Exchange 2003 boxes configured in MS cluster and responds by the VIP hostname (have 3 separate VIP hosts so technically I have 6 backend exchange 2003 hosts configured in MS cluster)

3 SMTP servers for sending (LVS'ed)

3 frontend servers (LVS'ed)

From what I am reading, this works well if you only have 1 exchange server. What about in a clustered environment like mine? Anyone familiar with a setup like above?

Post Reply