VPN Tunnel monitoring

Templates, scripts for templates, scripts and requests for templates.

Moderators: Moderators, Developers

Author
Message
Leeroy
Posts: 14
Joined: Fri Jan 18, 2008 6:36 am
Location: Paris, France

#61 Post by Leeroy » Wed Jan 30, 2008 9:43 am

I solved my issue. In fact the time to execute was long because more than 200 tunnels exist on the host. So i execute the script on the other side of the tunnel where there is 1 or 2 tunnels.

Also, i've another issue. After an ipsec (lan to lan) tunnel fails and comes up, cacti / snmpd (i don't know which exactly) isn't able to recover information. This appears only on ASA whiches haves 2 tunnels. It seems that snmp can't find mib value.
The result of lan2lan_cisco.pl execution is tx:0 / rx:0 or "request error: No response from remote host 'xxx.xxx.xxx.xxx' at lan2lan_cisco.pl line 124."

User avatar
Setarcos
Cacti User
Posts: 143
Joined: Mon Dec 13, 2004 2:55 pm
Location: San Jose, CA
Contact:

#62 Post by Setarcos » Tue May 06, 2008 7:38 pm

Hi Folks,

I hacked up the original script, and created an indexed script query to simplify adding peers. If you are interested, check out the thread here.

cgi_itdeusto
Posts: 2
Joined: Thu Jun 17, 2010 1:39 am

#63 Post by cgi_itdeusto » Thu Jun 17, 2010 1:49 am

Sorry for my English. This script worked fine and it's just what I needed but I have a problem. Suddenly one day left to paint the graphics. I have not made any software change. Running the script returns me the following error:

"request error: A loop Was detected with the table on the remote host at / var/www/cacti/scripts/query_lan2lan_cisco.pl line 246"

Does anyone know how to fix? I think it is related to the router does not increase the OID and may be solved with the option "Non Increasing" Net:: SNMP but I do not know how to activate it. Anybody can help me?

Thank you very much

kugar
Posts: 1
Joined: Mon Nov 22, 2010 11:43 am

Re: VPN Tunnel monitoring

#64 Post by kugar » Mon Nov 22, 2010 12:01 pm

I was using this template with the lan2lan_cisco.pl script without problem but since I updated perl to v5.12.2, the script just return this error :

Code: Select all

defined(%hash) is deprecated at /var/www/stats/htdocs/cacti/scripts/lan2lan_cisco.pl line 124.
        (Maybe you should just omit the defined()?)
request error: The argument "1.3.6.1.4.1.9.9.171.1.2.3.1.7." is unknown at /var/www/stats/htdocs/cacti/scripts/lan2lan_cisco.pl line 124.
:( Does someone have the same problem ? I suppose this is juste a perl problem but my knowledge in perl is quite limited ...

Post Reply