Juniper temps

Templates, scripts for templates, scripts and requests for templates.

Moderators: Moderators, Developers

Post Reply
Author
Message
lighiche
Posts: 6
Joined: Mon Mar 03, 2014 9:16 am

Juniper temps

#1 Post by lighiche » Mon Mar 03, 2014 9:30 am

Hi there guys,

New to the forum, looking for some help. I'm also new to cacti and RRD. I'm building up to being able to write my own xml templates but for right now I've been checking out other peoples work. I've been using a Juniper xml I downloaded from the site here to monitor certain statistics that I hope to elaborate on over the coming months. And will probably have more questions as that happens. But for right now though the Juniper template is really good. I'm concerned about the Temp graph though, It shows me

FPC0,1 (this grabs statistics but doesn't graph)
FPC2,3 (these graph normally)
RE0,1 (these graph normally)
SSB0,1 (this grabs no statistics)

This template was in no way designed for the setup that we have right now in our core. It's a virtual chassis of EX4550's and EX4200's. I can walk the OID for FPC0,1 and the set on the graph template version is identical for all FPC/RE/SSB so there's nothing I can see that's set different. I'm using cacti 0.8.8b (Cactiez updated) It's been graphing for around 2 weeks or so. ( I don't even know if this is reporting on virtual chassis statistics or a particular switch within it like i said right now it's a work in progress.)


# here are the details

/usr/bin/rrdtool graph - \
--imgformat=PNG \
--start=1393564172 \
--end=1393856011 \
--title='EX CORE - Temperatures' \
--base=1000 \
--height=200 \
--width=500 \
--alt-autoscale-max \
--lower-limit='0' \
COMMENT:"From 2014/02/28 00\:09\:32 To 2014/03/03 09\:13\:31\c" \
COMMENT:" \n" \
--vertical-label='Degrees C' \
--slope-mode \
--font TITLE:10:'DejaVu Sans Mono' \
--font AXIS:8: \
--font LEGEND:8: \
--font UNIT:8: \
DEF:a='/var/www/html/rra/ex_core_juniper_fpc0_temp_65.rrd':'juniper_fpc0_temp':AVERAGE \
DEF:b='/var/www/html/rra/ex_core_juniper_fpc1_temp_66.rrd':'juniper_fpc1_temp':AVERAGE \
DEF:c='/var/www/html/rra/ex_core_juniper_fpc2_temp_67.rrd':'juniper_fpc2_temp':AVERAGE \
DEF:d='/var/www/html/rra/ex_core_juniper_fpc3_temp_68.rrd':'juniper_fpc3_temp':AVERAGE \
DEF:e='/var/www/html/rra/ex_core_juniper_re0_temp_69.rrd':'juniper_re0_temp':AVERAGE \
DEF:f='/var/www/html/rra/ex_core_juniper_re1_temp_70.rrd':'juniper_re1_temp':AVERAGE \
--watermark "Created using CactiEZ" \
LINE1:a#00BF47FF:'FPC0 Temp' \
GPRINT:a:LAST:'Current\:%8.2lf %s' \
GPRINT:a:AVERAGE:'Average\:%8.2lf %s' \
GPRINT:a:MAX:'Maximum\:%8.2lf %s\n' \
LINE1:b#55009DFF:'FPC1 Temp' \
GPRINT:b:LAST:'Current\:%8.2lf %s' \
GPRINT:b:AVERAGE:'Average\:%8.2lf %s' \
GPRINT:b:MAX:'Maximum\:%8.2lf %s\n' \
LINE1:c#DA4725FF:'FPC2 Temp' \
GPRINT:c:LAST:'Current\:%8.2lf %s' \
GPRINT:c:AVERAGE:'Average\:%8.2lf %s' \
GPRINT:c:MAX:'Maximum\:%8.2lf %s\n' \
LINE1:d#ED7600FF:'FPC3 Temp' \
GPRINT:d:LAST:'Current\:%8.2lf %s' \
GPRINT:d:AVERAGE:'Average\:%8.2lf %s' \
GPRINT:d:MAX:'Maximum\:%8.2lf %s\n' \
LINE1:e#EACC00FF:'RE0 Temp' \
GPRINT:e:LAST:' Current\:%8.2lf %s' \
GPRINT:e:AVERAGE:'Average\:%8.2lf %s' \
GPRINT:e:MAX:'Maximum\:%8.2lf %s\n' \
LINE1:f#FFF200FF:'RE1 Temp' \
GPRINT:f:LAST:' Current\:%8.2lf %s' \
GPRINT:f:AVERAGE:'Average\:%8.2lf %s' \
GPRINT:f:MAX:'Maximum\:%8.2lf %s\n'

I should mention I removed SSB from this graph on purpose as it wasn't pulling anything anyway
Also this may need to be moved to general help or whatever i'm not sure

Post Reply