Template Request - Radware WSD & Appdirector

Templates, scripts for templates, scripts and requests for templates.

Moderators: Moderators, Developers

Post Reply
Author
Message
boots
Cacti User
Posts: 55
Joined: Wed Jan 07, 2004 4:59 am
Location: Melbourne Australia

Template Request - Radware WSD & Appdirector

#1 Post by boots » Wed Oct 17, 2007 1:26 am

Hi all,

I'm already pulling CPU load and interface stats of Radware WSD devices, but I am really after a template that will allow you to select specific farms and display stats on attached users, peak load, frames rate etc per farm member server.

Anyone written one?

Thanks

Boots

boots
Cacti User
Posts: 55
Joined: Wed Jan 07, 2004 4:59 am
Location: Melbourne Australia

#2 Post by boots » Mon Oct 29, 2007 12:25 am

Here is version 1, templates covering Users per farm and Frames per second per farm.
Attachments
Radware.zip
Everything you need should be here.....
(44.21 KiB) Downloaded 1352 times
Connected Users.jpg
Connected Users Graph
Connected Users.jpg (28.55 KiB) Viewed 14090 times
TCP Frames.jpg
Frames Per Second
TCP Frames.jpg (31.65 KiB) Viewed 14090 times

sapofeo
Posts: 13
Joined: Thu Feb 17, 2005 5:23 pm
Contact:

#3 Post by sapofeo » Mon May 05, 2008 1:19 pm

Not too many Radware users in the world it seems...

I seem to be missing how to get this setup. I see you're using Get SNMP Data (Indexed) to retrieve the data. Do I have to make any additional manual entries to poll the individual farms or should the script discover and display the ones it finds?

boots
Cacti User
Posts: 55
Joined: Wed Jan 07, 2004 4:59 am
Location: Melbourne Australia

#4 Post by boots » Thu May 08, 2008 12:06 pm

Yeah, I think they are on the decline...F5 seems to have that market stitched up....

The SNMP script will show the farms by IP address for you to select which ones you are interested in...

Cheers

Boots

blacknasa
Posts: 1
Joined: Mon Jun 16, 2008 2:04 am

Radware Appdirector

#5 Post by blacknasa » Wed Jun 25, 2008 3:44 am

Hi,

I tried to use the Radware Template however i cant import it, i'm using version 0.86 (i think).

Do anybody had a Template for AppDirector.

10x

Blacknasa

boots
Cacti User
Posts: 55
Joined: Wed Jan 07, 2004 4:59 am
Location: Melbourne Australia

#6 Post by boots » Wed Jun 25, 2008 6:15 am

This template also works for the app director hardware....

old8xp
Posts: 5
Joined: Thu Jul 27, 2006 7:58 pm

Re: Radware Appdirector

#7 Post by old8xp » Tue Jun 23, 2009 6:58 am

blacknasa wrote:Hi,

I tried to use the Radware Template however i cant import it, i'm using version 0.86 (i think).

Do anybody had a Template for AppDirector.

10x

Blacknasa

I think U import Template use follow step:

1)import all xml to cacti.
2)copy radware_packets.xml and radware_wsd to CACTI server $HOMECACTI/resource/snmp_query

and try it.

lisun
Posts: 3
Joined: Fri Mar 06, 2009 8:56 am

can i change the color?

#8 Post by lisun » Wed Jun 23, 2010 3:07 am

This template is good.
But can i change the color and how ?
Thank you!

jay
Cacti User
Posts: 390
Joined: Wed Aug 31, 2005 8:55 am
Location: Bristol, England

#9 Post by jay » Fri Jun 25, 2010 10:08 am

You just need to go to the graph template and change the colour for the graph item.
Cacti Version 0.8.7e, Spine 0.8.7e, Apache 2.2.15, Mysql 5.0.88, PHP 5.2.13, RRDTool 1.2.30, NET-SNMP 5.5
Quad Core AMD Opteron Processor 2384, 2.70Ghz, 2GB RAM , 1 CPU used
Windows Server 2003 (X64), VMWARE ESX
Plugins: Aggregate 0.75

SYSTEM STATS: Time:12.5140 Method:spine Processes:2 Threads:15 Hosts:400 HostsPerProcess:200 DataSources:2909 RRDsProcessed:1384

bojus
Posts: 13
Joined: Tue Apr 05, 2011 4:44 am

Re: Template Request - Radware WSD & Appdirector

#10 Post by bojus » Tue Apr 05, 2011 5:07 am

Hi ALL,

I faced problem with drawing the connected users. Everything looks OK, but on the graph I don't see anything. And when I click on "Verbose Query" in Devices there are entries like this:


Executing SNMP walk for list of indexes @ '.1.3.6.1.4.1.89.35.1.40.29.7.1.2'
+ Index found at OID: '.1.3.6.1.4.1.89.35.1.40.29.7.1.2.XX.XX.XX.XX' value: '126'
+ Index found at OID: '.1.3.6.1.4.1.89.35.1.40.29.7.1.2.YY.YY.YY.YY' value: '776'
+ index_parse at OID: '.1.3.6.1.4.1.89.35.1.40.29.7.1.2.XX.XX.XX.XX' results: '.XX.XX.XX.XX'
+ index_parse at OID: '.1.3.6.1.4.1.89.35.1.40.29.7.1.2.YY.YY.YY.YY' results: '.YY.YY.YY.YY'



So, where I made the mistake??

Thanks a lot for any hint.

rfc791
Posts: 2
Joined: Wed Apr 13, 2011 3:37 pm

Re: Template Request - Radware WSD & Appdirector

#11 Post by rfc791 » Wed Apr 13, 2011 4:50 pm

Thanks for the template!

I am having an issue with the Connected User Count. When I check the logs I am seeing "RROR: Problems parsing Multi SNMP OID:" and in the OID string it includes a double .. with the Index Value. So .1.3.6.1.4.1.89.35.1.40.29.7.1.2..XX.XX.XX.XX.

Any ideas why? Is it in the Template that is adding the extra dot or someone else. I have removed and re-added the Device and it still shows up. Can I change something in the DB?

noname
Cacti Guru User
Posts: 1566
Joined: Thu Aug 05, 2010 2:04 am
Location: Japan

Re: Template Request - Radware WSD & Appdirector

#12 Post by noname » Wed Apr 13, 2011 10:30 pm

rfc791 wrote:When I check the logs I am seeing "ERROR: Problems parsing Multi SNMP OID!" and in the OID string it includes a double .. with the Index Value. So .1.3.6.1.4.1.89.35.1.40.29.7.1.2..XX.XX.XX.XX.
It seems to be Spine specific error.
Try to replace in 'radware_wsd.xml',
from
<oid_index_parse>OID/REGEXP:^.{32}(.*)</oid_index_parse>

to
<oid_index_parse>OID/REGEXP:^.{33}(.*)</oid_index_parse>
or
<oid_index_parse>OID/REGEXP:^.*\.([0-9]+\.[0-9]+\.[0-9]+\.[0-9]+)$</oid_index_parse>

rfc791
Posts: 2
Joined: Wed Apr 13, 2011 3:37 pm

Re: Template Request - Radware WSD & Appdirector

#13 Post by rfc791 » Thu Apr 14, 2011 8:26 am

Thanks! This one fixed the issue.
<oid_index_parse>OID/REGEXP:^.{33}(.*)</oid_index_parse>

yreddy
Posts: 43
Joined: Fri May 02, 2008 7:33 am
Location: Canada

Re: Template Request - Radware WSD & Appdirector

#14 Post by yreddy » Tue Nov 19, 2013 5:39 am

Hi,

I've compiled the different radware graphs I've found on this forum, fixed different issues I've seen with the snmp queries and developed my own graphs in order to provide the following resulting host template (Radware AppDirector):
http://docs.cacti.net/usertemplate:host ... ppdirector

enjoy!
Youri

Post Reply