Cacti (home)ForumsDocumentation
Cacti: offical forums and support
It is currently Thu Apr 25, 2019 5:12 am

All times are UTC - 5 hours




Post new topic Reply to topic  [ 14 posts ] 
Author Message
 Post subject: Template Request - Radware WSD & Appdirector
PostPosted: Wed Oct 17, 2007 1:26 am 
Offline
Cacti User

Joined: Wed Jan 07, 2004 4:59 am
Posts: 55
Location: Melbourne Australia
Hi all,

I'm already pulling CPU load and interface stats of Radware WSD devices, but I am really after a template that will allow you to select specific farms and display stats on attached users, peak load, frames rate etc per farm member server.

Anyone written one?

Thanks

Boots


Top
 Profile  
 
 Post subject:
PostPosted: Mon Oct 29, 2007 12:25 am 
Offline
Cacti User

Joined: Wed Jan 07, 2004 4:59 am
Posts: 55
Location: Melbourne Australia
Here is version 1, templates covering Users per farm and Frames per second per farm.


Attachments:
File comment: Frames Per Second
TCP Frames.jpg
TCP Frames.jpg [ 31.65 KiB | Viewed 13879 times ]
File comment: Connected Users Graph
Connected Users.jpg
Connected Users.jpg [ 28.55 KiB | Viewed 13879 times ]
File comment: Everything you need should be here.....
Radware.zip [44.21 KiB]
Downloaded 1341 times
Top
 Profile  
 
 Post subject:
PostPosted: Mon May 05, 2008 1:19 pm 
Offline

Joined: Thu Feb 17, 2005 5:23 pm
Posts: 13
Not too many Radware users in the world it seems...

I seem to be missing how to get this setup. I see you're using Get SNMP Data (Indexed) to retrieve the data. Do I have to make any additional manual entries to poll the individual farms or should the script discover and display the ones it finds?


Top
 Profile  
 
 Post subject:
PostPosted: Thu May 08, 2008 12:06 pm 
Offline
Cacti User

Joined: Wed Jan 07, 2004 4:59 am
Posts: 55
Location: Melbourne Australia
Yeah, I think they are on the decline...F5 seems to have that market stitched up....

The SNMP script will show the farms by IP address for you to select which ones you are interested in...

Cheers

Boots


Top
 Profile  
 
 Post subject: Radware Appdirector
PostPosted: Wed Jun 25, 2008 3:44 am 
Offline

Joined: Mon Jun 16, 2008 2:04 am
Posts: 1
Hi,

I tried to use the Radware Template however i cant import it, i'm using version 0.86 (i think).

Do anybody had a Template for AppDirector.

10x

Blacknasa


Top
 Profile  
 
 Post subject:
PostPosted: Wed Jun 25, 2008 6:15 am 
Offline
Cacti User

Joined: Wed Jan 07, 2004 4:59 am
Posts: 55
Location: Melbourne Australia
This template also works for the app director hardware....


Top
 Profile  
 
 Post subject: Re: Radware Appdirector
PostPosted: Tue Jun 23, 2009 6:58 am 
Offline

Joined: Thu Jul 27, 2006 7:58 pm
Posts: 5
blacknasa wrote:
Hi,

I tried to use the Radware Template however i cant import it, i'm using version 0.86 (i think).

Do anybody had a Template for AppDirector.

10x

Blacknasa



I think U import Template use follow step:

1)import all xml to cacti.
2)copy radware_packets.xml and radware_wsd to CACTI server $HOMECACTI/resource/snmp_query

and try it.


Top
 Profile  
 
 Post subject: can i change the color?
PostPosted: Wed Jun 23, 2010 3:07 am 
Offline

Joined: Fri Mar 06, 2009 8:56 am
Posts: 3
This template is good.
But can i change the color and how ?
Thank you!


Top
 Profile  
 
 Post subject:
PostPosted: Fri Jun 25, 2010 10:08 am 
Offline
Cacti User

Joined: Wed Aug 31, 2005 8:55 am
Posts: 390
Location: Bristol, England
You just need to go to the graph template and change the colour for the graph item.

_________________
Cacti Version 0.8.7e, Spine 0.8.7e, Apache 2.2.15, Mysql 5.0.88, PHP 5.2.13, RRDTool 1.2.30, NET-SNMP 5.5
Quad Core AMD Opteron Processor 2384, 2.70Ghz, 2GB RAM , 1 CPU used
Windows Server 2003 (X64), VMWARE ESX
Plugins: Aggregate 0.75

SYSTEM STATS: Time:12.5140 Method:spine Processes:2 Threads:15 Hosts:400 HostsPerProcess:200 DataSources:2909 RRDsProcessed:1384


Top
 Profile  
 
 Post subject: Re: Template Request - Radware WSD & Appdirector
PostPosted: Tue Apr 05, 2011 5:07 am 
Offline

Joined: Tue Apr 05, 2011 4:44 am
Posts: 13
Hi ALL,

I faced problem with drawing the connected users. Everything looks OK, but on the graph I don't see anything. And when I click on "Verbose Query" in Devices there are entries like this:


Executing SNMP walk for list of indexes @ '.1.3.6.1.4.1.89.35.1.40.29.7.1.2'
+ Index found at OID: '.1.3.6.1.4.1.89.35.1.40.29.7.1.2.XX.XX.XX.XX' value: '126'
+ Index found at OID: '.1.3.6.1.4.1.89.35.1.40.29.7.1.2.YY.YY.YY.YY' value: '776'
+ index_parse at OID: '.1.3.6.1.4.1.89.35.1.40.29.7.1.2.XX.XX.XX.XX' results: '.XX.XX.XX.XX'
+ index_parse at OID: '.1.3.6.1.4.1.89.35.1.40.29.7.1.2.YY.YY.YY.YY' results: '.YY.YY.YY.YY'



So, where I made the mistake??

Thanks a lot for any hint.


Top
 Profile  
 
 Post subject: Re: Template Request - Radware WSD & Appdirector
PostPosted: Wed Apr 13, 2011 4:50 pm 
Offline

Joined: Wed Apr 13, 2011 3:37 pm
Posts: 2
Thanks for the template!

I am having an issue with the Connected User Count. When I check the logs I am seeing "RROR: Problems parsing Multi SNMP OID:" and in the OID string it includes a double .. with the Index Value. So .1.3.6.1.4.1.89.35.1.40.29.7.1.2..XX.XX.XX.XX.

Any ideas why? Is it in the Template that is adding the extra dot or someone else. I have removed and re-added the Device and it still shows up. Can I change something in the DB?


Top
 Profile  
 
 Post subject: Re: Template Request - Radware WSD & Appdirector
PostPosted: Wed Apr 13, 2011 10:30 pm 
Offline
Cacti Guru User

Joined: Thu Aug 05, 2010 2:04 am
Posts: 1566
Location: Japan
rfc791 wrote:
When I check the logs I am seeing "ERROR: Problems parsing Multi SNMP OID!" and in the OID string it includes a double .. with the Index Value. So .1.3.6.1.4.1.89.35.1.40.29.7.1.2..XX.XX.XX.XX.

It seems to be Spine specific error.
Try to replace in 'radware_wsd.xml',
from
Quote:
<oid_index_parse>OID/REGEXP:^.{32}(.*)</oid_index_parse>

to
Quote:
<oid_index_parse>OID/REGEXP:^.{33}(.*)</oid_index_parse>

or
Quote:
<oid_index_parse>OID/REGEXP:^.*\.([0-9]+\.[0-9]+\.[0-9]+\.[0-9]+)$</oid_index_parse>


Top
 Profile  
 
 Post subject: Re: Template Request - Radware WSD & Appdirector
PostPosted: Thu Apr 14, 2011 8:26 am 
Offline

Joined: Wed Apr 13, 2011 3:37 pm
Posts: 2
Thanks! This one fixed the issue.

Quote:
<oid_index_parse>OID/REGEXP:^.{33}(.*)</oid_index_parse>


Top
 Profile  
 
 Post subject: Re: Template Request - Radware WSD & Appdirector
PostPosted: Tue Nov 19, 2013 5:39 am 
Offline

Joined: Fri May 02, 2008 7:33 am
Posts: 43
Location: Canada
Hi,

I've compiled the different radware graphs I've found on this forum, fixed different issues I've seen with the snmp queries and developed my own graphs in order to provide the following resulting host template (Radware AppDirector):
http://docs.cacti.net/usertemplate:host:radware:appdirector

enjoy!
Youri


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 14 posts ] 

All times are UTC - 5 hours


Who is online

Users browsing this forum: No registered users and 3 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  

Protected by Anti-Spam ACP Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group