WinXP-Win8, Win2000-Server 2012 x32/x64 Templates

Templates, scripts for templates, scripts and requests for templates.

Moderators: Moderators, Developers

Post Reply
Author
Message
boomam
Posts: 5
Joined: Wed Jul 04, 2012 5:42 am

Re: WinXP/Vista/Win7/Win2000/Win2003/Win2008 Templates x32/x

#226 Post by boomam » Wed Jul 04, 2012 5:45 am

Just imported these templates/XMLs.
All seems fine, no errors, but the graphs themselves dont display, just a blank box.

Any reason for that?
Is there something more i need to do to get them working? Or is just not displaying data as it has no data to give yet?

Thanks in advance.

boomam
Posts: 5
Joined: Wed Jul 04, 2012 5:42 am

Re: WinXP/Vista/Win7/Win2000/Win2003/Win2008 Templates x32/x

#227 Post by boomam » Wed Jul 04, 2012 6:31 am

...progress!
Removed all templates/devices and re-updated with v9 of these templates, now some of the graphs create.

However anything to do with disk statistics, or memory (apart from paging), dont display.

Thoughts?

##EDIT##

Error on the graph debug shows:
ERROR: opening '/var/lib/cacti/rra/SERVER1_avgdisksecperread_149.rrd': No such file or directory

Checked the permissions and they show the permissions as:
drwxr-xr-x 3 root root 4096 Jun 19 09:23 .
drwxr-xr-x 53 root root 4096 Jun 20 19:32 ..
drwxrwx--- 2 root www-data 12288 Jul 4 13:55 rra


Ideas?

boomam
Posts: 5
Joined: Wed Jul 04, 2012 5:42 am

Re: WinXP/Vista/Win7/Win2000/Win2003/Win2008 Templates x32/x

#228 Post by boomam » Thu Jul 05, 2012 11:30 am

Ive come to the conclusion that there is something wrong with these templates.

Put them on a windows install of cacti and the same error rears its head! :(

fnsnetsys
Posts: 1
Joined: Thu Jul 05, 2012 11:37 pm

Re: WinXP/Vista/Win7/Win2000/Win2003/Win2008 Templates x32/x

#229 Post by fnsnetsys » Thu Jul 05, 2012 11:39 pm

Ok Guys, I have got the templates collecting data from the CPU, and graphing fine, but the other templates give me the error below:
This data query returned 0 rows, perhaps there was a problem executing this data query. You can run this data query in debug mode to get more information.

Debug info below:
+ Running data query [11].
+ Found type = '3' [SNMP Query].
+ Found data query XML file at '/resource/snmp_queries/snmp_informant_standard_disk.xml'
+ XML file parsed ok.
+ <oid_num_indexes> missing in XML file, 'Index Count Changed' emulated by counting oid_index entries
+ Executing SNMP walk for list of indexes @ '.1.3.6.1.4.1.9600.1.1.1.1.1' Index Count: 4
+ Index found at OID: '1.3.6.1.4.1.9600.1.1.1.1.1.2.67.58' value: 'C:'
+ Index found at OID: '1.3.6.1.4.1.9600.1.1.1.1.1.2.68.58' value: 'D:'
+ Index found at OID: '1.3.6.1.4.1.9600.1.1.1.1.1.6.95.84.111.116.97.108' value: '_Total'
+ Index found at OID: '1.3.6.1.4.1.9600.1.1.1.1.1.15.72.97.114.100.100.105.115.107.86.111.108.117.109.101.49' value: 'HarddiskVolume1'
+ index_parse at OID: '1.3.6.1.4.1.9600.1.1.1.1.1.2.67.58' results: '2.67.58'
+ index_parse at OID: '1.3.6.1.4.1.9600.1.1.1.1.1.2.68.58' results: '2.68.58'
+ index_parse at OID: '1.3.6.1.4.1.9600.1.1.1.1.1.6.95.84.111.116.97.108' results: '6.95.84.111.116.97.108'
+ index_parse at OID: '1.3.6.1.4.1.9600.1.1.1.1.1.15.72.97.114.100.100.105.115.107.86.111.108.117.109.101.49' results: '15.72.97.114.100.100.105.115.107.86.111.108.117.109.101.49'
+ Located input field 'lDiskInstance' [walk]
+ Executing SNMP walk for data @ '.1.3.6.1.4.1.9600.1.1.1.1.1'
+ Found item [lDiskInstance='C:'] index: 2.67.58 [from value]
+ Found item [lDiskInstance='D:'] index: 2.68.58 [from value]
+ Found item [lDiskInstance='_Total'] index: 6.95.84.111.116.97.108 [from value]
+ Found item [lDiskInstance='HarddiskVolume1'] index: 15.72.97.114.100.100.105.115.107.86.111.108.117.109.101.49 [from value]

Any ideas????

User avatar
G0dSmack
Cacti User
Posts: 85
Joined: Wed Nov 12, 2008 10:25 am
Contact:

Re: WinXP/Vista/Win7/Win2000/Win2003/Win2008 Templates x32/x

#230 Post by G0dSmack » Sat Jul 07, 2012 1:29 pm

bahiano04 wrote:Hi G0dSmack,

I'm useing Cacti 0.8.8a and v12 of your templates but CPU template doesn't get any information:

+ Running data query [20].
+ Found type = '3' [SNMP Query].
+ Found data query XML file at '/var/www/html/cacti/resource/snmp_queries/snmp_informant_standard_cpu.xml'
+ XML file parsed ok.
+ <oid_num_indexes> missing in XML file, 'Index Count Changed' emulated by counting oid_index entries
+ Executing SNMP walk for list of indexes @ '.1.3.6.1.4.1.9600.1.1.5.1' Index Count: 0
+ No SNMP data returned

All of the other templates are working fine.

Do I have to enable something in the Windows Server ??
Were you able to get them working? I just did the exact same install last night using 0.8.8a on Ubuntu 12.04 and imported v12 templates and all graphs are working as they should be. Did you install SNMP Informant Free Standard edition on your windows server?
@mrlesmithjr
http://everythingshouldbevirtual.com

User avatar
G0dSmack
Cacti User
Posts: 85
Joined: Wed Nov 12, 2008 10:25 am
Contact:

Re: WinXP/Vista/Win7/Win2000/Win2003/Win2008 Templates x32/x

#231 Post by G0dSmack » Sat Jul 07, 2012 1:37 pm

boomam wrote:...progress!
Removed all templates/devices and re-updated with v9 of these templates, now some of the graphs create.

However anything to do with disk statistics, or memory (apart from paging), dont display.

Thoughts?

##EDIT##

Error on the graph debug shows:
ERROR: opening '/var/lib/cacti/rra/SERVER1_avgdisksecperread_149.rrd': No such file or directory

Checked the permissions and they show the permissions as:
drwxr-xr-x 3 root root 4096 Jun 19 09:23 .
drwxr-xr-x 53 root root 4096 Jun 20 19:32 ..
drwxrwx--- 2 root www-data 12288 Jul 4 13:55 rra


Ideas?
Have you installed SNMP Informant Free standard edition? These templates work perfectly if you follow the steps.
@mrlesmithjr
http://everythingshouldbevirtual.com

zuoye
Posts: 1
Joined: Sat Jul 07, 2012 4:08 am

Re: WinXP/Vista/Win7/Win2000/Win2003/Win2008 Templates x32/x

#232 Post by zuoye » Sun Jul 08, 2012 1:21 am

G0dSmack,Good Job,it's perfect and works for me,Thank you very much! :D

boomam
Posts: 5
Joined: Wed Jul 04, 2012 5:42 am

Re: WinXP/Vista/Win7/Win2000/Win2003/Win2008 Templates x32/x

#233 Post by boomam » Mon Jul 09, 2012 6:57 am

G0dSmack wrote:
boomam wrote:...progress!
Removed all templates/devices and re-updated with v9 of these templates, now some of the graphs create.

However anything to do with disk statistics, or memory (apart from paging), dont display.

Thoughts?

##EDIT##

Error on the graph debug shows:
ERROR: opening '/var/lib/cacti/rra/SERVER1_avgdisksecperread_149.rrd': No such file or directory

Checked the permissions and they show the permissions as:
drwxr-xr-x 3 root root 4096 Jun 19 09:23 .
drwxr-xr-x 53 root root 4096 Jun 20 19:32 ..
drwxrwx--- 2 root www-data 12288 Jul 4 13:55 rra


Ideas?
Have you installed SNMP Informant Free standard edition? These templates work perfectly if you follow the steps.
Yes.

Im now working off a 2008 R2 server as the Cacti host, same issue.

User avatar
G0dSmack
Cacti User
Posts: 85
Joined: Wed Nov 12, 2008 10:25 am
Contact:

Re: WinXP/Vista/Win7/Win2000/Win2003/Win2008 Templates x32/x

#234 Post by G0dSmack » Mon Aug 13, 2012 10:06 am

All,
I have started a new blog site if you would like to check it out. I will be writing up some cacti docs soon as well.

http://everythingshouldbevirtual.com
Last edited by G0dSmack on Mon Feb 25, 2013 3:40 pm, edited 1 time in total.
@mrlesmithjr
http://everythingshouldbevirtual.com

kevinqiu
Posts: 1
Joined: Thu Sep 13, 2012 4:44 am

Re: WinXP/Vista/Win7/Win2000/Win2003/Win2008 Templates x32/x

#235 Post by kevinqiu » Sat Sep 15, 2012 2:36 am

Dear godsmark
i really need your help i already according to what your said to do i import the template and dorp the *.xml in the specified directory but it seens not work . when i add a windows device and i can get the snmp information but the satus is unknow ...

User avatar
G0dSmack
Cacti User
Posts: 85
Joined: Wed Nov 12, 2008 10:25 am
Contact:

Re: WinXP/Vista/Win7/Win2000/2003/2008/2012 x32/x64 Template

#236 Post by G0dSmack » Fri Sep 28, 2012 7:17 pm

New walkthrough and setup for using these templates over on my blog site. Go check it out.
http://everythingshouldbevirtual/cacti- ... ws-servers
Last edited by G0dSmack on Mon Feb 25, 2013 3:39 pm, edited 2 times in total.
@mrlesmithjr
http://everythingshouldbevirtual.com

User avatar
G0dSmack
Cacti User
Posts: 85
Joined: Wed Nov 12, 2008 10:25 am
Contact:

Re: WinXP/Vista/Win7/Win2000/2003/2008/2012 x32/x64 Template

#237 Post by G0dSmack » Fri Sep 28, 2012 7:22 pm

New updated templates and previous versions available http://everythingshouldbevirtual.com/ca ... r-windows/
Last edited by G0dSmack on Mon Feb 25, 2013 3:39 pm, edited 2 times in total.
@mrlesmithjr
http://everythingshouldbevirtual.com

User avatar
G0dSmack
Cacti User
Posts: 85
Joined: Wed Nov 12, 2008 10:25 am
Contact:

Re: WinXP/Vista/Win7/Win2000/2003/2008/2012 x32/x64 Template

#238 Post by G0dSmack » Sun Sep 30, 2012 2:10 pm

New templates version. Read readme.txt for instructions or go here.
Attachments
Cacti_SNMP_Informant_Standard_Metrics_v13.zip
(67.14 KiB) Downloaded 8802 times
Last edited by G0dSmack on Sun Feb 03, 2013 12:22 am, edited 1 time in total.
@mrlesmithjr
http://everythingshouldbevirtual.com

Nayrb
Posts: 1
Joined: Thu Nov 01, 2012 10:19 am

Re: WinXP/Vista/Win7/Win2000/2003/2008/2012 x32/x64 Template

#239 Post by Nayrb » Thu Nov 01, 2012 10:22 am

G0dSmack wrote:New templates version.
Thank you!

User avatar
morgentau
Posts: 39
Joined: Fri Jun 16, 2006 4:05 am
Location: Zurich, Switzerland

Re: WinXP/Vista/Win7/Win2000/2003/2008/2012 x32/x64 Template

#240 Post by morgentau » Thu Nov 08, 2012 3:24 am

I set this up on Windows Server 2003 and 2008 for both x86 and x64... I'got the Informant SNMP, the templates and scripts working... :-) They are all collecting data and consolidate all this to nice graphs...

I can't see any issues... right now.

Now i've got a question...

While doing a normal "add new device" i get this from a Windows 2008R2 x64....

(SNMP Informant Template)
Teredo Tunneling Pseudo-Interface
isatap.{4BC68530-9015-468C-B90B-1EC01D41438E}
Broadcom BCM5708C NetXtreme II GigE [NDIS VBD Client]
Broadcom BCM5708C NetXtreme II GigE [NDIS VBD Client] _2

But my Configuration is a teaming

(SNMP Cacti Template)

10 Up Broadcom BCM5708C NetXtreme II GigE (NDIS VBD Client ethernet_5 Team 1 ethernetCsmacd(6 1000000000 1000
11 Up Broadcom BCM5708C NetXtreme II GigE (NDIS VBD Client) #2 ethernet_9 Team 2 ethernetCsmacd(6 1000000000 1000

and i just want to get the networking data from the logical teaming interface

16 Up BASP Virtual Adapter ethernet_12 RAD LAN OE 450 ethernetCsmacd(6 1000000000 1000 00:21:5E:70:0F:D4 10.XXX:XXX:XXX

Would this be possible?
Server: IBM x3650 M3, 1 XEON CPU 3.0 GHz, 4 Core, 8GB RAM,
OS: Suse Linux 11.4 x64
Apache 2.x
MySQL 5.x
PHP 5.x
Plugins: DSStats, Settings, NMID Cereus Reporting, Spikekill
Install Date: May, 2011

Wed, 19 Oct 2011 13:46:36 +0200
Cacti Version 0.8.7g
Cacti OS unix
SNMP Version NET-SNMP version: 5.6.1
RRDTool Version RRDTool 1.4.x
Hosts 57
Graphs 716
Data Sources Script/Command: 15
SNMP: 166
SNMP Query: 310
Script Query: 4
Script - Script Server (PHP): 46
Script Query - Script Server: 319
Total: 860

Last Run Statistics Time:97.9035 Method:cmd.php Processes:10 Threads:N/A Hosts:58 HostsPerProcess:6 DataSources:3040 RRDsProcessed:860

Post Reply