WinXP-Win8, Win2000-Server 2012 x32/x64 Templates

Templates, scripts for templates, scripts and requests for templates.

Moderators: Moderators, Developers

Post Reply
Author
Message
Jeroma11
Posts: 2
Joined: Mon May 05, 2014 6:33 am

Re: WinXP-Win8, Win2000-Server 2012 x32/x64 Templates

#271 Post by Jeroma11 » Mon May 05, 2014 6:41 am

I have a little problem. When I setup a new datasource on my windows 2003 server R2 64 bits with Informant Cacti ask after the creation of datasource an input field for an index

Have I missed a step ?

Atreides
Cacti User
Posts: 150
Joined: Mon May 31, 2010 9:26 am

Re: WinXP-Win8, Win2000-Server 2012 x32/x64 Templates

#272 Post by Atreides » Thu Jul 03, 2014 10:05 am

Same problem here, I have a Windows 2012 Server with 32GB of Ram.

+ Running data query [23].
+ Found type = '3' [SNMP Query].
+ Found data query XML file at '/var/www/html/v3/resource/snmp_queries/snmp_informant_memory.xml'
+ XML file parsed ok.
+ <oid_num_indexes> missing in XML file, 'Index Count Changed' emulated by counting oid_index entries
+ Executing SNMP walk for list of indexes @ '.1.3.6.1.4.1.9600.1.1.2' Index Count: 40
+ Index found at OID: '1.3.6.1.4.1.9600.1.1.2.1.0' value: '2595594240'
+ Index found at OID: '1.3.6.1.4.1.9600.1.1.2.2.0' value: '10925312'
+ Index found at OID: '1.3.6.1.4.1.9600.1.1.2.3.0' value: '10669'
+ Index found at OID: '1.3.6.1.4.1.9600.1.1.2.4.0' value: '2702274560'
+ Index found at OID: '1.3.6.1.4.1.9600.1.1.2.5.0' value: '379092992'
+ Index found at OID: '1.3.6.1.4.1.9600.1.1.2.6.0' value: '593330176'
+ Index found at OID: '1.3.6.1.4.1.9600.1.1.2.7.0' value: '35'
+ Index found at OID: '1.3.6.1.4.1.9600.1.1.2.8.0' value: '0'
+ Index found at OID: '1.3.6.1.4.1.9600.1.1.2.9.0' value: '0'
+ Index found at OID: '1.3.6.1.4.1.9600.1.1.2.10.0' value: '0'
+ Index found at OID: '1.3.6.1.4.1.9600.1.1.2.11.0' value: '135323648'
+ Index found at OID: '1.3.6.1.4.1.9600.1.1.2.12.0' value: '408879104'
+ Index found at OID: '1.3.6.1.4.1.9600.1.1.2.13.0' value: '403861504'
+ Index found at OID: '1.3.6.1.4.1.9600.1.1.2.14.0' value: '379092992'
+ Index found at OID: '1.3.6.1.4.1.9600.1.1.2.15.0' value: '12738560'
+ Index found at OID: '1.3.6.1.4.1.9600.1.1.2.16.0' value: '0'
+ Index found at OID: '1.3.6.1.4.1.9600.1.1.2.17.0' value: '8916992'
+ Index found at OID: '1.3.6.1.4.1.9600.1.1.2.18.0' value: '10649600'
+ Index found at OID: '1.3.6.1.4.1.9600.1.1.2.19.0' value: '23610460'
+ Index found at OID: '1.3.6.1.4.1.9600.1.1.2.20.0' value: '370208'
+ Index found at OID: '1.3.6.1.4.1.9600.1.1.2.21.0' value: '579424'
+ Index found at OID: '1.3.6.1.4.1.9600.1.1.2.22.0' value: '132152'
+ Index found at OID: '1.3.6.1.4.1.9600.1.1.2.23.0' value: '399296'
+ Index found at OID: '1.3.6.1.4.1.9600.1.1.2.24.0' value: '394396'
+ Index found at OID: '1.3.6.1.4.1.9600.1.1.2.25.0' value: '370208'
+ Index found at OID: '1.3.6.1.4.1.9600.1.1.2.26.0' value: '12440'
+ Index found at OID: '1.3.6.1.4.1.9600.1.1.2.27.0' value: '0'
+ Index found at OID: '1.3.6.1.4.1.9600.1.1.2.28.0' value: '8708'
+ Index found at OID: '1.3.6.1.4.1.9600.1.1.2.29.0' value: '10400'
+ Index found at OID: '1.3.6.1.4.1.9600.1.1.2.30.0' value: '23057'
+ Index found at OID: '1.3.6.1.4.1.9600.1.1.2.31.0' value: '361'
+ Index found at OID: '1.3.6.1.4.1.9600.1.1.2.32.0' value: '565'
+ Index found at OID: '1.3.6.1.4.1.9600.1.1.2.33.0' value: '129'
+ Index found at OID: '1.3.6.1.4.1.9600.1.1.2.34.0' value: '389'
+ Index found at OID: '1.3.6.1.4.1.9600.1.1.2.35.0' value: '385'
+ Index found at OID: '1.3.6.1.4.1.9600.1.1.2.36.0' value: '361'
+ Index found at OID: '1.3.6.1.4.1.9600.1.1.2.37.0' value: '12'
+ Index found at OID: '1.3.6.1.4.1.9600.1.1.2.38.0' value: '0'
+ Index found at OID: '1.3.6.1.4.1.9600.1.1.2.39.0' value: '8'
+ Index found at OID: '1.3.6.1.4.1.9600.1.1.2.40.0' value: '10'
+ Located input field 'memory' [walk]
+ Executing SNMP walk for data @ '.1.3.6.1.4.1.9600.1.1.2'
+ Found item [memory='2596491264'] index: 0 [from value]
+ Found item [memory='10924244'] index: 0 [from value]
+ Found item [memory='10668'] index: 0 [from value]
+ Found item [memory='2704809984'] index: 0 [from value]
+ Found item [memory='379297792'] index: 0 [from value]
+ Found item [memory='593330176'] index: 0 [from value]
+ Found item [memory='35'] index: 0 [from value]
+ Found item [memory='0'] index: 0 [from value]
+ Found item [memory='0'] index: 0 [from value]
+ Found item [memory='0'] index: 0 [from value]
+ Found item [memory='135323648'] index: 0 [from value]
+ Found item [memory='408883200'] index: 0 [from value]
+ Found item [memory='403861504'] index: 0 [from value]
+ Found item [memory='379297792'] index: 0 [from value]
+ Found item [memory='12738560'] index: 0 [from value]
+ Found item [memory='0'] index: 0 [from value]
+ Found item [memory='8916992'] index: 0 [from value]
+ Found item [memory='10649600'] index: 0 [from value]
+ Found item [memory='23612936'] index: 0 [from value]
+ Found item [memory='370408'] index: 0 [from value]
+ Found item [memory='579424'] index: 0 [from value]
+ Found item [memory='132152'] index: 0 [from value]
+ Found item [memory='399300'] index: 0 [from value]
+ Found item [memory='394396'] index: 0 [from value]
+ Found item [memory='370408'] index: 0 [from value]
+ Found item [memory='12440'] index: 0 [from value]
+ Found item [memory='0'] index: 0 [from value]
+ Found item [memory='8708'] index: 0 [from value]
+ Found item [memory='10400'] index: 0 [from value]
+ Found item [memory='23059'] index: 0 [from value]
+ Found item [memory='361'] index: 0 [from value]
+ Found item [memory='565'] index: 0 [from value]
+ Found item [memory='129'] index: 0 [from value]
+ Found item [memory='389'] index: 0 [from value]
+ Found item [memory='385'] index: 0 [from value]
+ Found item [memory='361'] index: 0 [from value]
+ Found item [memory='12'] index: 0 [from value]
+ Found item [memory='0'] index: 0 [from value]
+ Found item [memory='8'] index: 0 [from value]
+ Found item [memory='10'] index: 0 [from value]


PS : Also I cant import the latest templates(XML parse error), tried multiple times/downloads/servers. I'm using the "original files".

jbossert
Posts: 3
Joined: Thu Jan 26, 2012 2:04 pm

Re: WinXP-Win8, Win2000-Server 2012 x32/x64 Templates

#273 Post by jbossert » Wed Jul 16, 2014 1:18 pm

Hi,

any idea why all my preview pictures are broken for informant statistics only (regular snmp is fine !)

when i click on the broken image i can see the full size graph, but it is annoying !

thanks,
Attachments
snmp_informant.jpg
snmp_informant.jpg (11.76 KiB) Viewed 7479 times

lan9203
Posts: 3
Joined: Tue Jul 22, 2014 2:17 am

Re: WinXP-Win8, Win2000-Server 2012 x32/x64 Templates

#274 Post by lan9203 » Tue Jul 22, 2014 2:27 am

help!
cacti 0.8.8b

Data Query Debug Information
+ Running data query [13].
+ Found type = '3' [SNMP Query].
+ Found data query XML file at '/www/cacti/resource/snmp_queries/snmp_informant_network.xml'
+ XML file parsed ok.
+ <oid_num_indexes> missing in XML file, 'Index Count Changed' emulated by counting oid_index entries
+ Executing SNMP walk for list of indexes @ '.1.3.6.1.4.1.9600.1.1.3.1.1' Index Count: 0
+ No SNMP data returned

User avatar
phalek
Cacti Guru User
Posts: 2724
Joined: Thu Jan 31, 2008 6:39 am
Location: Kressbronn, Germany
Contact:

Re: WinXP-Win8, Win2000-Server 2012 x32/x64 Templates

#275 Post by phalek » Tue Jul 22, 2014 2:44 am

Do your system have the SNMP Informant agent installed at all ?
Greetings,
Phalek
---
Need more help ? Read the Cacti documentation or my new Cacti 1.x Book
Need on-site support ? Look here Cacti Workshop
Need professional Cacti support ? Look here CereusService
---
Plugins : CereusTransporter | CereusReporting | nmidWebService | nmidSmokeping | nmidWeb2 |

Code: Select all

CereusServer Master:  SYSTEM STATS: Time:2.5621 Method:spine Processes:1 Threads:16 Hosts:446 HostsPerProcess:446 DataSources:14683 RRDsProcessed:7573
CereusServer Agent:   SYSTEM STATS: Time:27.4840 Method:spine Processes:1 Threads:8 Hosts:16 HostsPerProcess:16 DataSources:114576 RRDsProcessed:48061
[/size]

lan9203
Posts: 3
Joined: Tue Jul 22, 2014 2:17 am

Re: WinXP-Win8, Win2000-Server 2012 x32/x64 Templates

#276 Post by lan9203 » Tue Jul 22, 2014 3:39 am

snmpwalk -v 2c 192.168.1.18 -c public .1.3.6.1.4.1.9600.1.1.3.1.1
SNMPv2-SMI::enterprises.9600.1.1.3.1.1 = No more variables left in this MIB View (It is past the end of the MIB tree)

Agent client os: Microsoft Windows Server 2003 Enterprise Edition Service Pack 2

I have installed informant-std-16 and open the snmp server.

lan9203
Posts: 3
Joined: Tue Jul 22, 2014 2:17 am

Re: WinXP-Win8, Win2000-Server 2012 x32/x64 Templates

#277 Post by lan9203 » Tue Jul 22, 2014 3:41 am

phalek wrote:Do your system have the SNMP Informant agent installed at all ?
snmpwalk -v 2c 192.168.1.18 -c public .1.3.6.1.4.1.9600.1.1.3.1.1
SNMPv2-SMI::enterprises.9600.1.1.3.1.1 = No more variables left in this MIB View (It is past the end of the MIB tree)

Agent client os: Microsoft Windows Server 2003 Enterprise Edition Service Pack 2

I have installed informant-std-16 and open the snmp server.

epiclulz666
Posts: 1
Joined: Tue Aug 19, 2014 7:09 pm

Re: WinXP-Win8, Win2000-Server 2012 x32/x64 Templates

#278 Post by epiclulz666 » Tue Aug 19, 2014 7:19 pm

pulling my hair out trying to get this working


at the moment i have snmp agent installed on server 2008 R2 Datacentre edition

i was able to get Ethernet statistics working and its also graphing number of running programs that run via MIB templates
... but i am unable to get any of the informant graphs to work

in the

Verbose Query shows


Data Query Debug Information
+ Running data query [12].
+ Found type = '3' [SNMP Query].
+ Found data query XML file at 'C:/Apache24/htdocs/cacti/resource/snmp_queries/snmp_informant_standard_cpu.xml'
+ Error parsing XML file into an array.
+ Found data query XML file at 'C:/Apache24/htdocs/cacti/resource/snmp_queries/snmp_informant_standard_cpu.xml'
+ Found data query XML file at 'C:/Apache24/htdocs/cacti/resource/snmp_queries/snmp_informant_standard_cpu.xml'
+ Found data query XML file at 'C:/Apache24/htdocs/cacti/resource/snmp_queries/snmp_informant_standard_cpu.xml'


but all of the data sources for informant show

Data Query [SNMP_Informant_Standard - CPU Statistics]
Error in data query.

Data Query [SNMP_Informant_Standard - Disk Statistics]
Error in data query.
Select a graph type:

Data Query [SNMP_Informant_Standard - Memory Statistics]
Error in data query.
Select a graph type:

Data Query [SNMP_Informant_Standard - Network Statistics]
Error in data query.
Select a graph type:

Data Query [SNMP_Informant_Standard - Objects Statistics]
Error in data query.

what am i doing wrong guys

xq1
Posts: 3
Joined: Sun Oct 05, 2014 9:34 pm

Re: WinXP-Win8, Win2000-Server 2012 x32/x64 Templates

#279 Post by xq1 » Sun Oct 05, 2014 9:40 pm

I must be blind - can somewhere show me were to download these templates?

Thanx!

blinker86
Posts: 2
Joined: Wed Feb 25, 2015 11:04 am

Re: WinXP-Win8, Win2000-Server 2012 x32/x64 Templates

#280 Post by blinker86 » Wed Feb 25, 2015 11:10 am

Hi!
I following the instrucion of this page:

http://everythingshouldbevirtual.com/ca ... ws-servers

But when I want to import cacti_host_template_snmp_informant_windows.xml I have a problem:

Error: XML parse error.

Image

can you help me?

dmcit
Posts: 1
Joined: Fri Mar 13, 2015 9:39 am

Re: WinXP-Win8, Win2000-Server 2012 x32/x64 Templates

#281 Post by dmcit » Fri Mar 13, 2015 9:41 am

I am having the exact same error, results in empty host and graph templates in the lists. Any solution for this?

Version 0.8.7i

** UPDATE **

After fiddling around, I am now getting a different error:

Error: XML: Hash version does not exist. which I gather is a version issue. I have updated by forcing apt to pull from the latest repo using steps similar to this:
http://linux-surfing.blogspot.ca/2013/1 ... -1204.html

blinker86
Posts: 2
Joined: Wed Feb 25, 2015 11:04 am

Re: WinXP-Win8, Win2000-Server 2012 x32/x64 Templates

#282 Post by blinker86 » Fri Mar 13, 2015 10:45 am

dmcit wrote:
After fiddling around, I am now getting a different error:

Error: XML: Hash version does not exist. which I gather is a version issue. I have updated by forcing apt to pull from the latest repo using steps similar to this:
http://linux-surfing.blogspot.ca/2013/1 ... -1204.html
What did you do?

sharkys
Posts: 12
Joined: Sun Oct 05, 2008 11:17 am

Re: WinXP-Win8, Win2000-Server 2012 x32/x64 Templates

#283 Post by sharkys » Mon Mar 30, 2015 2:48 pm

lan9203 wrote:
phalek wrote:Do your system have the SNMP Informant agent installed at all ?
snmpwalk -v 2c 192.168.1.18 -c public .1.3.6.1.4.1.9600.1.1.3.1.1
SNMPv2-SMI::enterprises.9600.1.1.3.1.1 = No more variables left in this MIB View (It is past the end of the MIB tree)

Agent client os: Microsoft Windows Server 2003 Enterprise Edition Service Pack 2

I have installed informant-std-16 and open the snmp server.
I was fighting with this problem as well, also on Windows 2003 Server and the fix seems to be very easy :

- launch on Windows Server 2003 following command (it will run quite long, several minutes, showing no activity nor results)

Code: Select all

lodctr /R
- restart snmp service

Miyun
Posts: 1
Joined: Tue Mar 31, 2015 5:07 pm

Re: WinXP-Win8, Win2000-Server 2012 x32/x64 Templates

#284 Post by Miyun » Tue Mar 31, 2015 6:00 pm

I'm also having trouble with this on a Windows Server 2008 R2 machine. I've followed the guide completely from here: http://everythingshouldbevirtual.com/ca ... ws-servers

SNMP seems to be working on both ends, but I'm not getting any data populated in the graphs. Can someone please help me troubleshoots this?

Thank you
Attachments
Screen Shot 2015-03-31 at 3.53.48 PM.png
Screen Shot 2015-03-31 at 3.53.48 PM.png (168.93 KiB) Viewed 6208 times
Screen Shot 2015-03-31 at 3.52.14 PM.png
Screen Shot 2015-03-31 at 3.52.14 PM.png (390.34 KiB) Viewed 6208 times
Screen Shot 2015-03-31 at 3.51.44 PM.png
Screen Shot 2015-03-31 at 3.51.44 PM.png (231.33 KiB) Viewed 6208 times

undertoe
Posts: 10
Joined: Wed May 19, 2004 7:34 pm
Contact:

Re: WinXP-Win8, Win2000-Server 2012 x32/x64 Templates

#285 Post by undertoe » Thu Apr 23, 2015 8:25 am

I have all the graphs working except network and memory. Memory just gives me a Paging option. Is this normal? Traffic for the network card is a dead image.

https://db.tt/8h2wgwgl

Post Reply