Error to build graph

Templates, scripts for templates, scripts and requests for templates.

Moderators: Moderators, Developers

Post Reply
Author
Message
Versolato
Posts: 2
Joined: Wed Nov 28, 2012 10:28 am

Error to build graph

#1 Post by Versolato » Wed Nov 28, 2012 10:55 am

I'm having trouble with graphics. I am trying to monitor a Canopy SM. I tried to create graphics to Jitter using OID ".1.3.6.1.4.1.161.19.3.2.2.3.0" and ".1.3.6.1.4.1. 161.19.3.2.2.21.0" to RSSI.

The graphic was created to RSSI normally but not to Jitter. I set Jitter OID on RSSI OID field and the graphic was created.

All templates are identical, I changed only the OID number.

The Jitter file was not created.

{
RRDTool Command:

/usr/bin/rrdtool graph - \
--imgformat=PNG \
--start=-86400 \
--end=-60 \
--title='sm - SM - RSSI' \
--base=1000 \
--height=120 \
--width=500 \
--alt-autoscale-max \
--lower-limit='0' \
--vertical-label='' \
--slope-mode \
--font TITLE:10: \
--font AXIS:7: \
--font LEGEND:8: \
--font UNIT:7: \
DEF:a="/usr/share/cacti/rra/sm_rssi_161.rrd":'rssi':AVERAGE \
AREA:a#00FF00FF:"" \
GPRINT:a:LAST:"Current\:%8.2lf %s" \
GPRINT:a:AVERAGE:"Average\:%8.2lf %s" \
GPRINT:a:MAX:"Max\:%8.2lf %s" \
GPRINT:a:MIN:"Min\:%8.2lf %s" RRDTool Says:

ERROR: opening '/usr/share/cacti/rra/sm_rssi_161.rrd': No such file or directory
}

What is happening ?

User avatar
Linegod
Developer
Posts: 1630
Joined: Thu Feb 20, 2003 10:16 am
Location: Canada
Contact:

Re: Error to build graph

#2 Post by Linegod » Thu Nov 29, 2012 9:15 pm

Can you get the result by doing an snmpget or snmpwalk?
--
Live fast, die young
You're sucking up my bandwidth.

J.P. Pasnak,CD
CCNA, LPIC-1
http://www.warpedsystems.sk.ca

Post Reply