IBM BladeCenter H template

Templates, scripts for templates, scripts and requests for templates.

Moderators: Moderators, Developers

Author
Message
virus84
Posts: 20
Joined: Thu Nov 01, 2007 2:23 am
Location: Jönköping

IBM BladeCenter H template

#1 Post by virus84 » Sun Oct 24, 2010 3:06 pm

Hello i have made a host template for IBM BladeCenter H chassis. I head mutch help from this thread

http://forums.cacti.net/about17708.html .

This template addes the posibilitys to graph the values listed below.

- Temperature of the chassi in/out
- Power usage per blade slot
- Power usage per power domain
- Power usage per fan pack
- Power usage per I/O module
- Power usage per managemnt module
- Voltage for +1,8V, +12V, +2,5V, +3,3V and +5V
- Thermal output (BTU/Hour)
- Fan speed both in porcentage and RPM

This template was tested on a IBM BladCenter H (MT: 8852xxx there X can be a bit diffrent.). Some values works on IBM BladeCenter E to but most dont. Headent have time to develop it for E chassis yet. The template is exported from cacti 0.8.7e.

I hope some have some use for the template. If you have any questions about the template dont hasetat to ask me :) . And a big thanks for the authers of the base of this template from the abow thred this is only a extended version. Sorry if my english is a bit out of line :).

Regards
Magnus
Attachments
cacti_host_template_ibm_bladecenter-h_v1.1.xml
(420.63 KiB) Downloaded 697 times
ibm_bladecenter_mgmt_module_power_usage.JPG
ibm_bladecenter_mgmt_module_power_usage.JPG (38.2 KiB) Viewed 10330 times
ibm_bladecenter_io_module_power_usage.JPG
ibm_bladecenter_io_module_power_usage.JPG (63.48 KiB) Viewed 10330 times
ibm_bladecenter_fan_pack_power_usage_pd1.JPG
ibm_bladecenter_fan_pack_power_usage_pd1.JPG (43.71 KiB) Viewed 10330 times
ibm_bladecenter_blade_power_usage.JPG
ibm_bladecenter_blade_power_usage.JPG (42.86 KiB) Viewed 10330 times

User avatar
Linegod
Developer
Posts: 1630
Joined: Thu Feb 20, 2003 10:16 am
Location: Canada
Contact:

Re: IBM BladeCenter H template

#2 Post by Linegod » Sun Oct 24, 2010 11:38 pm

If you get a chance, post it to the template repository:

http://docs.cacti.net/templates
http://docs.cacti.net/templates.guidelines
--
Live fast, die young
You're sucking up my bandwidth.

J.P. Pasnak,CD
CCNA, LPIC-1
http://www.warpedsystems.sk.ca

virus84
Posts: 20
Joined: Thu Nov 01, 2007 2:23 am
Location: Jönköping

Re: IBM BladeCenter H template

#3 Post by virus84 » Mon Oct 25, 2010 2:23 pm

Added it to the template reposetory

http://docs.cacti.net/usertemplate:host ... decenter_h

Regards
Magnus

User avatar
Linegod
Developer
Posts: 1630
Joined: Thu Feb 20, 2003 10:16 am
Location: Canada
Contact:

Re: IBM BladeCenter H template

#4 Post by Linegod » Tue Oct 26, 2010 12:31 am

Excellent. Thanks.
--
Live fast, die young
You're sucking up my bandwidth.

J.P. Pasnak,CD
CCNA, LPIC-1
http://www.warpedsystems.sk.ca

itms
Posts: 1
Joined: Fri Feb 25, 2011 6:04 am

Re: IBM BladeCenter H template

#5 Post by itms » Fri Feb 25, 2011 7:36 am

Hi, guys


have you a idea on my issue?
I uploaded the template "cacti_host_template_ibm_bladecenter_h_v1.1.zip" and i assigned on device in cacti but my graph is blank.
After collectin about my issue on google , it seems that lack a data source for cacti

Could you tell me where i can download that or the link for create the datasource ?

below my setting snmp on my bladecenter Management Module ( serie H and S )

Snmp agent V1 enable

Community:Mycommunity AccesType:Get Hostname or Ip: Mycacti

virus84
Posts: 20
Joined: Thu Nov 01, 2007 2:23 am
Location: Jönköping

Re: IBM BladeCenter H template

#6 Post by virus84 » Mon Mar 21, 2011 12:46 pm

Hello

I goten some emails about problems with the template. It seams that the template have some problems on Cacti 0.8.7g. I alsow have the problem and cant figur out what the problem is. I maybe have a ide what the problem is but need some help.

I noticed in 0.8.7e i get results like the one below

03/21/2011 06:13:22 PM - CMDPHP: Poller[0] Host[87] DS[3159] SNMP: v1: 172.24.4.205, dsname: bc_pwr_usg_pd1_slo1, oid: .1.3.6.1.4.1.2.3.51.2.2.10.2.1.1.7.17, output: 129

And the same respons in 0.8.7g is the one below

03/21/2011 06:43:14 PM - SPINE: Poller[0] Host[3] TH[1] DS[125] SNMP: v1: 172.24.4.205, dsname: bc_pwr_usg_pd1_slo1, oid: .1.3.6.1.4.1.2.3.51.2.2.10.2.1.1.7.17, value: 133W

I gues cacti cant handel the valus then it says like in the exampel abow then the value is 133W insted of only 133?
Is it possible to change a setting in the template maybe so cacti can understand the valus that it gets from SNMP?
Almost all valus is presented with some kind of unit like W, V and some other.

Or can this be a spine problem? The 0.8.7e install im using cmdphp to poll and the new 0.8.7g is using spine as you can see in the logoutput abow.

EDIT: I tryed changing from spine to cmd.php as poller and it works i see in the log it removes the W and other units from the SNMP answer. Is that possible to fix so i can use spine to do the same? Happy for any help here :).

Can somone maybe help out if there is a solution to this problem.

Thanks in advace.

Regards
Magnus

jflanda
Posts: 2
Joined: Thu Aug 07, 2008 7:18 am

Re: IBM BladeCenter H template

#7 Post by jflanda » Wed Aug 10, 2011 2:44 am

Hello.

I am having the same problem with spine 0.8.6g and this template. Have anyone found a solution?

Thanks.

virus84
Posts: 20
Joined: Thu Nov 01, 2007 2:23 am
Location: Jönköping

Re: IBM BladeCenter H template

#8 Post by virus84 » Mon Dec 12, 2011 10:13 am

Hello

I still have problems with spine and that it dont handel the SNMP data. As said before here in the thread. I installed the new release today of 0.8.7i of cacti + spine.
Still have the same problem. Gone include some pictures.

Picture 1: Showes that the values work with fan speed in rpm using spine.
Picture 2: Showes that then getting the values as percentage it dont get any info
Picture 3: Showes that the data for the RPM graph is only a plane number like 3680 for exampel.
Picture 4: Shoews that spine cant update the rras only the once goten only numeric values. Cant updated the once contauing more text.
Picture 5: Shoews that then i change to cmd.php as poller insted both works and the graphs work fine.

Why does doesen´t spine handel the text like cmd.php it seams for exampel in picture 3 that spine keep the text "% of maximum" then using cmd.php it removes it and can insert it into the RRA.
Any sugestions what can be wrong. Hope someone have any ide how to fix it.

Sorry for a bit bad english.

Thanks in advanc
Regards
Magnus
Attachments
5_ibm_bladecenter_h_fan_speed_cacti_log_output_cmd_poller.JPG
Picture 5
5_ibm_bladecenter_h_fan_speed_cacti_log_output_cmd_poller.JPG (75.33 KiB) Viewed 9250 times
4_ibm_bladecenter_h_fan_speed_cacti_log_output_rrdtool_update.JPG
Picture 4
4_ibm_bladecenter_h_fan_speed_cacti_log_output_rrdtool_update.JPG (53.85 KiB) Viewed 9250 times
3_ibm_bladecenter_h_fan_speed_cacti_log_output.JPG
Picture 3
3_ibm_bladecenter_h_fan_speed_cacti_log_output.JPG (42.36 KiB) Viewed 9250 times
2_ibm_bladecenter_h_fan_speed_rpm.JPG
Picture 2
2_ibm_bladecenter_h_fan_speed_rpm.JPG (44.94 KiB) Viewed 9250 times
1_ibm_bladecenter_h_fan_speed_procents.JPG
Picture 1
1_ibm_bladecenter_h_fan_speed_procents.JPG (39.57 KiB) Viewed 9250 times

User avatar
TheWitness
Developer
Posts: 14817
Joined: Tue May 14, 2002 5:08 pm
Location: MI, USA
Contact:

Re: IBM BladeCenter H template

#9 Post by TheWitness » Mon Dec 12, 2011 7:48 pm

This is 'i' spine?
True understanding begins only when we realize how little we truly understand...

Life is an adventure, let yours begin with Cacti!

Author of MacTrack, Boost, CLog, SpikeKill, Platform RTM, DSStats, maintainer of Spine, lot's of unpublished work and most of Cacti's bugs.
_________________
Official Cacti Documentation
GitHub Repository with Supported Plugins
Central Plugin Repository
Central Templates Repository


I'm still out there people. Getting excited for Cacti 1.2. I think it will be a great release.

virus84
Posts: 20
Joined: Thu Nov 01, 2007 2:23 am
Location: Jönköping

Re: IBM BladeCenter H template

#10 Post by virus84 » Tue Dec 13, 2011 2:17 am

Hello

Yes its Cacti 0.8.7i and Spine 0.8.7i. Have head this problems since maybe 0.8.7e or 0.8.7g.

Regards
Magnus

User avatar
TheWitness
Developer
Posts: 14817
Joined: Tue May 14, 2002 5:08 pm
Location: MI, USA
Contact:

Re: IBM BladeCenter H template

#11 Post by TheWitness » Tue Dec 13, 2011 9:42 am

Use the attached 'instrumented' binary side band, in other words, not in production. When running, do the following:

Code: Select all

./spine -R -V 3 -S -f <host_id> -l <host_id>
Where the host_id is the host_id of the host that needs stripping. Attach the output for review.

TheWitness
Attachments
poller.zip
(11.53 KiB) Downloaded 238 times
True understanding begins only when we realize how little we truly understand...

Life is an adventure, let yours begin with Cacti!

Author of MacTrack, Boost, CLog, SpikeKill, Platform RTM, DSStats, maintainer of Spine, lot's of unpublished work and most of Cacti's bugs.
_________________
Official Cacti Documentation
GitHub Repository with Supported Plugins
Central Plugin Repository
Central Templates Repository


I'm still out there people. Getting excited for Cacti 1.2. I think it will be a great release.

virus84
Posts: 20
Joined: Thu Nov 01, 2007 2:23 am
Location: Jönköping

Re: IBM BladeCenter H template

#12 Post by virus84 » Tue Dec 13, 2011 10:13 am

Hello

How do i compile the file in the zip file? host_id is that an IP or a file name?

Regards
Magnus

virus84
Posts: 20
Joined: Thu Nov 01, 2007 2:23 am
Location: Jönköping

Re: IBM BladeCenter H template

#13 Post by virus84 » Tue Dec 13, 2011 10:28 am

Hello again

I put the poller.c in the spine src dir from 0.8.7i folder replacing the original. Compiled the binary as youre documentation said and installed it. Se below a log from cacti. Dont know if it helps. I have a totaly isolated cacti install so i replaced the old one. Hope it shoews you somthing that can help.

Regards
Magnus
Attachments
log_from_new_spine_binary.JPG
log_from_new_spine_binary.JPG (662.35 KiB) Viewed 9233 times

User avatar
TheWitness
Developer
Posts: 14817
Joined: Tue May 14, 2002 5:08 pm
Location: MI, USA
Contact:

Re: IBM BladeCenter H template

#14 Post by TheWitness » Tue Dec 13, 2011 6:23 pm

You need to follow my instructions to the letter. What you posted means nothing...
True understanding begins only when we realize how little we truly understand...

Life is an adventure, let yours begin with Cacti!

Author of MacTrack, Boost, CLog, SpikeKill, Platform RTM, DSStats, maintainer of Spine, lot's of unpublished work and most of Cacti's bugs.
_________________
Official Cacti Documentation
GitHub Repository with Supported Plugins
Central Plugin Repository
Central Templates Repository


I'm still out there people. Getting excited for Cacti 1.2. I think it will be a great release.

virus84
Posts: 20
Joined: Thu Nov 01, 2007 2:23 am
Location: Jönköping

Re: IBM BladeCenter H template

#15 Post by virus84 » Wed Dec 14, 2011 2:07 am

Hello again and sorry for doing it wrong. Hope this is the right way.
Check the image below. I took the ID from Console > Devices and the ID for the device. Hope it can tell you something usefull.

Regards
Magnus
Attachments
spine-output.JPG
spine-output
spine-output.JPG (100.09 KiB) Viewed 9220 times

Post Reply