Cacti (home)ForumsDocumentation
Cacti: offical forums and support
It is currently Mon Jun 17, 2019 2:36 am

All times are UTC - 5 hours




Post new topic Reply to topic  [ 3 posts ] 
Author Message
 Post subject: NetApp Interface Template for Cacti
PostPosted: Tue Feb 05, 2008 12:29 pm 
Offline

Joined: Tue Feb 05, 2008 12:20 pm
Posts: 1
Location: Seattle, WA
NetApp Interfaces are a serious pain, and even after the netapp engineers posted about how cool cacti is, they still are not able to come up with a workable template for their whacked out mib. I have worked through the mibs, and created some CDEF functions to add the high and low bits for gig-e interfaces ((high_bit*4294967296) + low). But the graphs do not look right, they jump up and down by 100MB nearly every poll. If anyone has any idea why this might be please post here. Import the cacti_host_template_netapp.xml into cacti, and put the netapp_interface.xml file in ~cacti/resources/snmp_queries/


Attachments:
graph_image.png
graph_image.png [ 36.79 KiB | Viewed 8761 times ]
cacti_interface_template.tar.gz [10.94 KiB]
Downloaded 1090 times
Top
 Profile  
 
 Post subject:
PostPosted: Tue Feb 05, 2008 3:37 pm 
Offline
Cacti Guru User
User avatar

Joined: Fri Sep 19, 2003 8:36 am
Posts: 2326
Location: Sophia-Antipolis, France
Moving to the Templates forum.

_________________

HOWTOs :
Templates :


Top
 Profile  
 
 Post subject: Re: NetApp Interface Template for Cacti
PostPosted: Fri Feb 27, 2009 3:12 pm 
Offline

Joined: Wed Jan 31, 2007 3:56 pm
Posts: 3
Location: Austin, TX
andreas,

I've been looking at this problem and I think I've found part of an explanation, but haven't figured out how to make things work out correctly. From the rrdcreate manpage:

COUNTER
is for continuous incrementing counters like the ifInOctets
counter in a router. The COUNTER data source assumes that the
counter never decreases, except when a counter overflows. The
update function takes the overflow into account. The counter
is stored as a per-second rate. When the counter overflows,
RRDtool checks if the overflow happened at the 32bit or 64bit
border and acts accordingly by adding an appropriate value to
the result.


(emphasis mine). So what needs to happen is for the RRD file to *not* add that "appropriate value" to the low counters. I'm think that removing the Maximum Value setting from the low counters would do it, but that seems to be difficult without re-implementing the data template. Another possibility is to change the data type to "GAUGE" instead of "COUNTER". I'll keep working on it.

HTH,

-=Tom Nail


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 3 posts ] 

All times are UTC - 5 hours


Who is online

Users browsing this forum: Google Adsense [Bot] and 9 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  

Protected by Anti-Spam ACP Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group