Cisco CSS SNMP rosetta stone

Templates, scripts for templates, scripts and requests for templates.

Moderators: Moderators, Developers

Author
Message
User avatar
cdukes
Cacti User
Posts: 61
Joined: Tue Mar 26, 2002 1:25 pm
Location: Morrisville, NC
Contact:

Any updates to this?

#31 Post by cdukes » Fri Aug 04, 2006 5:55 pm

Has anyone been able to create a good template for the CSS's?
I tried using the previously posted template, but get errors in the data query.

Any help would be super :-)

User avatar
TFC
Cacti Pro User
Posts: 722
Joined: Wed Apr 09, 2003 2:17 am
Location: Izmir/Turkey

#32 Post by TFC » Tue Sep 05, 2006 5:37 am

egironda wrote:Here ya go... warning that of course this includes dependancies, so it may clobber anything of your own. I don't have any custom rrds, but you may want to back things up regardless before import.
Hi,
Is there any order to import these templates?
because I get some messages when I try to import templates like this:
Unmet Dependency: bla bla bla
One more thing,
When I check the data queries, I find two data queries about CSS:
CSS Connections
CSS Service State
In CSS Connections preferences, XML paths shows a xml file as css-conns.xml but there is no file as this name in your attachement.
Again, CSS Service State shown another xml files that is css-status.xml and this file not shown in template attachement.
Is there any update about that?

User avatar
Pumpi
Cacti User
Posts: 256
Joined: Wed Jan 14, 2004 3:23 am
Location: Germany

Missing XML files

#33 Post by Pumpi » Thu Oct 05, 2006 3:39 am

egironda wrote:Here are the ones I'm using. I cobbled these together from both posts on the forums here, and my own investigations... I can't remember what thread I found the ones that set me on the right track in - but, props to them.
Hello egironda,

nice work !

I found that following data query XML files are missing:

* css-status.xml
* css-conns.xml


Can you share this too ?

Thanks

Pumpi

Jeb
Posts: 38
Joined: Tue May 24, 2005 2:50 am

#34 Post by Jeb » Thu Oct 26, 2006 7:15 am

I made css-status.xml and css-conns.xml file

I hope they are correct and should work but i did not get them working because when a create a new graph, rrd files are not created.
I did not find why for the moment, may be there is an error in others files supllied in the css.zip ?

I will try to find what append but it would be cool if someone check ;)
Attachments
css-conns.xml
(1.03 KiB) Downloaded 947 times
css-status.xml
(1.02 KiB) Downloaded 893 times

User avatar
Pumpi
Cacti User
Posts: 256
Joined: Wed Jan 14, 2004 3:23 am
Location: Germany

#35 Post by Pumpi » Thu Nov 02, 2006 10:43 am

jeb,

thanks for these two missing files.

Pumpi

gl2000
Posts: 4
Joined: Fri Dec 08, 2006 4:02 am

#36 Post by gl2000 » Fri Dec 08, 2006 4:24 am

I have made a stab at fixing the errors in this template and have hopefully managed it.

I have also added Memory Usage, DOS Attacks and the Max Connection value to the Service Hits.
Attachments
CSS-NEW.zip
(64.09 KiB) Downloaded 777 times

User avatar
ScOp3
Cacti User
Posts: 61
Joined: Wed Aug 03, 2005 4:14 am
Location: Cologne Germany
Contact:

#37 Post by ScOp3 » Fri Dec 08, 2006 7:08 am

gl2000 wrote:I have made a stab at fixing the errors in this template and have hopefully managed it.

I have also added Memory Usage, DOS Attacks and the Max Connection value to the Service Hits.
Sounds great. Which version did you use to export the templates? I get the "famous" hash version error.
fear leads to anger, anger leads to hate and dancing leads to sex!

gl2000
Posts: 4
Joined: Fri Dec 08, 2006 4:02 am

#38 Post by gl2000 » Fri Dec 08, 2006 7:52 am

I used Cacti version 0.8.6i

User avatar
ScOp3
Cacti User
Posts: 61
Joined: Wed Aug 03, 2005 4:14 am
Location: Cologne Germany
Contact:

#39 Post by ScOp3 » Fri Dec 08, 2006 9:36 am

gl2000 wrote:I used Cacti version 0.8.6i
Then i have to upgrade my installation first. This version hash check really sucks. Don't know why it is necessary at all. Thanks for you're swift reply.

ScOp3
fear leads to anger, anger leads to hate and dancing leads to sex!

kitkit201
Posts: 40
Joined: Mon Jun 20, 2005 6:32 pm

#40 Post by kitkit201 » Mon Dec 11, 2006 7:05 pm

is anyone else running the CSS-new.zip file uploaded by Gl2000 on a 11501 version 8.1 .. I got all the verbose queries to query, but when looking at the graphs, it shows values as NAN, but it did create the graphs.

kitkit201
Posts: 40
Joined: Mon Jun 20, 2005 6:32 pm

#41 Post by kitkit201 » Mon Dec 11, 2006 7:30 pm

kitkit201 wrote:is anyone else running the CSS-new.zip file uploaded by Gl2000 on a 11501 version 8.1 .. I got all the verbose queries to query, but when looking at the graphs, it shows values as NAN, but it did create the graphs.
Nevermind, i screwed up myself. I forgot to copy over the 4 .xml files over to the snmp_queries directory BEFORE creating graphs.. I ended up deleting the device alltogether and recreating it and all is well..

Note to everyone.. have everything ready before jumping ;)

thierry.chich
Posts: 24
Joined: Tue Jun 14, 2005 7:58 am

#42 Post by thierry.chich » Tue Dec 12, 2006 9:48 am

I just try this fine package. It's a very good work. However, I am believe that the CSS Content Rule Hits Data template shouldn't be GAUGE. I think COUNTER would be more appropriate.

Furthermore, the same remark could be done for each DOS counter.

Are you agreing with that ?

gl2000
Posts: 4
Joined: Fri Dec 08, 2006 4:02 am

#43 Post by gl2000 » Tue Dec 12, 2006 10:06 am

I noticed it when I added some more of my CSS's into Cacti. Attached is a new version where the Data Templates are now COUNTER.
Attachments
css-new-v2.zip
(63.18 KiB) Downloaded 730 times

thierry.chich
Posts: 24
Joined: Tue Jun 14, 2005 7:58 am

#44 Post by thierry.chich » Thu Dec 14, 2006 10:35 am

Two others details:
o the name of the data source of the Dos datasources was
|host_decription| - Installed Memory. It is not very important, but if you have to erase a DoS graph, cacti will let you choice to erase 5 Installed memory datasources
o I believe that the Y scale of the graphs of the CSS Content Rule Traffic should be bit/s instead of byte/s. The snmp data are expressed in bit/s, it seems to me.

bidzer
Posts: 30
Joined: Tue Jun 20, 2006 12:49 pm

Anyone have a template for the CSM?

#45 Post by bidzer » Mon Dec 18, 2006 11:44 am

We have a few CSM modules for the 6500 platform? Has anyone been able to create a template for that model?

Thanks

Post Reply