Cacti (home)ForumsDocumentation
Cacti: offical forums and support
It is currently Wed Feb 20, 2019 6:32 am

All times are UTC - 5 hours




Post new topic Reply to topic  [ 9 posts ] 
Author Message
 Post subject: Graphs are not updating
PostPosted: Tue Oct 30, 2018 11:59 pm 
Offline

Joined: Mon Oct 29, 2018 1:55 am
Posts: 23
Dear All,

I have installed new cacti server Version 1.1.38 on centos 7. i have added new devices on it but graphs are not updating.
There is a error on /var/log/httpd/error_log.

ERROR: opening '/usr/share/cacti/rra/tr-2_agr-3_traffic_out_3.rrd': No such file or directory.

Please let me know the issue on here.

Also, is there any Patches for this version which needs to be updated?

Thanks.


Top
 Profile  
 
 Post subject: Re: Graphs are not updating
PostPosted: Wed Oct 31, 2018 9:36 am 
Offline
Cacti Guru User

Joined: Sun Aug 27, 2017 12:05 am
Posts: 2064
Check that your poller is running. You can also use the debug plugin if you are running 1.0.x or 1.1.x to verify your data sources. From 1.2 we integrated that plugin.

_________________
Official Cacti Developer

Cacti Resources:
Cacti Website (including releases)
Cacti Issues
Cacti Development Releases
Cacti Development Documentation

My resources:
How to submit Pull Requests
Development Wiki and How To's
Updated NetSNMP Memory template for Cacti 1.x
Cisco SFP template for Cacti 0.8.8


Top
 Profile  
 
 Post subject: Re: Graphs are not updating
PostPosted: Mon Nov 05, 2018 2:44 am 
Offline

Joined: Mon Oct 29, 2018 1:55 am
Posts: 23
Dear Team,

im not clear about it, can you please elaborate ? commands

Thanks.


Top
 Profile  
 
 Post subject: Re: Graphs are not updating
PostPosted: Mon Nov 05, 2018 2:54 am 
Offline

Joined: Mon Oct 29, 2018 1:55 am
Posts: 23
Further i receive errors as below,

[Mon Nov 05 05:23:30.550317 2018] [suexec:notice] [pid 1339] AH01232: suEXEC mechanism enabled (wrapper: /usr/sbin/suexec)
AH00557: httpd: apr_sockaddr_info_get() failed for DBill-Monitor
AH00558: httpd: Could not reliably determine the server's fully qualified domain name, using 127.0.0.1. Set the 'ServerName' directive globally to suppress this message
[Mon Nov 05 05:23:30.579808 2018] [auth_digest:notice] [pid 1339] AH01757: generating secret for digest authentication ...
[Mon Nov 05 05:23:30.580352 2018] [lbmethod_heartbeat:notice] [pid 1339] AH02282: No slotmem from mod_heartmonitor
[Mon Nov 05 05:23:31.683337 2018] [mpm_prefork:notice] [pid 1339] AH00163: Apache/2.4.6 (CentOS) PHP/5.4.16 configured -- resuming normal operations
[Mon Nov 05 05:23:31.683371 2018] [core:notice] [pid 1339] AH00094: Command line: '/usr/sbin/httpd -D FOREGROUND'
[Mon Nov 05 06:49:48.562973 2018] [:error] [pid 2887] [client X.X.X.X:52235] PHP Notice: Undefined index: host_template_id in /usr/share/cacti/graphs_new.php on line 1035, referer: http://Y.Y.Y.Y/cacti/host.php?action=edit&id=2


Top
 Profile  
 
 Post subject: Re: Graphs are not updating
PostPosted: Mon Nov 05, 2018 7:12 am 
Offline
Cacti Guru User

Joined: Sun Aug 27, 2017 12:05 am
Posts: 2064
What version of cacti is this again? The current 1.2 version only has 854 lines.

_________________
Official Cacti Developer

Cacti Resources:
Cacti Website (including releases)
Cacti Issues
Cacti Development Releases
Cacti Development Documentation

My resources:
How to submit Pull Requests
Development Wiki and How To's
Updated NetSNMP Memory template for Cacti 1.x
Cisco SFP template for Cacti 0.8.8


Top
 Profile  
 
 Post subject: Re: Graphs are not updating
PostPosted: Wed Nov 07, 2018 11:14 pm 
Offline

Joined: Mon Oct 29, 2018 1:55 am
Posts: 23
My cacti version is Version 1.1.38


Top
 Profile  
 
 Post subject: Re: Graphs are not updating
PostPosted: Thu Nov 08, 2018 9:08 am 
Offline
Cacti Guru User

Joined: Sun Aug 27, 2017 12:05 am
Posts: 2064
This is a problem I think when creating new graphs that are not associated to a host?

The problem would still exist currently in 1.2 so can you open a new issue on GitHub for this? It comes because the $host field is not properly populated with a value for 'host_template_id' thus when attempting to later use that key, it's not found.

_________________
Official Cacti Developer

Cacti Resources:
Cacti Website (including releases)
Cacti Issues
Cacti Development Releases
Cacti Development Documentation

My resources:
How to submit Pull Requests
Development Wiki and How To's
Updated NetSNMP Memory template for Cacti 1.x
Cisco SFP template for Cacti 0.8.8


Top
 Profile  
 
 Post subject: Re: Graphs are not updating
PostPosted: Thu Nov 08, 2018 11:26 pm 
Offline

Joined: Mon Oct 29, 2018 1:55 am
Posts: 23
Dear Guru,

im not clear about it what u have said, can you please explain how can i resolve this by commands?

Thanks in advanced.


Top
 Profile  
 
 Post subject: Re: Graphs are not updating
PostPosted: Fri Nov 09, 2018 4:14 am 
Offline
Cacti Guru User

Joined: Sun Aug 27, 2017 12:05 am
Posts: 2064
Goto https://github.com/cacti/cacti/issues and open a new issue about this so it can be fixed properly. There are no commands to fix it at the moment.

_________________
Official Cacti Developer

Cacti Resources:
Cacti Website (including releases)
Cacti Issues
Cacti Development Releases
Cacti Development Documentation

My resources:
How to submit Pull Requests
Development Wiki and How To's
Updated NetSNMP Memory template for Cacti 1.x
Cisco SFP template for Cacti 0.8.8


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 9 posts ] 

All times are UTC - 5 hours


Who is online

Users browsing this forum: Google [Bot], Google Adsense [Bot] and 4 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  

Protected by Anti-Spam ACP Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group