Cacti (home)ForumsDocumentation
Cacti: offical forums and support
It is currently Fri Dec 15, 2017 8:27 pm

All times are UTC - 5 hours




Post new topic Reply to topic  [ 2 posts ] 
Author Message
 Post subject: SNMP Informant SQL Template Issue [SOLVED]
PostPosted: Thu Aug 24, 2017 4:42 pm 
Offline

Joined: Thu Oct 03, 2013 12:07 pm
Posts: 18
Generally I'm able to figure out my Cacti issues but this one has me stumped...

I'm running an older Cacti server at the moment, CentOS 6.5 with Cacti 0.8.8b, and am getting ready to build a new server, but in the meantime I have at template downloaded from this forum that has not been not working or me. If need be I can create a basic template but I'd REALLY like to get this to work...

The issue is with SNMP Informant SQL. Of the files associated with the template (source linked below) the one not working is the one named "SQLServer_InstanceStatistics.xml". I see the Query template and the graph template in Cacti, and I add the template to the host using its the Associated Data Queries section, but the data will not display in the Graphs tab for the host. The data and graph template appear to be built correctly. Any ideas if there's an issue with the template or if I'm doing something wrong? I do have SNMP Informant SQL installed on the Windows host. I don't see this template listed in the poller cache, and no errors found in the log when set to DEBUG.

This is where I downloaded the original files. The other two templates at this URL work fine: https://forums.cacti.net/viewtopic.php?f=12&t=36361

When I run a Verbose Query I get these results, and I was expecting more data:

+ Running data query [23].
+ Found type = '3' [SNMP Query].
+ Found data query XML file at '/usr/share/cacti/resource/snmp_queries/SQLServer_InstanceStatistics.xml'
+ XML file parsed ok.
+ <oid_num_indexes> missing in XML file, 'Index Count Changed' emulated by counting oid_index entries
+ Executing SNMP walk for list of indexes @ '.1.3.6.1.4.1.9600.1.13.2.1.1.1' Index Count: 1
+ Index found at OID: '1.3.6.1.4.1.9600.1.13.2.1.1.1.1' value: '1'
+ Located input field 'InstanceName' [walk]
+ Executing SNMP walk for data @ '.1.3.6.1.4.1.9600.1.13.2.1.1.2'
+ Found item [InstanceName='4294967295'] index: 1 [from value]

Any help is MUCH appreciated.


Top
 Profile  
 
 Post subject: Re: SNMP Informant SQL Template Issue [SOLVED]
PostPosted: Thu Aug 24, 2017 4:58 pm 
Offline

Joined: Thu Oct 03, 2013 12:07 pm
Posts: 18
Now this is embarrassing...

It was right in front of me the whole time. I just had check the box create the graph in the Data Query list for the host. It seems to be working fine now that it's properly added...

If it helps anyone in the future the host is a new Windows 2012 R2 server running SQL Server 2012.


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 2 posts ] 

All times are UTC - 5 hours


Who is online

Users browsing this forum: No registered users and 4 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  

Protected by Anti-Spam ACP Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group