Advanced ping template packet loss

Templates, scripts for templates, scripts and requests for templates.

Moderators: Moderators, Developers

Post Reply
Author
Message
Axel90
Cacti User
Posts: 125
Joined: Fri Feb 10, 2017 12:41 pm

Advanced ping template packet loss

#1 Post by Axel90 » Thu Nov 15, 2018 4:49 am

Hi!
I'm using the advanced ping template.
At some devices, there is a packet loss, but I can't understand why:

Code: Select all

[email protected]:/usr/share/cacti/site/scripts# ping -c 10 x.x.x.x
PING 134.76.24.159 (134.76.24.159) 56(84) bytes of data.
64 bytes from x.x.x.x: icmp_seq=1 ttl=57 time=10.7 ms
64 bytes from x.x.x.x: icmp_seq=2 ttl=57 time=10.6 ms
64 bytes from x.x.x.x: icmp_seq=3 ttl=57 time=10.9 ms
64 bytes from x.x.x.x: icmp_seq=4 ttl=57 time=10.8 ms
64 bytes from x.x.x.x: icmp_seq=5 ttl=57 time=11.0 ms
64 bytes from x.x.x.x: icmp_seq=6 ttl=57 time=10.6 ms
64 bytes from x.x.x.x: icmp_seq=7 ttl=57 time=10.5 ms
64 bytes from x.x.x.x: icmp_seq=8 ttl=57 time=11.0 ms
64 bytes from x.x.x.x: icmp_seq=9 ttl=57 time=10.7 ms
64 bytes from x.x.x.x: icmp_seq=10 ttl=57 time=11.1 ms
When I do a normal ping, there isn't any packet loss.

Code: Select all

[email protected]:/usr/share/cacti/site/scripts# php ss_fping.php x.x.x.x 10 ICMP
min:10.5960 avg:10.8790 max:11.2420 dev:0.2112 loss:30.0000
With the php file, I have 30% packet loss.

Can someone help me?

netniV
Cacti Guru User
Posts: 2670
Joined: Sun Aug 27, 2017 12:05 am

Re: Advanced ping template packet loss

#2 Post by netniV » Thu Nov 15, 2018 6:53 am

When you are using ping at the command line, try using the -O parameter to see if there are outstanding ECHO requests before sending the next packet. Out of sequence requests can be treated as loss by some systems (though I can't say specifically for this template/script/system).

Post Reply