[SOLVED]RRD files not updating - copied from a server

Templates, scripts for templates, scripts and requests for templates.

Moderators: Moderators, Developers

Post Reply
Author
Message
eholz1
Cacti User
Posts: 129
Joined: Mon Oct 01, 2018 10:09 am

[SOLVED]RRD files not updating - copied from a server

#1 Post by eholz1 » Mon Dec 17, 2018 6:27 pm

Hello All,
The famous rrd not updating issue with a twist.
Running Red Hat 6.7,cacti-1.1.28, spine -same version, rrdtool 1.5.5
I ahve a production cacti server, and a server we use for backup of the production.
It is basically a copy of the files from cacti, the rrd files, and the database.
I copied some rrd files for a particular device which is accessible by both servers
to the backup server.

The backup server has its own poller, the database(s) are the same name on each server.
The issue is that the rrd files I copied over, show cacti as user, etc but they are not being
updated by the poller.

Other devices and files do seem to be updating.

Any ideas on what to look for? The permissions for rra and the *.rrd files appear OK

[SOLVED] - The cron job was not configured correctly - a typo - pilot error

Thanks,
eholz1
Last edited by eholz1 on Tue Dec 18, 2018 11:51 am, edited 1 time in total.

netniV
Cacti Guru User
Posts: 2682
Joined: Sun Aug 27, 2017 12:05 am

Re: RRD files not updating - copied from a server

#2 Post by netniV » Tue Dec 18, 2018 7:47 am

If you have SELinux enabled, you may find that the access to the file are blocked by it if the context is wrong.

Post Reply