Cacti (home)ForumsDocumentation
Cacti: offical forums and support
It is currently Sat Feb 23, 2019 6:05 pm

All times are UTC - 5 hours




Post new topic Reply to topic  [ 4 posts ] 
Author Message
 Post subject: new snmp_query and graph template don't create rrd file
PostPosted: Wed Jan 16, 2019 11:08 am 
Offline

Joined: Fri Sep 02, 2016 8:44 am
Posts: 15
I've created a new xml snmp query and created all the links through a device, but for some reason the poller never attempts to query the device for the new OIDs. I've created similar queries previously without trouble, but I can not figure out why this one won't query the OIDs for the device.

I'm running Centos7, cacti 1.1.38. Below is the process for the creation. Any ideas would be appreciated.

create data source template
created data query pointing to snmp query xml file
created graph template linking back to datasource
- graph item inputs reference datasource values which reference XML field values
data collection->data queries->data query name->link graph template to data query name
- data source items listed, check boxes to map data template to proper data source

Once all the templates have been created, I add the data query to the host and perform a verbose query which returns all the right data:

Data Query Debug Information
Total: 0.000000, Delta: 0.000000, Running data query [8].
Total: 0.000000, Delta: 0.000000, Found type = '3' [SNMP Query].
Total: 0.000000, Delta: 0.000000, Found data query XML file at '/usr/local/cacti/resource/snmp_queries/ciena5142_PM_DataQuery.xml'
Total: 0.000000, Delta: 0.000000, XML file parsed ok.
Total: 0.010000, Delta: 0.000000, Executing SNMP get for num of indexes @ '.1.3.6.1.4.1.6141.2.60.27.1.1.4.1.18' Index Count:
Total: 0.010000, Delta: 0.010000, Executing SNMP walk for list of indexes @ '.1.3.6.1.4.1.6141.2.60.27.1.1.4.1.18' Index Count: 4
Total: 0.010000, Delta: 0.000000, Index found at OID: '.1.3.6.1.4.1.6141.2.60.27.1.1.4.1.18.1.1' value: 'ATL-IP_Direct'
Total: 0.010000, Delta: 0.000000, Index found at OID: '.1.3.6.1.4.1.6141.2.60.27.1.1.4.1.18.4.1' value: 'ATL-IP_Direct'
Total: 0.010000, Delta: 0.000000, Index found at OID: '.1.3.6.1.4.1.6141.2.60.27.1.1.4.1.18.5.1' value: 'a32.dia.atl.5142.dc2.1.5'
Total: 0.010000, Delta: 0.000000, Index found at OID: '.1.3.6.1.4.1.6141.2.60.27.1.1.4.1.18.6.1' value: 'a39.dia.atl.5142.dc2.1.6_V115'
Total: 0.010000, Delta: 0.000000, index_parse at OID: '.1.3.6.1.4.1.6141.2.60.27.1.1.4.1.18.1.1' results: '1'
Total: 0.010000, Delta: 0.000000, index_parse at OID: '.1.3.6.1.4.1.6141.2.60.27.1.1.4.1.18.4.1' results: '4'
Total: 0.010000, Delta: 0.000000, index_parse at OID: '.1.3.6.1.4.1.6141.2.60.27.1.1.4.1.18.5.1' results: '5'
Total: 0.010000, Delta: 0.000000, index_parse at OID: '.1.3.6.1.4.1.6141.2.60.27.1.1.4.1.18.6.1' results: '6'
Click to show Data Query output for field 'ifDesc'
Total: 0.020000, Delta: 0.000000, Update data query sort cache complete
Total: 0.020000, Delta: 0.000000, Updated data query index ordering
Total: 0.020000, Delta: 0.000000, Update re-index cache complete
Total: 0.020000, Delta: 0.000000, Update graph data query cache complete
Total: 0.020000, Delta: 0.000000, Update data source data query cache complete
Total: 0.020000, Delta: 0.000000, Update data query cache complete
Total: 0.020000, Delta: 0.000000, Update poller cache from query complete
Total: 0.020000, Delta: 0.000000, Automation execute data query complete
Total: 0.020000, Delta: 0.000000, Plugin hooks complete

add graphs for device, graph descriptions displayed from the data query performed. Graphs create, all data sources active, device active and returning data for other graphs but on every subsequent poll the new graph OIDs/rrd file is not created.

debug on spine or cmd poller shows nothing for the new rrd file or OID attempted to be pulled. No errors for the device. It just continues to work 'normally' for existing datasources on the same device.


Top
 Profile  
 
 Post subject: Re: new snmp_query and graph template don't create rrd file
PostPosted: Wed Jan 16, 2019 12:40 pm 
Offline

Joined: Fri Sep 02, 2016 8:44 am
Posts: 15
To add some more detail;

If I go to device management, select the device, the datasource is listed and is active, but there is no rrd file. So somewhere there appears to be a break triggering an active datasource to initiate query/collection when the poller is run.

Other datasources listed for the same device can be added/removed, such as interface statistics and create/remove graphs/rrd files.


Top
 Profile  
 
 Post subject: Re: new snmp_query and graph template don't create rrd file
PostPosted: Wed Jan 16, 2019 8:30 pm 
Offline

Joined: Fri Sep 02, 2016 8:44 am
Posts: 15
upgraded to 1.2.0 and that resolved the rrd file creation. Not really clear to me why that made a difference.


Top
 Profile  
 
 Post subject: Re: new snmp_query and graph template don't create rrd file
PostPosted: Thu Jan 17, 2019 7:33 pm 
Offline
Cacti Pro User
User avatar

Joined: Mon Jan 05, 2015 10:10 am
Posts: 744
There are some nasty issues with 1.2.0. Make sure you upgrade to 1.2.1 as soon as it's released.

_________________
Before history, there was a paradise, now dust.


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 4 posts ] 

All times are UTC - 5 hours


Who is online

Users browsing this forum: No registered users and 3 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  

Protected by Anti-Spam ACP Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group