The MySQL Graph Collection - Version 2.0!

Templates, scripts for templates, scripts and requests for templates.

Moderators: Moderators, Developers

Post Reply
Author
Message
cobi
Posts: 1
Joined: Tue Jun 14, 2005 10:32 am

#61 Post by cobi » Tue Jun 14, 2005 10:47 am

I corrected on my config the empty problem of graph by change the lib/poller.php line 215
preg_match("/^([a-zA-Z0-9_\.-]+):([0-9Ee-\+\.]+)$/", $values[$i], $matches) by
preg_match("/^([a-zA-Z0-9_\.-]+):([0-9-Ee\+\.]+)$/", $values[$i], $matches)
and I also filled the rrd_name in the table poller_item by using the
rrd_path

Sorry for my english i m french.

Kroontje
Posts: 6
Joined: Thu Jun 16, 2005 3:14 am
Location: The Netherlands

#62 Post by Kroontje » Thu Jun 16, 2005 3:23 am

Hello Cacti-freaks,

I'am new with cacti and linux and try to install the MySQL graphs. When I try to import the xml-files I'll get the error: Error: XML: Cacti version does not exist.

Fedora Core 3
Cacti 0.8.6d

Is there another way to import the xml-files?

Thanks in advance for your help :)

ottob
Cacti User
Posts: 51
Joined: Tue Apr 27, 2004 11:43 am
Location: Duesseldorf, Germany
Contact:

#63 Post by ottob » Thu Jun 16, 2005 3:34 am

youre right! I have to export this template for 0.8.6d. Currently they are run only with 0.8.6c.

There will be an update very soon...!

otto

Kroontje
Posts: 6
Joined: Thu Jun 16, 2005 3:14 am
Location: The Netherlands

#64 Post by Kroontje » Thu Jun 16, 2005 3:43 am

ottob wrote:youre right! I have to export this template for 0.8.6d. Currently they are run only with 0.8.6c.

There will be an update very soon...!

otto
Great! Thanks a lot!

tenkawa69
Posts: 5
Joined: Wed Jun 29, 2005 5:25 am

Unable to graph a foreign host

#65 Post by tenkawa69 » Wed Jun 29, 2005 5:32 am

Hello everybody ,

first of all , thank you very much for these scripts . they are impressive.

my problem is that i am unable to graph a foreign host, actually localhost is working great.
but when i try to graph another hosts it said :
->ERROR: Not enough arguments

i didn't forgot to set privilege for the cactiuser
->GRANT PROCESS ON * TO [email protected]'192.168.0.52' IDENTIFIED by 'cacti';

if anyone can help me
thanks everybody in advance

feeman
Posts: 1
Joined: Sun Jul 03, 2005 10:51 am

#66 Post by feeman » Sun Jul 03, 2005 10:59 pm

First! Thank otto for giving us such a wonderful tool!!
SCaRaBaeuS wrote:okay i found the problem.

normally a mysql connection has a priveliges system for localhost i just set that (so nobody from the outside can connect)

But my cacti has a hostname www.only4clans.com so it connects to that, but that doens't work..
so you should change your stuff to localhost instead to |hostname| ;)

(also alot of the time php -q doesnt work)
example i have to use /usr/local/bin/php instead of only php :)
When I try the addon , I meet the same problem that without any graph but the command line php-q <cacti_path> ... <username> <password> work!!
Cacti log tell me "WARNING: Result from CMD not valid. Partial Result: Error: MySQL connect "

After watching SCaRaBaeuS's article above , I realize that I have changed my default hostname in DEVICE. Finally I change it back to localhost and it works... Ya!! Maybe this is helpful to those people who have met the same problem like mine!!

My BOX
Pentium 4-1.6G
Ram 1G
OS: Freebsd 5.4
Apache/2.0.54
PHP 4.3.11 (cli)
mysql Distrib 4.1.12
CACTI 0.8.6f

jayray
Posts: 24
Joined: Sat May 01, 2004 11:01 pm

#67 Post by jayray » Thu Jul 28, 2005 9:50 pm

Is there a release for 0.8.6d? I can not get this one to import correctly.

jeffreyheinen
Posts: 2
Joined: Wed Apr 27, 2005 11:18 am

#68 Post by jeffreyheinen » Fri Jul 29, 2005 2:18 pm

What about a conversion into the php script_server. Shouldn't that help preformance some? Is that in the works as well?

paulbeard206
Cacti User
Posts: 149
Joined: Sat Jul 30, 2005 2:15 pm

mysql_stats and 0.8.6f?

#69 Post by paulbeard206 » Mon Aug 01, 2005 3:45 pm

Is this a problem with the templates and the current version?

Code: Select all

[email protected]:~/cacti> php -q poller.php 

public: Unknown Object Identifier (Sub-id not found: mib-2 -> public)
Actually, scratch that: I am using these scripts with 0.8.6f on my home network. works fine. It seems some people are using 0.8.6f without any issues?

EmiT
Posts: 1
Joined: Mon Aug 08, 2005 8:35 am
Contact:

Added support for MySQLi

#70 Post by EmiT » Mon Aug 08, 2005 11:22 am

At first thanks for this cool script. But I'm using MySQL database version 4.1 and PHP uses new functions for MySQL 4.1x and later. So I have updated your script and templates. They are called MySQLi and can coexist with mysql_stats. I have tested it on 0.8.6f and it works well.

Write if something won't work.
Attachments
mysqli_stats.zip
Updated package of mysql_stats - all contents included . Now supporting MySQL 4.1.
(24.69 KiB) Downloaded 1505 times

pruesse
Posts: 2
Joined: Mon Sep 12, 2005 5:12 am
Contact:

#71 Post by pruesse » Mon Sep 12, 2005 8:33 am

The above files do require PHP5, as far as I can see. What do I want to do to monitor MySQL 4.1 using PHP4 ?

suse
Posts: 23
Joined: Sun Nov 13, 2005 1:05 am

#72 Post by suse » Mon Nov 14, 2005 9:47 am

can not use it on 0.8.6g + mysql 4.0.26{foreign DB host)

php -q ./mysql_stats.php command localhost user pass

did not give anything.

suse
Posts: 23
Joined: Sun Nov 13, 2005 1:05 am

#73 Post by suse » Mon Nov 14, 2005 9:56 am

how to monitor multi DB host at same time?

ottob
Cacti User
Posts: 51
Joined: Tue Apr 27, 2004 11:43 am
Location: Duesseldorf, Germany
Contact:

#74 Post by ottob » Mon Nov 14, 2005 10:11 am

what does "php --version" give?

suse
Posts: 23
Joined: Sun Nov 13, 2005 1:05 am

#75 Post by suse » Mon Nov 14, 2005 6:12 pm

now only
MySQL - Command statistics
MySQL - Connections

can graph for me,
others can not.
error msg is

RRDTool Says:

ERROR: Not a valid vname: #FF9900 in line LINE1:#FF9900:Read Rnd Next


maybe it is template error?

Thanks for your help

Post Reply