Cacti (home)ForumsDocumentation
Cacti: offical forums and support
It is currently Sun Jun 16, 2019 1:54 am

All times are UTC - 5 hours




Post new topic Reply to topic  [ 40 posts ]  Go to page Previous  1, 2, 3
Author Message
 Post subject:
PostPosted: Thu Feb 21, 2008 5:05 am 
Offline

Joined: Tue Dec 19, 2006 8:15 am
Posts: 14
Elvar wrote:
rs232 wrote:
Don't ask me why, but the solution was to edit asspstats.pl and change:


$passwd = $ARGV[0];
into
$passwd = "mypassword";

$ipaddress = $ARGV[1];
into
$ipaddress = "127.0.0.1";

So ignore the web page config where to set these paramenter.

HTH



The version of the script I have is already set like this. When I run it I still don't get any results. Even if I paste the URL that works straight from the browser into the script I don't get any results.


May be it's an Apache access permission problem from localhost to localhost? May be the firewall?
What happens if you run the asspstats.pl manually?
You should get an output like:

Code:
[email protected]# ./asspstats.pl
smtpcon:362727 totmess:23517 bayspam:2107 locmail:5150


Top
 Profile  
 
 Post subject:
PostPosted: Thu Feb 21, 2008 7:01 am 
Offline

Joined: Tue Feb 19, 2008 3:06 pm
Posts: 7
rs232 wrote:
Elvar wrote:
rs232 wrote:
Don't ask me why, but the solution was to edit asspstats.pl and change:


$passwd = $ARGV[0];
into
$passwd = "mypassword";

$ipaddress = $ARGV[1];
into
$ipaddress = "127.0.0.1";

So ignore the web page config where to set these paramenter.

HTH



The version of the script I have is already set like this. When I run it I still don't get any results. Even if I paste the URL that works straight from the browser into the script I don't get any results.


May be it's an Apache access permission problem from localhost to localhost? May be the firewall?
What happens if you run the asspstats.pl manually?
You should get an output like:

Code:
[email protected]# ./asspstats.pl
smtpcon:362727 totmess:23517 bayspam:2107 locmail:5150



I am running the script manually. I've verified it's definitely not firewall rules as I am explicitly allowing all traffic between both hosts. When I run manually I just get the following...

perl asspstats123.pl
smtpcon: totmess: bayspam: locmail: whitemail:#


That's all I get unfortunately.


Thanks!


Top
 Profile  
 
 Post subject: Resolved
PostPosted: Wed Feb 27, 2008 9:23 am 
Offline

Joined: Tue Feb 19, 2008 3:06 pm
Posts: 7
Elvar wrote:
rs232 wrote:
Elvar wrote:
rs232 wrote:
Don't ask me why, but the solution was to edit asspstats.pl and change:


$passwd = $ARGV[0];
into
$passwd = "mypassword";

$ipaddress = $ARGV[1];
into
$ipaddress = "127.0.0.1";

So ignore the web page config where to set these paramenter.

HTH



The version of the script I have is already set like this. When I run it I still don't get any results. Even if I paste the URL that works straight from the browser into the script I don't get any results.


May be it's an Apache access permission problem from localhost to localhost? May be the firewall?
What happens if you run the asspstats.pl manually?
You should get an output like:

Code:
[email protected]# ./asspstats.pl
smtpcon:362727 totmess:23517 bayspam:2107 locmail:5150



I am running the script manually. I've verified it's definitely not firewall rules as I am explicitly allowing all traffic between both hosts. When I run manually I just get the following...

perl asspstats123.pl
smtpcon: totmess: bayspam: locmail: whitemail:#


That's all I get unfortunately.


Thanks!



Unfortunately my problem was related to "AllowedAdminConnections" and it blocking admin access from my Cacti server... :\

Sorry to waste everyones time!


Top
 Profile  
 
 Post subject: this is the final configuration that works on assp 1.3.3.8
PostPosted: Sun Mar 09, 2008 9:03 am 
Offline

Joined: Sun Mar 09, 2008 8:57 am
Posts: 1
as we can see in the script we are using GET function.
this line :
$starturl ='http://'.$username.':'.$passwd.'@'.$ipaddress.':55555/infostats';

will not work, and you will not be able to login.

so just modify it to:
$starturl = 'http://anyuser:[email protected]:55555/infostats';

now your good to go !

enjoy.


Top
 Profile  
 
 Post subject:
PostPosted: Sun Jul 20, 2008 4:45 am 
Offline

Joined: Tue Dec 19, 2006 8:15 am
Posts: 14
I've just upgraded ASSP to the latest version (1.3.3.10) and suddenly cacti stopped collecting ASSp data.
I believe there is a slightly different info/stat page in this version (if this can help)


Regards
rs232


Top
 Profile  
 
 Post subject: ASSP v 1.3.3.10
PostPosted: Wed Jul 30, 2008 2:46 am 
Offline

Joined: Wed Jul 30, 2008 2:27 am
Posts: 2
Hi,
I'm new to this forum trying to get ASSP 1.3.3.10 to work with Cacti 0.8.7b.
I have another (separate) setup with ASSP 1.3.1 / Cacti 0.8.6j that is working just fine.
Can someone maybe post a working set of templates and script since I believe that there are a few changes compared to previous versions of ASSP combined with Cacti's latest release.
I spent days on getting it fixed and no luck so far.
Any help would be great!

thx

Roger


Top
 Profile  
 
 Post subject: Re: ASSP v 1.3.3.10
PostPosted: Mon Aug 11, 2008 3:31 pm 
Offline

Joined: Wed Jul 30, 2008 2:27 am
Posts: 2
RogMoe wrote:
Hi,
I'm new to this forum trying to get ASSP 1.3.3.10 to work with Cacti 0.8.7b.
I have another (separate) setup with ASSP 1.3.1 / Cacti 0.8.6j that is working just fine.
Can someone maybe post a working set of templates and script since I believe that there are a few changes compared to previous versions of ASSP combined with Cacti's latest release.
I spent days on getting it fixed and no luck so far.
Any help would be great!

thx

Roger


anybody?
I'm still stuck with this one!


Top
 Profile  
 
 Post subject:
PostPosted: Mon Aug 18, 2008 9:34 am 
Offline

Joined: Fri Dec 22, 2006 6:37 am
Posts: 4
rs232 wrote:
I've just upgraded ASSP to the latest version (1.3.3.10) and suddenly cacti stopped collecting ASSp data.
I believe there is a slightly different info/stat page in this version (if this can help)


ASSP is changing some infostats parameters; in the meanwhile, the beta releases have a RAW STATS page at http://server:55553, available without login (but allowing specified hosts to connect from). The new page is full of details and a LOT simpler to parse.

New releases are here: http://www.asspsmtp.org/forums/index.php?board=26.0

Just any volunteer to modify the asspstats.pl script? :-)

Here the new page:

ASSP Proxy Uptime | 1.860 days| 285.558 days Messages Processed | 1967 (1057.6 per day) | 180189 (631.0 per day) Non-Local Mail Blocked | 96.9% | 93.0% CPU Usage | 15.57% (0.35% avg) | 0.69% avg Concurrent SMTP Sessions | 0 (5 max) | 10 max SMTP Connections Received | 3414 | 685403 SMTP Connections Accepted | 3411 | 594118 SMTP Connections Rejected | 3 | 91285 Envelope Recipients Processed | 3364 | 528210 Envelope Recipients Accepted | 86 | 34011 Envelope Recipients Rejected | 3278 | 494199 Messages Processed | 1967 | 180189 Messages Passed | 67 | 18197 Messages Rejected | 1900 | 161992 Admin Connections Received | 9069 | 107480 Admin Connections Accepted | 9069 | 107480 Admin Connections Rejected | 0 | 0 Stat Connections Received | 289 | 302 Stat Connections Accepted | 151 | 164 Stat Connections Rejected | 138 | 138 Accepted Logged SMTP Connections | 3409 | 584935 Not Logged SMTP Connections | 2 | 9183 SMTP Connection Limits | 3 | 90378 Overall Limits | 0 | 0 By IP Limits | 3 | 464 By IP Frequency Limits | 0 | 89914 By Domain IP Limits | 0 | 0 SMTP Connections Timeout | 6 | 3574 Denied SMTP Connections | 0 | 907 Local Recipients Accepted | 85 | 33921 Validated Recipients | 83 | 31360 Unchecked Recipients | 0 | 20 Spam-Lover Recipients | 2 | 2541 Remote Recipients Accepted | 0 | 42 Whitelisted Recipients | 0 | 26 Not Whitelisted Recipients | 0 | 16 Noprocessed Recipients | 0 | 0 Email Reports | 1 | 48 Spam Reports | 1 | 29 Ham Reports | 0 | 19 Whitelist Additions | 0 | 0 Whitelist Deletions | 0 | 0 Redlist Additions | 0 | 0 Redlist Deletions | 0 | 0 Local Recipients Rejected | 3244 | 455544 Nonexistent Recipients | 16 | 2003 Delayed Recipients | 2887 | 417287 Delayed (Late) Recipients | 0 | 3 Delayed (Expired) Recipients | 0 | 0 Embargoed Recipients | 187 | 27296 Spam Bucketed Recipients | 154 | 8955 Remote Recipients Rejected | 34 | 38655 Relay Attempts Rejected | 34 | 38655 Bayesian Hams | 39 | 8815 Whitelisted | 9 | 1943 Local | 7 | 6083 Noprocessing | 10 | 1169 Spamlover Spams Passed | 2 | 187 Bayesian Spams | 0 | 0 Domains Blacklisted | 0 | 0 HELO Blacklisted | 0 | 283 HELO Invalid | 0 | 176 HELO Forged | 0 | 1513 Missing MX | 0 | 29 Missing PTR | 0 | 5 Invalid PTR | 0 | 17 Spam Collected Messages | 123 | 3919 Penalty Trap Messages | 0 | 7729 Bad Attachments | 0 | 0 Viruses Detected | 20 | 39 Sender Regex | 0 | 0 Bomb Regex | 0 | 0 Penalty Box | 0 | 6685 Message Scoring | 19 | 2255 Invalid Local Sender | 0 | 0 Invalid Internal Mail | 0 | 0 Scripts | 0 | 0 SPF Failures | 0 | 49 RBL Failures | 19 | 1082 URIBL Failures | 0 | 380 Max Errors Exceeded | 5 | 94 Delayed | 1712 | 46826 Empty Recipient | 2 | 64 Not SRS Signed Bounces | 0 | 0

Cheers
Luca


Top
 Profile  
 
 Post subject:
PostPosted: Mon Sep 08, 2008 1:36 pm 
Offline

Joined: Mon Sep 08, 2008 1:16 pm
Posts: 1
I had a problem problem upgrading ASSP from 1.3.3.8 to 1.3.3.10.
To solve it I had to modify all lines starting as following in asspstats.pl:

if ($line2 =

I had to remove 2 and " between / and >.
Original line:

if ($line2 =~ /2">(\d+)<\/td/i) {

Modified line:

if ($line2 =~ />(\d+)<\/td/i) {

Now the script works with ASSP 1.3.3.10 and also with 1.3.3.8.


Top
 Profile  
 
 Post subject: 1.4.3.0.2
PostPosted: Sun Nov 23, 2008 5:43 am 
Offline
User avatar

Joined: Mon Jan 21, 2008 3:55 pm
Posts: 7
Hi there,

for who's interested, I modified the script to the output of ASSP 1.4.3.0.2 ; beware that I'm not a Perl programmer; I just copied some lines to select the correct line and trimmed some spaces. But it works :)


Attachments:
asspstats.pl [3.34 KiB]
Downloaded 496 times
Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 40 posts ]  Go to page Previous  1, 2, 3

All times are UTC - 5 hours


Who is online

Users browsing this forum: No registered users and 11 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron

Protected by Anti-Spam ACP Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group