NPC Nagios Plugin For Cacti Problem

General discussion about Plugins for Cacti

Moderators: Moderators, Developers

Post Reply
Author
Message
crocop_83
Posts: 6
Joined: Tue Apr 25, 2006 10:59 am

NPC Nagios Plugin For Cacti Problem

#1 Post by crocop_83 » Tue Apr 25, 2006 11:08 am

Hi,

I would like to install Nagios Plugin For Cacti.
I 've read the document about it and I've installed it.
But when I tried to restart Nagios, I 've got this message in my log !

Code: Select all

[1145976826] initializing nagios-db mysql inserter...
[1145976826] nagios-db: inserter locked into db
[1145976826] Event broker module '/usr/local/nagios/modules/inserter.o' initialized successfully.
[1145976826] Finished daemonizing... (New PID=16277)
[1145976869] Caught SIGTERM, shutting down...
Nagios can not start.
NPC use Event Broker and I have configured the file nagios.cfg

Code: Select all

        retain_state_information=0
        event_broker_options=-1 and
        broker_module=/path/to/nagios/modules/inserter.o
Any ideas why Nagios can't start ?

Thanks,

Crocop_83

julpie
Posts: 13
Joined: Mon Apr 03, 2006 7:43 am
Location: Wuerzburg (Germany)

#2 Post by julpie » Wed Apr 26, 2006 2:13 am

/path/to/nagios must be replaced by the path to nagios (/usr/local/nagios by default).

crocop_83
Posts: 6
Joined: Tue Apr 25, 2006 10:59 am

#3 Post by crocop_83 » Wed Apr 26, 2006 2:38 am

I have already replaced the path with the right one.
But It 's always the same error.

(It was a code copy from the document provides with NPC. It was an example to show what I've done, sorry)

Post Reply