Requested URL /cacti was not found on this server

General discussion about Plugins for Cacti

Moderators: Moderators, Developers

Post Reply
Author
Message
cezario2009
Posts: 11
Joined: Mon Dec 11, 2017 7:26 am

Requested URL /cacti was not found on this server

#1 Post by cezario2009 » Tue Dec 19, 2017 1:48 pm

I installed cacti 1.1.28 with debian 9.
after installation does not open.
the message appears:
"Requested URL / cacti was not found on this server"
help please


cezario2009
Posts: 11
Joined: Mon Dec 11, 2017 7:26 am

Re: Requested URL /cacti was not found on this server

#3 Post by cezario2009 » Tue Dec 19, 2017 4:38 pm

markv wrote:Have you made sure that apache has been restarted?
yes, I even do the initial configuration

netniV
Cacti Guru User
Posts: 2670
Joined: Sun Aug 27, 2017 12:05 am

Re: Requested URL /cacti was not found on this server

#4 Post by netniV » Tue Dec 19, 2017 4:44 pm

That does not make sense since the install is beneath the /cacti/ in /cacti/install/

Can you describe the steps you have taken so far?

cezario2009
Posts: 11
Joined: Mon Dec 11, 2017 7:26 am

Re: Requested URL /cacti was not found on this server

#5 Post by cezario2009 » Tue Dec 19, 2017 4:53 pm

markv wrote:That does not make sense since the install is beneath the /cacti/ in /cacti/install/

Can you describe the steps you have taken so far?
after installation step 1 localhost / install ----> ok ----> step 2 login: admin password admin -----> failed ---> Requested URL / cacti was not found on this server "

netniV
Cacti Guru User
Posts: 2670
Joined: Sun Aug 27, 2017 12:05 am

Re: Requested URL /cacti was not found on this server

#6 Post by netniV » Tue Dec 19, 2017 4:58 pm

Whilst performing the install, did you change the site location as your using cacti as the root folder not the normal /cacti/ subfolder.

cezario2009
Posts: 11
Joined: Mon Dec 11, 2017 7:26 am

Re: Requested URL /cacti was not found on this server

#7 Post by cezario2009 » Tue Dec 19, 2017 5:12 pm

markv wrote:Whilst performing the install, did you change the site location as your using cacti as the root folder not the normal /cacti/ subfolder.
I did not understand, can you explain it again?

cezario2009
Posts: 11
Joined: Mon Dec 11, 2017 7:26 am

Re: Requested URL /cacti was not found on this server

#8 Post by cezario2009 » Tue Dec 19, 2017 5:16 pm

cezario2009 wrote:
markv wrote:Whilst performing the install, did you change the site location as your using cacti as the root folder not the normal /cacti/ subfolder.
I did not understand, can you explain it again?
I made the installation following this site
https://www.tecmint.com/install-cacti-w ... nd-ubuntu/

netniV
Cacti Guru User
Posts: 2670
Joined: Sun Aug 27, 2017 12:05 am

Re: Requested URL /cacti was not found on this server

#9 Post by netniV » Wed Dec 20, 2017 3:33 am

paulgevers maintains a backport of cacti for ubuntu/debian (his signature has the details if you click on his name). Using that would seem to have been easier to install cacti as it does most of this work for you.

However, in your case, you will also need to check that the configuration file has the correct path set for $url_path in the include/config.php file. This will most likely be set to "/cacti/" and needs changing to just "/"

ie, from:

Code: Select all

/* set the $url_path to point to the default URL of your cacti
 * install ex: if your cacti install as at
 * http://serverip/cacti/ this would be set to /cacti/.
*/

$url_path = '/cacti/';
To:

Code: Select all

/* set the $url_path to point to the default URL of your cacti
 * install ex: if your cacti install as at
 * http://serverip/cacti/ this would be set to /cacti/.
*/

$url_path = '/';

netniV
Cacti Guru User
Posts: 2670
Joined: Sun Aug 27, 2017 12:05 am

Re: Requested URL /cacti was not found on this server

#10 Post by netniV » Wed Dec 20, 2017 4:07 am

I can verify that in 0.8.8a, the configuration file was updated to default to the /config/ format instead of just /

However, I am also going to raise a bug/feature request to allow the setting of that value during an installation since a manual install can place it anywhere and I can't see (at the moment) any point during the install that updates or sets this. At the very least, it should point out the issue during the installation by checking the path of the /cacti/install folder matches the url_path with the URL actually used.

cezario2009
Posts: 11
Joined: Mon Dec 11, 2017 7:26 am

Re: Requested URL /cacti was not found on this server

#11 Post by cezario2009 » Wed Dec 20, 2017 1:25 pm

markv wrote:paulgevers maintains a backport of cacti for ubuntu/debian (his signature has the details if you click on his name). Using that would seem to have been easier to install cacti as it does most of this work for you.

However, in your case, you will also need to check that the configuration file has the correct path set for $url_path in the include/config.php file. This will most likely be set to "/cacti/" and needs changing to just "/"

ie, from:

Code: Select all

/* set the $url_path to point to the default URL of your cacti
 * install ex: if your cacti install as at
 * http://serverip/cacti/ this would be set to /cacti/.
*/

$url_path = '/cacti/';
To:

Code: Select all

/* set the $url_path to point to the default URL of your cacti
 * install ex: if your cacti install as at
 * http://serverip/cacti/ this would be set to /cacti/.
*/

$url_path = '/';
Thank you very much for the help, it's working now!


Post Reply