zond plug-in v0.34c released

General discussion about Plugins for Cacti

Moderators: Moderators, Developers

Post Reply
Author
Message
jenchingyang
Posts: 18
Joined: Wed Jul 20, 2005 8:44 am

#121 Post by jenchingyang » Wed Mar 18, 2009 3:29 am

I found the root cause and solved it. In Cacti setting->Paths.
section: Structured RRD Path.
uncheck "Structured RRA Path (/host_id/local_data_id.rrd)".
Everything work well.


jenchingyang wrote:
dononeil wrote:I just tried installing zond as well... blank windows for me too, both under firefox and IE7.

I'm running Jave 6, so that's not an issue, no erros showing in the console log for Java.

Any ideas on how to get it to work?

Running Cacti 0.8.7b
johnrembo wrote:
johnrembo wrote: i'll check it asap
please, try v0.34c.
In case of failure you should supply more details - check your web server's logs for php errors, see blank window source code (ctrl+u with FF), check zond plugin with different graph templates and don't forget to read requirements at 1st post on 1st page this topic.
Hello,
I installed zond v0.34c on CentOS5.2, Used zond to view realtime graph(memory usage, load average,logged in users) for localhost(127.0.0.1) is no problem.

but unable to view other hosts. I got blank windows, try to create one new device CentOS52(127.0.0.0,same IP with localhost) and use same graph template. but the result also failed(only saw blank windows). any idea?

ERROR INFO: returned incorrect data values count! (0 instead of 2 records)

I am using
Cacti Version - 0.8.7d
Plugin Architecture - 2.4
Poller Type - CMD.php
Server Info - CentOS5.2
Web Server - Apache/HTTPD2.2.3-11 for CentOS5.2
PHP - 5.2.9
MySQL - 5.1.32
RRDTool - 1.2.30
SNMP - 5.3.1-24


for locahost(127.0.0.1) Memory Usage. use Zond is normal
network: 伺服器 http://10.xx.xxx.xxx/cacti/plugins/zond ... ToiYiI7fX0. 要求以 "Cacti=5j2uoi5jhlpl0g704pauij3dc5; path=/" 來 set-cookie
network: 找不到快取記憶體項目 [url:http://10.xx.xxx.xxx/cacti/plugins/zond ... ToiYiI7fX0.,版本:null]
network: 使用 Proxy DIRECT 來連接 http://10.xx.xxx.xxx/cacti/plugins/zond ... ToiYiI7fX0.
network: 使用 Proxy DIRECT 來連接 http://10.xx.xxx.xxx:80/
network: 使用 Cookie "Cacti=5j2uoi5jhlpl0g704pauij3dc5; clickedFolder=tree_1%5Etree_1_leaf_9%5Etree_1_leaf_7%5E; highlightedTreeviewLink=tree_1_leaf_7" 來連接 http://10.xx.xxx.xxx/cacti/plugins/zond ... ToiYiI7fX0.


for CentOS52(127.0.0.1) Memory Usage. use Zond is abnormal(show blank window)

network: 伺服器 http://10.xx.xxx.xxx/cacti/plugins/zond ... QsKiI7fX19 要求以 "Cacti=5j2uoi5jhlpl0g704pauij3dc5; path=/" 來 set-cookie
Script [http://10.xx.xxx.xxx/cacti/plugins/zond ... QsKiI7fX19] returned incorrect data values count! (0 instead of 2 records)
network: 找不到快取記憶體項目 [url:http://10.xx.xxx.xxx/cacti/plugins/zond ... QsKiI7fX19,版本:null]
network: 使用 Proxy DIRECT 來連接 http://10.xx.xxx.xxx/cacti/plugins/zond ... QsKiI7fX19
network: 使用 Proxy DIRECT 來連接 http://10.xx.xxx.xxx:80/
network: 使用 Cookie "Cacti=5j2uoi5jhlpl0g704pauij3dc5; clickedFolder=tree_1%5Etree_1_leaf_9%5Etree_1_leaf_7%5E; highlightedTreeviewLink=tree_1_leaf_9" 來連接 http://10.xx.xxx.xxx/cacti/plugins/zond ... QsKiI7fX19


bonj87
Cacti User
Posts: 92
Joined: Fri Mar 26, 2010 7:42 am

#122 Post by bonj87 » Fri Apr 02, 2010 9:34 am

I may be late to the party.. but i just got cacti up and running.. this plug in is something i really want.. does it work in the latest CACTI version?

User avatar
johnrembo
Cacti User
Posts: 216
Joined: Mon Apr 24, 2006 3:33 am

#123 Post by johnrembo » Tue Apr 06, 2010 12:23 pm

bonj87 wrote:I may be late to the party.. but i just got cacti up and running.. this plug in is something i really want.. does it work in the latest CACTI version?
hmm...tried running it some half a year ago and it went fluently. However, please read the notes in the very first post - there might have been some updates in snmp packages or java runtime since then(ucd snmp, net snmp or even windows native snmp - whatever your servers being monitored are using) - that's one of the major reasons I'm not supporting this plugin anymore.
[url=http://forums.cacti.net/viewtopic.php?t=24934&highlight=zond]zond plugin[/url]
[url=http://forums.cacti.net/viewtopic.php?t=28384]memorize plugin[/url]
[url=http://forums.cacti.net/viewtopic.php?p=141322#141322]transporter plugin[/url]

blueroy81
Posts: 1
Joined: Tue Jul 29, 2008 5:30 pm

Re: zond plug-in v0.34c released

#124 Post by blueroy81 » Thu Nov 11, 2010 6:04 pm

I am receiving the following errors when attempting to launch Zond:

Cacti - 0.8.7g
PIA - 2.9
Zond - 0.34c

Notice: Undefined index: vertical-label in C:\Apache2.2\htdocs\cacti\plugins\zond\zond_init.php on line 402

Notice: Undefined index: vertical-label in C:\Apache2.2\htdocs\cacti\plugins\zond\zond_init.php on line 409

Notice: Undefined variable: display in C:\Apache2.2\htdocs\cacti\plugins\zond\zond_init.php on line 428

Warning: Invalid argument supplied for foreach() in C:\Apache2.2\htdocs\cacti\plugins\zond\zond_init.php on line 428

Notice: Undefined variable: legend_widths in C:\Apache2.2\htdocs\cacti\plugins\zond\zond_init.php on line 508

Warning: Invalid argument supplied for foreach() in C:\Apache2.2\htdocs\cacti\plugins\zond\zond_init.php on line 508

Notice: Undefined variable: item_strings in C:\Apache2.2\htdocs\cacti\plugins\zond\zond_init.php on line 593

Warning: Invalid argument supplied for foreach() in C:\Apache2.2\htdocs\cacti\plugins\zond\zond_init.php on line 593

Notice: Undefined variable: item_strings in C:\Apache2.2\htdocs\cacti\plugins\zond\zond_init.php on line 596

Warning: implode() [function.implode]: Invalid arguments passed in C:\Apache2.2\htdocs\cacti\plugins\zond\zond_init.php on line 596

Post Reply