zond plug-in v0.34c released

General discussion about Plugins for Cacti

Moderators: Moderators, Developers

Post Reply
Author
Message
slech
Cacti User
Posts: 90
Joined: Tue Nov 06, 2007 7:51 am

#31 Post by slech » Fri Dec 28, 2007 2:53 pm

It's work fine with Safari
Image
[size=75]
[color=green]|Cacti 0.87|[/color][color=green]|PA 1.3|[/color][color=green]|Poller cmd.php|[/color][color=green]|IIS 6.0|[/color][color=green]|PHP Version 5.2.4|[/color][color=green]|MySQL 5.0.27|[/color][color=green]|RRDtool 1.2.15|[/color][/size]
[color=brown]|Thold 0.3.8 |[/color] [color=red]|Zond 0.34 |[/color]
[url=http://forums.cacti.net/viewtopic.php?t=15067][size=75]Complete List of Cacti Scripts and Templates[/size][/url]
[url=http://forums.cacti.net/viewtopic.php?t=14985][size=75]Currently Known Plugins[/size][/url]

User avatar
johnrembo
Cacti User
Posts: 216
Joined: Mon Apr 24, 2006 3:33 am

#32 Post by johnrembo » Sat Dec 29, 2007 7:27 am

I've recently uploaded a new version.

chrisgapske, slech, apperault, cliles, tarpat1 - could you please check if errors you have reported are still present?

if so - I am waiting of your debugs (instructions on doing this are at http://www.netzond.com/netzond/debug/debug.html)

thank you for collaboration!

slech
Cacti User
Posts: 90
Joined: Tue Nov 06, 2007 7:51 am

#33 Post by slech » Sat Dec 29, 2007 9:03 am

Thanks for work !

Zond 0.34a
Themes not work

1.8 CPU box - complicated graphs
Image

unknown variable("") type(string) !

2. Loged in Users - simple graphs
Image

Array

3. 1 Cpu Load
Image

Debug don't return any data



This help to identify graph
This is the same with parametr to zond_init.php ?
Image
Attachments
1cpu.txt
(887 Bytes) Downloaded 211 times
logedinusers.txt
(614 Bytes) Downloaded 208 times
8cpulog.txt
(3.44 KiB) Downloaded 227 times
Last edited by slech on Sat Dec 29, 2007 10:22 am, edited 4 times in total.
[size=75]
[color=green]|Cacti 0.87|[/color][color=green]|PA 1.3|[/color][color=green]|Poller cmd.php|[/color][color=green]|IIS 6.0|[/color][color=green]|PHP Version 5.2.4|[/color][color=green]|MySQL 5.0.27|[/color][color=green]|RRDtool 1.2.15|[/color][/size]
[color=brown]|Thold 0.3.8 |[/color] [color=red]|Zond 0.34 |[/color]
[url=http://forums.cacti.net/viewtopic.php?t=15067][size=75]Complete List of Cacti Scripts and Templates[/size][/url]
[url=http://forums.cacti.net/viewtopic.php?t=14985][size=75]Currently Known Plugins[/size][/url]

slech
Cacti User
Posts: 90
Joined: Tue Nov 06, 2007 7:51 am

#34 Post by slech » Sat Dec 29, 2007 9:49 am

Zond 0.34 work but not corect
Image
[size=75]
[color=green]|Cacti 0.87|[/color][color=green]|PA 1.3|[/color][color=green]|Poller cmd.php|[/color][color=green]|IIS 6.0|[/color][color=green]|PHP Version 5.2.4|[/color][color=green]|MySQL 5.0.27|[/color][color=green]|RRDtool 1.2.15|[/color][/size]
[color=brown]|Thold 0.3.8 |[/color] [color=red]|Zond 0.34 |[/color]
[url=http://forums.cacti.net/viewtopic.php?t=15067][size=75]Complete List of Cacti Scripts and Templates[/size][/url]
[url=http://forums.cacti.net/viewtopic.php?t=14985][size=75]Currently Known Plugins[/size][/url]

tarpat1
Posts: 17
Joined: Sun Jan 01, 2006 11:39 pm

#35 Post by tarpat1 » Sun Dec 30, 2007 12:05 am

Looks pretty good on my end. I will know better when the network has more of a traffic load on it. Thanks for the quick update!

User avatar
johnrembo
Cacti User
Posts: 216
Joined: Mon Apr 24, 2006 3:33 am

#36 Post by johnrembo » Sun Dec 30, 2007 4:15 pm

slech wrote:Zond 0.34 work but not corect
is this a default (built-in) logged-in users cacti template?

i've tried the one on all of my test platforms - works like a charm. this is very strange.

ps: Because of my fault i have left two mistakes realated to snmp-gauges in v.34a. I've corrected them and reuploaded v0.34a. So you can try once-again.

User avatar
johnrembo
Cacti User
Posts: 216
Joined: Mon Apr 24, 2006 3:33 am

#37 Post by johnrembo » Sun Dec 30, 2007 4:18 pm

slech wrote:Thanks for work !

Zond 0.34a
Themes not work

Debug don't return any data
slech, I appretiate your help!

as I have allready replied - you have revealed one mistake realated to snmp-gauges. can you please try reuploaded v0.34a?

User avatar
chrisgapske
Cacti User
Posts: 278
Joined: Tue May 22, 2007 7:56 am
Location: Pensacola, Fl - Padacuh, Ky-Alpena, MI-Gulf Shores,AL

johnrembo you are the man I will be testing this wednesday.

#38 Post by chrisgapske » Mon Dec 31, 2007 4:30 pm

You know you are great at what you do.

Is there anyway you could use a diffrent reveision when you release a new version. I keep having a hard time tracking them.

If not no worries. But it would be great if you could.


johnrembo wrote:
slech wrote:Thanks for work !

Zond 0.34a
Themes not work

Debug don't return any data
slech, I appretiate your help!

as I have allready replied - you have revealed one mistake realated to snmp-gauges. can you please try reuploaded v0.34a?

User avatar
johnrembo
Cacti User
Posts: 216
Joined: Mon Apr 24, 2006 3:33 am

Re: johnrembo you are the man I will be testing this wednesd

#39 Post by johnrembo » Wed Jan 02, 2008 5:37 am

chrisgapske wrote:You know you are great at what you do.
Is there anyway you could use a diffrent reveision when you release a new version. I keep having a hard time tracking them.

If not no worries. But it would be great if you could.
slech wrote:Thanks for work !
no problems, I will upload all the archived versions at netzond.com and will let you know. But i'll be able to do that only from 7th of january (I have several day vacancies).

KyRoo
Cacti User
Posts: 51
Joined: Fri Oct 19, 2007 10:19 am

#40 Post by KyRoo » Thu Jan 03, 2008 6:50 am

johnrembo wrote:I've recently uploaded a new version.

chrisgapske, slech, apperault, cliles, tarpat1 - could you please check if errors you have reported are still present?

if so - I am waiting of your debugs (instructions on doing this are at http://www.netzond.com/netzond/debug/debug.html)

thank you for collaboration!
The problem with the wrong config is stil in the new version.
Can i do anything to help you.

I've tried to use apache instead of iis and there was no change.
I tried versions 0.31 and 0.32 and they both give this screen.
Attachments
32.JPG
32.JPG (13.21 KiB) Viewed 6591 times

User avatar
johnrembo
Cacti User
Posts: 216
Joined: Mon Apr 24, 2006 3:33 am

#41 Post by johnrembo » Fri Jan 04, 2008 2:46 am

KyRoo wrote:
The problem with the wrong config is stil in the new version.
Can i do anything to help you.

I've tried to use apache instead of iis and there was no change.
I tried versions 0.31 and 0.32 and they both give this screen.
versions prior to 0.33 are not compatible with cacti 0.8.7.
could you please give me
java-console output
zond_init.php output
and zond_process.php output (if zond_init.php output is present). Instructions on doing this are here http://www.netzond.com/netzond/debug/debug.html

thank you

KyRoo
Cacti User
Posts: 51
Joined: Fri Oct 19, 2007 10:19 am

#42 Post by KyRoo » Fri Jan 04, 2008 8:56 am

i'm not useing 0.7.8 yet...

Code: Select all

C:\php>php.exe C:\Inetpub\wwwroot\cacti\plugins\zond\zond_init.php 93

Fatal error: Call to undefined function input_validate_input_number() in C:\Inet
pub\wwwroot\cacti\plugins\zond\zond_init.php on line 57

Code: Select all

Java Plug-in 1.6.0_03
Using JRE version 1.6.0_03 Java HotSpot(TM) Client VM
User home directory = C:\Documents and Settings\????


----------------------------------------------------
c:   clear console window
f:   finalize objects on finalization queue
g:   garbage collect
h:   display this help message
l:   dump classloader list
m:   print memory usage
o:   trigger logging
p:   reload proxy configuration
q:   hide console
r:   reload policy configuration
s:   dump system and deployment properties
t:   dump thread list
v:   dump thread stack
x:   clear classloader cache
0-5: set trace level to <n>
----------------------------------------------------

netZOND charting applet v 1.03
Author johnrembo (aka [email protected])
© www.netzond.com
Exception in thread "AWT-EventQueue-2" java.lang.NumberFormatException: For input string: "<br />"
	at sun.misc.FloatingDecimal.readJavaFormatString(Unknown Source)
	at java.lang.Double.parseDouble(Unknown Source)
	at netzond.a(Unknown Source)
	at netzond.paint(Unknown Source)
	at sun.awt.RepaintArea.paintComponent(Unknown Source)
	at sun.awt.RepaintArea.paint(Unknown Source)
	at sun.awt.windows.WComponentPeer.handleEvent(Unknown Source)
	at java.awt.Component.dispatchEventImpl(Unknown Source)
	at java.awt.Container.dispatchEventImpl(Unknown Source)
	at java.awt.Component.dispatchEvent(Unknown Source)
	at java.awt.EventQueue.dispatchEvent(Unknown Source)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
	at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.awt.EventDispatchThread.run(Unknown Source)
Exception in thread "AWT-EventQueue-2" java.lang.NumberFormatException: For input string: "<br />"
	at sun.misc.FloatingDecimal.readJavaFormatString(Unknown Source)
	at java.lang.Double.parseDouble(Unknown Source)
	at netzond.a(Unknown Source)
	at netzond.paint(Unknown Source)
	at netzond.update(Unknown Source)
	at sun.awt.RepaintArea.updateComponent(Unknown Source)
	at sun.awt.RepaintArea.paint(Unknown Source)
	at sun.awt.windows.WComponentPeer.handleEvent(Unknown Source)
	at java.awt.Component.dispatchEventImpl(Unknown Source)
	at java.awt.Container.dispatchEventImpl(Unknown Source)
	at java.awt.Component.dispatchEvent(Unknown Source)
	at java.awt.EventQueue.dispatchEvent(Unknown Source)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
	at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.awt.EventDispatchThread.run(Unknown Source)
Exception in thread "AWT-EventQueue-2" java.lang.NumberFormatException: For input string: "<br />"
	at sun.misc.FloatingDecimal.readJavaFormatString(Unknown Source)
	at java.lang.Double.parseDouble(Unknown Source)
	at netzond.a(Unknown Source)
	at netzond.paint(Unknown Source)
	at netzond.update(Unknown Source)
	at sun.awt.RepaintArea.updateComponent(Unknown Source)
	at sun.awt.RepaintArea.paint(Unknown Source)
	at sun.awt.windows.WComponentPeer.handleEvent(Unknown Source)
	at java.awt.Component.dispatchEventImpl(Unknown Source)
	at java.awt.Container.dispatchEventImpl(Unknown Source)
	at java.awt.Component.dispatchEvent(Unknown Source)
	at java.awt.EventQueue.dispatchEvent(Unknown Source)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
	at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.awt.EventDispatchThread.run(Unknown Source)
Exception in thread "AWT-EventQueue-2" java.lang.NumberFormatException: For input string: "<br />"
	at sun.misc.FloatingDecimal.readJavaFormatString(Unknown Source)
	at java.lang.Double.parseDouble(Unknown Source)
	at netzond.a(Unknown Source)
	at netzond.paint(Unknown Source)
	at netzond.update(Unknown Source)
	at sun.awt.RepaintArea.updateComponent(Unknown Source)
	at sun.awt.RepaintArea.paint(Unknown Source)
	at sun.awt.windows.WComponentPeer.handleEvent(Unknown Source)
	at java.awt.Component.dispatchEventImpl(Unknown Source)
	at java.awt.Container.dispatchEventImpl(Unknown Source)
	at java.awt.Component.dispatchEvent(Unknown Source)
	at java.awt.EventQueue.dispatchEvent(Unknown Source)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
	at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.awt.EventDispatchThread.run(Unknown Source)
Exception in thread "AWT-EventQueue-2" java.lang.NumberFormatException: For input string: "<br />"
	at sun.misc.FloatingDecimal.readJavaFormatString(Unknown Source)
	at java.lang.Double.parseDouble(Unknown Source)
	at netzond.a(Unknown Source)
	at netzond.paint(Unknown Source)
	at netzond.update(Unknown Source)
	at sun.awt.RepaintArea.updateComponent(Unknown Source)
	at sun.awt.RepaintArea.paint(Unknown Source)
	at sun.awt.windows.WComponentPeer.handleEvent(Unknown Source)
	at java.awt.Component.dispatchEventImpl(Unknown Source)
	at java.awt.Container.dispatchEventImpl(Unknown Source)
	at java.awt.Component.dispatchEvent(Unknown Source)
	at java.awt.EventQueue.dispatchEvent(Unknown Source)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
	at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.awt.EventDispatchThread.run(Unknown Source)
Exception in thread "AWT-EventQueue-2" java.lang.NumberFormatException: For input string: "<br />"
	at sun.misc.FloatingDecimal.readJavaFormatString(Unknown Source)
	at java.lang.Double.parseDouble(Unknown Source)
	at netzond.a(Unknown Source)
	at netzond.paint(Unknown Source)
	at netzond.update(Unknown Source)
	at sun.awt.RepaintArea.updateComponent(Unknown Source)
	at sun.awt.RepaintArea.paint(Unknown Source)
	at sun.awt.windows.WComponentPeer.handleEvent(Unknown Source)
	at java.awt.Component.dispatchEventImpl(Unknown Source)
	at java.awt.Container.dispatchEventImpl(Unknown Source)
	at java.awt.Component.dispatchEvent(Unknown Source)
	at java.awt.EventQueue.dispatchEvent(Unknown Source)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
	at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.awt.EventDispatchThread.run(Unknown Source)
Exception in thread "AWT-EventQueue-2" java.lang.NumberFormatException: For input string: "<br />"
	at sun.misc.FloatingDecimal.readJavaFormatString(Unknown Source)
	at java.lang.Double.parseDouble(Unknown Source)
	at netzond.a(Unknown Source)
	at netzond.paint(Unknown Source)
	at netzond.update(Unknown Source)
	at sun.awt.RepaintArea.updateComponent(Unknown Source)
	at sun.awt.RepaintArea.paint(Unknown Source)
	at sun.awt.windows.WComponentPeer.handleEvent(Unknown Source)
	at java.awt.Component.dispatchEventImpl(Unknown Source)
	at java.awt.Container.dispatchEventImpl(Unknown Source)
	at java.awt.Component.dispatchEvent(Unknown Source)
	at java.awt.EventQueue.dispatchEvent(Unknown Source)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
	at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.awt.EventDispatchThread.run(Unknown Source)
Exception in thread "AWT-EventQueue-2" java.lang.NumberFormatException: For input string: "<br />"
	at sun.misc.FloatingDecimal.readJavaFormatString(Unknown Source)
	at java.lang.Double.parseDouble(Unknown Source)
	at netzond.a(Unknown Source)
	at netzond.paint(Unknown Source)
	at netzond.update(Unknown Source)
	at sun.awt.RepaintArea.updateComponent(Unknown Source)
	at sun.awt.RepaintArea.paint(Unknown Source)
	at sun.awt.windows.WComponentPeer.handleEvent(Unknown Source)
	at java.awt.Component.dispatchEventImpl(Unknown Source)
	at java.awt.Container.dispatchEventImpl(Unknown Source)
	at java.awt.Component.dispatchEvent(Unknown Source)
	at java.awt.EventQueue.dispatchEvent(Unknown Source)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
	at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.awt.EventDispatchThread.run(Unknown Source)
Exception in thread "AWT-EventQueue-2" java.lang.NumberFormatException: For input string: "<br />"
	at sun.misc.FloatingDecimal.readJavaFormatString(Unknown Source)
	at java.lang.Double.parseDouble(Unknown Source)
	at netzond.a(Unknown Source)
	at netzond.paint(Unknown Source)
	at netzond.update(Unknown Source)
	at sun.awt.RepaintArea.updateComponent(Unknown Source)
	at sun.awt.RepaintArea.paint(Unknown Source)
	at sun.awt.windows.WComponentPeer.handleEvent(Unknown Source)
	at java.awt.Component.dispatchEventImpl(Unknown Source)
	at java.awt.Container.dispatchEventImpl(Unknown Source)
	at java.awt.Component.dispatchEvent(Unknown Source)
	at java.awt.EventQueue.dispatchEvent(Unknown Source)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
	at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.awt.EventDispatchThread.run(Unknown Source)
Exception in thread "AWT-EventQueue-2" java.lang.NumberFormatException: For input string: "<br />"
	at sun.misc.FloatingDecimal.readJavaFormatString(Unknown Source)
	at java.lang.Double.parseDouble(Unknown Source)
	at netzond.a(Unknown Source)
	at netzond.paint(Unknown Source)
	at netzond.update(Unknown Source)
	at sun.awt.RepaintArea.updateComponent(Unknown Source)
	at sun.awt.RepaintArea.paint(Unknown Source)
	at sun.awt.windows.WComponentPeer.handleEvent(Unknown Source)
	at java.awt.Component.dispatchEventImpl(Unknown Source)
	at java.awt.Container.dispatchEventImpl(Unknown Source)
	at java.awt.Component.dispatchEvent(Unknown Source)
	at java.awt.EventQueue.dispatchEvent(Unknown Source)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
	at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.awt.EventDispatchThread.run(Unknown Source)


Cacti Version - 0.8.6j
Plugin Architecture - 1.1
Poller Type - CMD.php
Server Info - Windows NT 5.2
Web Server - Apache/2.0.59 (Win32) PHP/5.2.4
PHP - 5.2.4
PHP Extensions - bcmath, calendar, com_dotnet, ctype, session, filter, ftp, hash, iconv, json, odbc, pcre, Reflection, date, libxml, standard, tokenizer, zlib, SimpleXML, dom, SPL, wddx, xml, xmlreader, xmlwriter, apache2handler, gd, mysql, snmp, sockets
MySQL - 5.0.45-community-nt
RRDTool - 1.2.15
SNMP - snmpwalk [OPTIONS] AGENT [OID]

Version: 5.4.1
Web: http://www.net-snmp.org/
Email: [email protected]

OPTIONS:
-h, --help display this help message
-H display configuration file directives understood
-v 1|2c|3 specifies SNMP version to use
-V, --version display package version number
SNMP Version 1 or 2c specific
-c COMMUNITY set the community string
SNMP Version 3 specific
-a PROTOCOL set authentication protocol (MD5|SHA)
-A PASSPHRASE set authentication protocol pass phrase
-e ENGINE-ID set security engine ID (e.g. 800000020109840301)
-E ENGINE-ID set context engine ID (e.g. 800000020109840301)
-l LEVEL set security level (noAuthNoPriv|authNoPriv|authPriv)
-n CONTEXT set context name (e.g. bridge1)
-u USER-NAME set security name (e.g. bert)
-x PROTOCOL set privacy protocol (DES)
-X PASSPHRASE set privacy protocol pass phrase
-Z BOOTS,TIME set destination engine boots/time
General communication options
-r RETRIES set the number of retries
-t TIMEOUT set the request timeout (in seconds)
Debugging
-d dump input/output packets in hexadecimal
-D TOKEN[,...] turn on debugging output for the specified TOKENs
(ALL gives extremely verbose debugging output)
General options
-m MIB[:...] load given list of MIBs (ALL loads everything)
-M DIR[:...] look in given list of directories for MIBs
-P MIBOPTS Toggle various defaults controlling MIB parsing:
u: allow the use of underlines in MIB symbols
c: disallow the use of "--" to terminate comments
d: save the DESCRIPTIONs of the MIB objects
e: disable errors when MIB symbols conflict
w: enable warnings when MIB symbols conflict
W: enable detailed warnings when MIB symbols conflict
R: replace MIB symbols from latest module
-O OUTOPTS Toggle various defaults controlling output display:
0: print leading 0 for single-digit hex characters
a: print all strings in ascii format
b: do not break OID indexes down
e: print enums numerically
E: escape quotes in string indices
f: print full OIDs on output
n: print OIDs numerically
q: quick print for easier parsing
Q: quick print with equal-signs
s: print only last symbolic element of OID
S: print MIB module-id plus last element
t: print timeticks unparsed as numeric integers
T: print human-readable text along with hex strings
u: print OIDs using UCD-style prefix suppression
U: don't print units
v: print values only (not OID = value)
x: print all strings in hex format
X: extended index format
-I INOPTS Toggle various defaults controlling input parsing:
b: do best/regex matching to find a MIB node
h: don't apply DISPLAY-HINTs
r: do not check values for range/type legality
R: do random access to OID labels
u: top-level OIDs must have '.' prefix (UCD-style)
s SUFFIX: Append all textual OIDs with SUFFIX before parsing
S PREFIX: Prepend all textual OIDs with PREFIX before parsing
-L LOGOPTS Toggle various defaults controlling logging:
e: log to standard error
o: log to standard output
n: don't log at all
f file: log to the specified file
s facility: log to syslog (via the specified facility)

(variants)
[EON] pri: log to standard error, output or /dev/null for level 'pri' and above
[EON] p1-p2: log to standard error, output or /dev/null for levels 'p1' to 'p2'
[FS] pri token: log to file/syslog for level 'pri' and above
[FS] p1-p2 token: log to file/syslog for levels 'p1' to 'p2'
-C APPOPTS Set various application specific behaviours:
p: print the number of variables found
i: include given OID in the search range
I: don't include the given OID, even if no results are returned
c: do not check returned OIDs are increasing
t: Display wall-clock time to complete the request
Plugins
  • Thresholds (thold - v0.3.5.2)
    Global Plugin Settings (settings - v0.3)
    Device Monitoring (monitor - v0.7)
    PHP Network Managing (manage - v0.5.1)
    Create Aggregate Graphs (aggregate - v0.63)
    PHP Network Weathermap (weathermap - v0.93)
    Network Tools (tools - v0.2)
    Host Info (hostinfo - v0.2)
    Real-time statistics (zond - v0.3)

cliles
Posts: 4
Joined: Wed Dec 26, 2007 12:09 pm

#43 Post by cliles » Fri Jan 04, 2008 4:38 pm

johnrembo wrote:I've recently uploaded a new version.

chrisgapske, slech, apperault, cliles, tarpat1 - could you please check if errors you have reported are still present?

if so - I am waiting of your debugs (instructions on doing this are at http://www.netzond.com/netzond/debug/debug.html)

thank you for collaboration!
Here is my debug info:

When looking at the java console I get "Data received successfuly" <-- typo?

When running zond_process.php I am getting:
73610752
63764384

If I roll back to the older plugin version I get the following from zond_process.php:
1073610752
68034848

So I can figure out that for the Jboss memory graphs the 1st number is the "free memory available" and the 2nd number is the "memory used".
The older version of the plugin is reporting correct numbers while the newest version posted in this thread does not.

My static cacti graphs are always correct.

What else can I do to help debug this issue?

myfreeke
Cacti User
Posts: 82
Joined: Tue Dec 04, 2007 10:24 pm

#44 Post by myfreeke » Tue Jan 08, 2008 4:49 am

I use cacti 0.8.7a

use zond no working
Attachments
zond-errorlog.TXT
(132.48 KiB) Downloaded 519 times
zend no work error.JPG
zend no work error.JPG (66.58 KiB) Viewed 6463 times

User avatar
timi
Cacti User
Posts: 240
Joined: Wed Nov 09, 2005 8:35 am
Location: Timisoara, Romania
Contact:

#45 Post by timi » Wed Jan 09, 2008 3:15 am

works for me, awesome plugin :)
10x

Post Reply