SNMPAgent not working on V1.0.X

General discussion about Plugins for Cacti

Moderators: Moderators, Developers

Post Reply
Author
Message
thubbard
Posts: 3
Joined: Wed Feb 22, 2017 12:36 pm

SNMPAgent not working on V1.0.X

#1 Post by thubbard » Wed Feb 22, 2017 2:27 pm

I've been trying to get the snmpagent plugin working, it would make a great replacement for a number of scripts I have running to gather stats on my various pollers. I know that's it's considered part of Cacti now, and I never tried to use it when it was a plugin.

It seems like it should be pretty easy to get going, put a pass_persist line in my /etc/snmp/snmpd.conf, make sure permissions on the <cacti>/snmpagent_*.php files are correct, restart the snmpd service. This is the line I put in the file:

pass_persist .1.3.6.1.4.1.23925 /data/cactiapp/cacti/snmpagent_persist.php

After restarting my snmpd service, I see this:

[[email protected] snmp]# ps -ef | grep snmp
root 20319 1 0 18:55 ? 00:00:01 /usr/sbin/snmpd -LS0-6d -f
root 20329 20319 0 18:56 ? 00:00:00 /usr/bin/php /data/cactiapp/cacti/snmpagent_persist.php
root 20336 1 0 18:56 ? 00:00:00 /bin/php -q ./snmpagent_mibcache.php

But when I try to poll it:

[[email protected] snmp]# snmpwalk -v2c -c****** localhost .1.3.6.1.4.1.23925
SNMPv2-SMI::enterprises.23925 = No Such Instance currently exists at this OID

Additionally, it keeps launching new processes as time goes by, so much so that I end up out of memory after a day. Finally, I get this in my cacti.log every 30 seconds:

2017-02-22 19:26:30 - CMDPHP PHP ERROR NOTICE Backtrace: (/snmpagent_mibcachechild.php: 47 CactiErrorHandler)(/lib/functions.php: 4242 cacti_debug_backtrace)
2017-02-22 19:26:30 - ERROR PHP NOTICE: Undefined variable: snmpagent in file: /data/cactiapp/cacti-1.0.2/snmpagent_mibcachechild.php on line: 47

Does anyone have this working against a V1.0.X install?

Thanks

User avatar
browniebraun
Developer
Posts: 788
Joined: Tue Jun 13, 2006 1:17 am
Location: Cologne, Germany

Re: SNMPAgent not working on V1.0.X

#2 Post by browniebraun » Mon Feb 27, 2017 6:39 pm

Hi thubbard,

I've just read your note and committed a bug fix addressing that issue.
https://github.com/Cacti/cacti/commit/5 ... 02e2eff9ed

Regards
-Andi
Hat das Blümchen einen Knick, war der Schmetterling zu dick! ;)
reportit v0.7.5a
SNMPAgent v0.2.3
Download ReportIt | Download SNMPAgent | ReportIt SVN | ReportIt Templates | Wish list

thubbard
Posts: 3
Joined: Wed Feb 22, 2017 12:36 pm

Re: SNMPAgent not working on V1.0.X

#3 Post by thubbard » Wed Apr 12, 2017 6:10 pm

I upgraded to 1.1.2 recently, and it does appear that this works now, sort of.

It does return values when I run an snmpwalk against the CACTI-MIB root OID.

However, it doesn't populate any of the performance counters (poller time, RRDs processed, etc.) for pollers other than the master that hosts the database. I'm trying to dig into the code to figure out why.

User avatar
Osiris
Cacti Pro User
Posts: 863
Joined: Mon Jan 05, 2015 10:10 am

Re: SNMPAgent not working on V1.0.X

#4 Post by Osiris » Tue Apr 25, 2017 7:11 pm

Maybe that belongs in GitHub?
Before history, there was a paradise, now dust.

User avatar
jt555
Cacti User
Posts: 54
Joined: Sat Nov 17, 2007 3:37 pm
Location: Atlanta, Ga

Re: SNMPAgent not working on V1.0.X

#5 Post by jt555 » Thu Oct 11, 2018 3:17 pm

Should the Cacti SNMPAgent be able to send THOLD traps in 1.1.37?

Post Reply