Sending SMTP test message error

General discussion about Plugins for Cacti

Moderators: Moderators, Developers

Post Reply
Author
Message
tung2000
Posts: 12
Joined: Thu Mar 29, 2012 8:44 am

Sending SMTP test message error

#1 Post by tung2000 » Mon May 07, 2012 3:49 am

I can't send test message using SMTP. I got the error as follows :
Unable to connect to SMTP Host 'mailhub.wharftt.com': (13) Permission denied

Then, I try to telnet to Cacti and then telnet to SMTP server port 25 to test SMTP operation by SMTP commands like helo, mail from: rcpt to:, data. I can get the e-mail.

Why Cacti can't send the test mail? Please advise.

Thanks!
Attachments
Cacti SMTP.JPG
Cacti SMTP.JPG (32.93 KiB) Viewed 3305 times

Swiftie
Posts: 6
Joined: Thu Feb 23, 2012 5:16 pm

Re: Sending SMTP test message error

#2 Post by Swiftie » Mon May 07, 2012 4:27 pm

This is more than likely an authentication issue for the SMTP server. Could be a required username and password to authenticate or wrong port.

tung2000
Posts: 12
Joined: Thu Mar 29, 2012 8:44 am

Re: Sending SMTP test message error

#3 Post by tung2000 » Mon May 07, 2012 8:20 pm

My SMTP server won't require authentication and use port 25.

Swiftie
Posts: 6
Joined: Thu Feb 23, 2012 5:16 pm

Re: Sending SMTP test message error

#4 Post by Swiftie » Wed May 16, 2012 6:24 pm

tung2000 wrote:My SMTP server won't require authentication and use port 25.
Can you tey telnet to the server mailhub.wharftt.com port 25?

tung2000
Posts: 12
Joined: Thu Mar 29, 2012 8:44 am

Re: Sending SMTP test message error

#5 Post by tung2000 » Wed May 16, 2012 8:40 pm

Yes, I can

villieb
Cacti User
Posts: 75
Joined: Fri Nov 09, 2012 5:14 am

Re: Sending SMTP test message error

#6 Post by villieb » Tue Feb 05, 2013 11:10 am

Hi - did you get this working? I'm experiencing the same issue...

nandozzi
Posts: 34
Joined: Sun Nov 25, 2012 6:44 am

Re: Sending SMTP test message error

#7 Post by nandozzi » Fri Feb 15, 2013 8:40 am

I have encountered the same problem and if you have a mail server you need to accept Unknown Client.
Cacti use a non standard email client and a lot of mail server doesn't accept it.
It's not a problem of authentication, but simple your email client is not recognized.
If you try to use the same settings with a client like Outlook, i am sure you haven't any problem :)

nandozzi
Posts: 34
Joined: Sun Nov 25, 2012 6:44 am

Re: Sending SMTP test message error

#8 Post by nandozzi » Fri Feb 15, 2013 8:40 am

Admin please delete this message.... It's a double... :D
Last edited by nandozzi on Fri Feb 15, 2013 8:40 am, edited 1 time in total.

villieb
Cacti User
Posts: 75
Joined: Fri Nov 09, 2012 5:14 am

Re: Sending SMTP test message error

#9 Post by villieb » Thu Feb 21, 2013 11:22 am

I found disabling SELINUX did the trick...

Run this command to see if it is running:

selinuxenabled && echo enabled || echo disabled

To disable SELINUX temporarily:
echo 0 > /selinux/enforce

To make the disabling of SELINUX permanent, edit /etc/selinux/config and change the line SELINUS="enabled" to disabled

User avatar
gandalf
Developer
Posts: 22375
Joined: Thu Dec 02, 2004 2:46 am
Location: Muenster, Germany
Contact:

Re: Sending SMTP test message error

#10 Post by gandalf » Wed Mar 06, 2013 3:00 pm

There are SELinux bolleans that rule sending SMTP bia HTTP. You may want to dive into this
R.

Post Reply