SMTP Authentication error 220

General discussion about Plugins for Cacti

Moderators: Moderators, Developers

Post Reply
Author
Message
Dwalk55
Posts: 1
Joined: Tue Sep 06, 2016 10:12 am

SMTP Authentication error 220

#1 Post by Dwalk55 » Tue Sep 06, 2016 10:32 am

I have a server on a clients network where they are now requiring me to enable SMTP Authentication. Using method SMTP, I added the username and password provide...When I run the test I can see authentication = true and it shows the correct username (pw blanked), but I get a 220 error stating SMTP Authentication required...I get the same message if I use an invalid username or password...I know the account and email server I'm sending to work correctly as I installed a lightweight SendEmail client and can successfully send email using the credentials supplied....I've seen a few similar posts, but haven't seen a working solution.

Is there some add'l setup for this that I'm missing?

Using cacti 0.8.7i on OEL 6.2

creiglee
Posts: 1
Joined: Mon Mar 19, 2018 11:48 pm

Re: SMTP Authentication error 220

#2 Post by creiglee » Mon Mar 19, 2018 11:51 pm

It is because Google blocks sign-in attempts from apps which do not use modern security standards (mentioned on their support page). You can however, turn on/off this safety feature by going to the link below:

Go to this link and select Turn On

https://www.google.com/settings/security/lesssecureapps

Moreover google block an ip when you try to send a email since a unusual location, so, you can unblock in the next link

https://support.google.com/accounts/answer/6009563

and clicked in

accounts.google.com/DisplayUnlockCaptcha .

http://net-informations.com/python/net/email.htm

Post Reply