Weathermap Pluings missing and editor giving 401 error

General discussion about Plugins for Cacti

Moderators: Moderators, Developers

Post Reply
Author
Message
dp0729
Posts: 2
Joined: Tue Sep 11, 2018 7:39 pm

Weathermap Pluings missing and editor giving 401 error

#1 Post by dp0729 » Tue Sep 11, 2018 8:01 pm

Hi,

I have upgraded cacti from 0.8.8b to 0.8.8f and weathermap from 0.97a to 0.98, but now I can't see weathermap plugins at all but when I enter http://myserver/cacti/plugins/weatherma ... plugin.php, I can see all my maps. Also, when I click on 'Editor', its giving me 401 error. I need to fix this ASAP as we need to add new monitoring and I cant find any solution.

Any advice will be appreciated.
weathermap_1.JPG
missing weathermap plugins
weathermap_1.JPG (33.04 KiB) Viewed 359 times
weathermap_2.JPG
error 401
weathermap_2.JPG (45.57 KiB) Viewed 359 times

netniV
Cacti Guru User
Posts: 2686
Joined: Sun Aug 27, 2017 12:05 am

Re: Weathermap Pluings missing and editor giving 401 error

#2 Post by netniV » Wed Sep 12, 2018 1:45 am

Goto Settings -> Users, add the plugin realm to the users who should have access.

dp0729
Posts: 2
Joined: Tue Sep 11, 2018 7:39 pm

Re: Weathermap Pluings missing and editor giving 401 error

#3 Post by dp0729 » Wed Sep 12, 2018 6:44 pm

Thanks netbiV, I have given full permission to user but still same error.
weathermap_3.JPG
permission is already there
weathermap_3.JPG (39.2 KiB) Viewed 339 times

netniV
Cacti Guru User
Posts: 2686
Joined: Sun Aug 27, 2017 12:05 am

Re: Weathermap Pluings missing and editor giving 401 error

#4 Post by netniV » Thu Sep 13, 2018 5:36 am

Then unfortunately, i'm at a loss and I don't really support 0.8.8 as I never used anything before 1.x (and things changed quite a bit there). Normally, I would say look at all the auth tables, check all the ID's, etc. but I'm not even sure which tables you would have in that version.

Post Reply