Cacti (home)ForumsDocumentation
Cacti: offical forums and support
It is currently Wed Jun 26, 2019 11:28 am

All times are UTC - 5 hours




Post new topic Reply to topic  [ 2 posts ] 
Author Message
 Post subject: Without Username input in Router Config Plugin
PostPosted: Thu Nov 15, 2018 9:23 pm 
Offline

Joined: Thu Nov 15, 2018 9:17 pm
Posts: 1
Dear All,

At the router of Cisco IOS which I currently manage, when I log in to the router I am configuring to access by omitting Username input.
However, if you attempt to back up the router's configuration file with RoutertConfig, it ends with an error after repeating Username input.

Is there a way to make backups run without inputting Username?

Below is the log of the execution.

# php ./router-download.php --force --debug --device 1

2018/11/12 11:25:44 - RCONFIG NOTICE: Starting manual backup of 1 devices
2018/11/12 11:25:44 - RCONFIG DEBUG: SQL: SELECT * FROM plugin_routerconfigs_devices WHERE enabled = 'on' AND id IN (1)
2018/11/12 11:25:44 - RCONFIG DEBUG: Attempting download for Rrouter-A
2018/11/12 11:25:44 - RCONFIG DEBUG: Base64 decoded: a:3:{i:125234712;i:1233446688;s:8:"password";s:8:"(8: chars)";i:887536946;i:678470285;}
2018/11/12 11:25:44 - RCONFIG DEBUG: Base64 decoded: a:3:{i:42097039;i:889761133;s:8:"password";s:8:"(8: chars)";i:590968666;i:1364610510;}
2018/11/12 11:25:44 - RCONFIG 172.16.xxx.yyy -> DEBUG: Attempting to connect via Telnet
2018/11/12 11:25:44 - RCONFIG 172.16.xxx.yyy (Telnet) -> DEBUG: Creating Telnet(Server: 172.16.xxx.yyy, User: , Password: (8 chars), Enablepw: (8 chars), Devicetype: {"id":"2","name":"Cisco CatOS","username":"Password:","password":"Password:","copytftp":"copy config tftp","version":"","confirm":"y","sleep":"125000","timeout":"1","forceconfirm":"on","checkendinconfig":""}
2018/11/12 11:25:44 - RCONFIG 172.16.xxx.yyy (Telnet) -> DEBUG: Setting timeout to 1 second(s)
2018/11/12 11:25:44 - RCONFIG 172.16.xxx.yyy (Telnet) -> DEBUG: Setting sleep time to 125000 microsecond(s)
2018/11/12 11:25:44 - RCONFIG 172.16.xxx.yyy (Telnet) -> Disconnect()
2018/11/12 11:25:44 - RCONFIG 172.16.xxx.yyy (Telnet) -> Attempting to open socket to 172.16.xxx.yyy:23
2018/11/12 11:25:44 - RCONFIG 172.16.xxx.yyy (Telnet) -> Looking for Password:
2018/11/12 11:25:44 - RCONFIG 172.16.xxx.yyy (Telnet) -> DEBUG: <-- ・・
2018/11/12 11:25:44 - RCONFIG 172.16.xxx.yyy (Telnet) -> DEBUG: <--
2018/11/12 11:25:44 - RCONFIG 172.16.xxx.yyy (Telnet) -> DEBUG: <--
2018/11/12 11:25:44 - RCONFIG 172.16.xxx.yyy (Telnet) -> DEBUG: <--
2018/11/12 11:25:44 - RCONFIG 172.16.xxx.yyy (Telnet) -> DEBUG: <-- User Access Verification
2018/11/12 11:25:44 - RCONFIG 172.16.xxx.yyy (Telnet) -> DEBUG: <--
2018/11/12 11:25:44 - RCONFIG 172.16.xxx.yyy (Telnet) -> DEBUG: <--
2018/11/12 11:25:44 - RCONFIG 172.16.xxx.yyy (Telnet) -> DEBUG: <--
2018/11/12 11:25:45 - RCONFIG 172.16.xxx.yyy (Telnet) -> DEBUG: <-- Password:  ・・'
2018/11/12 11:25:45 - RCONFIG 172.16.xxx.yyy (Telnet) -> DEBUG: Found Prompt (Password)
2018/11/12 11:25:45 - RCONFIG 172.16.xxx.yyy (Telnet) -> DEBUG: No Prompt received (4: 1 : 3)
2018/11/12 11:25:45 - RCONFIG 172.16.xxx.yyy (Telnet) -> DEBUG: <--
2018/11/12 11:25:45 - RCONFIG 172.16.xxx.yyy (Telnet) -> DEBUG: <--
2018/11/12 11:25:45 - RCONFIG 172.16.xxx.yyy (Telnet) -> DEBUG: <-- Password:
2018/11/12 11:25:45 - RCONFIG 172.16.xxx.yyy (Telnet) -> DEBUG: Found Prompt (Password)
2018/11/12 11:25:45 - RCONFIG 172.16.xxx.yyy (Telnet) -> DEBUG: No Prompt received (4: 2 : 3)
2018/11/12 11:25:45 - RCONFIG 172.16.xxx.yyy (Telnet) -> DEBUG: <--
2018/11/12 11:25:45 - RCONFIG 172.16.xxx.yyy (Telnet) -> DEBUG: <--
2018/11/12 11:25:46 - RCONFIG 172.16.xxx.yyy (Telnet) -> DEBUG: <-- Password:
2018/11/12 11:25:46 - RCONFIG 172.16.xxx.yyy (Telnet) -> DEBUG: Found Prompt (Password)
2018/11/12 11:25:46 - RCONFIG 172.16.xxx.yyy (Telnet) -> DEBUG: No Prompt received (4: 3 : 3)
2018/11/12 11:25:46 - RCONFIG 172.16.xxx.yyy (Telnet) -> DEBUG: <--
2018/11/12 11:25:46 - RCONFIG 172.16.xxx.yyy (Telnet) -> DEBUG: <--
2018/11/12 11:25:46 - RCONFIG 172.16.xxx.yyy (Telnet) -> DEBUG: <-- % Bad passwords
2018/11/12 11:25:46 - RCONFIG 172.16.xxx.yyy (Telnet) -> DEBUG: <--
2018/11/12 11:25:47 - RCONFIG 172.16.xxx.yyy (Telnet) -> DEBUG: Timeout of 1 seconds has been reached
2018/11/12 11:25:47 - RCONFIG 172.16.xxx.yyy (Telnet) -> DEBUG: No Prompt received (0: 4 : 3)
2018/11/12 11:25:48 - RCONFIG 172.16.xxx.yyy (Telnet) -> DEBUG: Timeout of 1 seconds has been reached
2018/11/12 11:25:48 - RCONFIG 172.16.xxx.yyy (Telnet) -> DEBUG: No Prompt received (0: 5 : 3)
2018/11/12 11:25:49 - RCONFIG 172.16.xxx.yyy (Telnet) -> DEBUG: Timeout of 1 seconds has been reached
2018/11/12 11:25:49 - RCONFIG 172.16.xxx.yyy (Telnet) -> DEBUG: No Prompt received (0: 6 : 3)
2018/11/12 11:25:50 - RCONFIG 172.16.xxx.yyy (Telnet) -> DEBUG: Timeout of 1 seconds has been reached
2018/11/12 11:25:50 - RCONFIG 172.16.xxx.yyy (Telnet) -> DEBUG: No Prompt received (0: 7 : 3)
2018/11/12 11:25:51 - RCONFIG 172.16.xxx.yyy (Telnet) -> DEBUG: Timeout of 1 seconds has been reached
2018/11/12 11:25:51 - RCONFIG 172.16.xxx.yyy (Telnet) -> DEBUG: No Prompt received (0: 8 : 3)
2018/11/12 11:25:53 - RCONFIG 172.16.xxx.yyy (Telnet) -> DEBUG: Timeout of 1 seconds has been reached
2018/11/12 11:25:53 - RCONFIG 172.16.xxx.yyy (Telnet) -> DEBUG: No Prompt received (0: 9 : 3)
2018/11/12 11:25:54 - RCONFIG 172.16.xxx.yyy (Telnet) -> DEBUG: Timeout of 1 seconds has been reached
2018/11/12 11:25:54 - RCONFIG 172.16.xxx.yyy (Telnet) -> DEBUG: No Prompt received (0: 10 : 3)
2018/11/12 11:25:55 - RCONFIG 172.16.xxx.yyy (Telnet) -> DEBUG: Timeout of 1 seconds has been reached
2018/11/12 11:25:55 - RCONFIG ERROR: Failed to Connect to Device 'Rrouter-A' using connection type: telnet
2018/11/12 11:25:55 - RCONFIG NOTICE: Failed to download for Rrouter-A
2018/11/12 11:25:55 - RCONFIG WARNING: 0 Devices Backed Up, 1 Devices Failed, 0 Disabled (ignored) in 11 seconds
2018/11/12 11:25:55 - RCONFIG DEBUG: 0 devices backed up successfully.
2018/11/12 11:25:55 - RCONFIG DEBUG: 1 devices failed to backup.
2018/11/12 11:25:55 - RCONFIG STATS: Time:11.16 Downloaded:0 Failed:1
#


Top
 Profile  
 
 Post subject: Re: Without Username input in Router Config Plugin
PostPosted: Fri Nov 16, 2018 3:51 am 
Offline
Cacti Guru User

Joined: Sun Aug 27, 2017 12:05 am
Posts: 2523
I'm baffled why you would NOT have a username being input? If you were using SSH, I can understand that since you may be using SSH Keys (though i'm not sure routerconfigs supports that yet).

If you really need to use telnet without a username as an option, you'll need to open an issue on the GitHub repo for RouterConfigs so it can be followed up.

_________________
Official Cacti Developer

Cacti Resources:
Cacti Website (including releases)
Cacti Issues
Cacti Development Releases
Cacti Development Documentation

My resources:
How to submit Pull Requests
Development Wiki and How To's
Updated NetSNMP Memory template for Cacti 1.x
Cisco SFP template for Cacti 0.8.8


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 2 posts ] 

All times are UTC - 5 hours


Who is online

Users browsing this forum: No registered users and 9 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  

Protected by Anti-Spam ACP Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group