Error - ERROR: Device Type Not Found in Device Type Table.

Support questions about the MAC Track plugin

Moderators: Moderators, Developers

Post Reply
Author
Message
wiffleballtony
Posts: 4
Joined: Thu Mar 30, 2017 10:04 am

Error - ERROR: Device Type Not Found in Device Type Table.

#1 Post by wiffleballtony » Tue Apr 04, 2017 3:02 pm

Hi All,
I have a couple devices that refuse to work. The error according the log is: Device Type Not Found in Device Type Table. I added the respective device types to the device type section. I am not sure what is needed to rectify this. Please assist. Thanks!
Attachments
DeviceType.PNG
DeviceType.PNG (37.34 KiB) Viewed 1908 times
DeviceSNMP1.PNG
DeviceSNMP1.PNG (79.14 KiB) Viewed 1908 times
DeviceSNMP.PNG
DeviceSNMP.PNG (81.17 KiB) Viewed 1908 times
LogError.PNG
LogError.PNG (18.08 KiB) Viewed 1908 times

User avatar
XTech
Cacti User
Posts: 59
Joined: Sat May 26, 2012 9:25 pm

Re: Error - ERROR: Device Type Not Found in Device Type Tabl

#2 Post by XTech » Wed Apr 05, 2017 3:35 am

Try to clear "System Description Match" in device type definition form. The "Vendor SNMP object Match" should be enough for proper device detection.

wiffleballtony
Posts: 4
Joined: Thu Mar 30, 2017 10:04 am

Re: Error - ERROR: Device Type Not Found in Device Type Tabl

#3 Post by wiffleballtony » Wed Apr 05, 2017 1:49 pm

XTech wrote:Try to clear "System Description Match" in device type definition form. The "Vendor SNMP object Match" should be enough for proper device detection.
I removed the System Description Match however that did not resolve the issue. Still indicating that the Device Type not found in Device table.

User avatar
XTech
Cacti User
Posts: 59
Joined: Sat May 26, 2012 9:25 pm

Re: Error - ERROR: Device Type Not Found in Device Type Tabl

#4 Post by XTech » Thu Apr 06, 2017 12:39 am

Note absence of the leading dot in "Vendor SNMP object Match":
Real ObjectID for Cisco 2960X is .1.3.6.1.4.1.9.1.1208, and in your Device Profile is "1.3.6.1.4.1.9.1.1208".

wiffleballtony
Posts: 4
Joined: Thu Mar 30, 2017 10:04 am

Re: Error - ERROR: Device Type Not Found in Device Type Tabl

#5 Post by wiffleballtony » Tue Apr 11, 2017 11:03 am

XTech wrote:Note absence of the leading dot in "Vendor SNMP object Match":
Real ObjectID for Cisco 2960X is .1.3.6.1.4.1.9.1.1208, and in your Device Profile is "1.3.6.1.4.1.9.1.1208".
Thank you very much, that resolved it!

Post Reply