Need help with the dev version of weathermap

Support questions about the Network Weather Map plugin

Moderators: Moderators, Developers

Post Reply
Author
Message
coolcliff
Posts: 14
Joined: Wed Dec 20, 2017 3:51 am

Need help with the dev version of weathermap

#1 Post by coolcliff » Tue May 29, 2018 6:53 am

Hi

I have installed the dev version of weathermap, the plugin shows up in cacti v1.1.38, however it want allow me to add map --- a popup "loading" appears in a tiny box and nothing happens, the page displays the error "main.js:1 Uncaught (in promise) TypeError: t.data.map is not a function at main.js:1"

cannot create a new map, the create button does not work

i already have maps from previous version of cacti-0.8.8.a, is there some way i can get the maps to show up in the new weathermap, I've copied them to the config directory,

the ownership and permissions on the weathermap folder is apache and 775

Regards
Clifford

User avatar
Howie
Cacti Guru User
Posts: 5327
Joined: Thu Sep 16, 2004 5:53 am
Location: United Kingdom
Contact:

Re: Need help with the dev version of weathermap

#2 Post by Howie » Tue May 29, 2018 9:23 am

That's correct. It's not finished.
Weathermap 0.98 is out! & QuickTree 1.0. Superlinks is over there now (and built-in to Cacti 1.x).
Some Other Cacti tweaks, including strip-graphs, icons and snmp/netflow stuff.
(Let me know if you have UK DevOps or Network Ops opportunities, too!)

Post Reply