Cacti (home)ForumsDocumentation
Cacti: offical forums and support
It is currently Thu Aug 17, 2017 2:59 am

All times are UTC - 5 hours




Post new topic Reply to topic  [ 7 posts ] 
Author Message
 Post subject: Unable to save some arguments, maps not working
PostPosted: Wed Jan 04, 2017 10:13 am 
Offline

Joined: Sat Feb 20, 2016 12:53 pm
Posts: 26
Hi,

I started before my post
PHP Deprecated: Function split() is deprecated in

I did upgrade of Cacti now is: 0.8.8h
weathermap: 0.98

Any one is able to help me, because to be honest, don’t know what is going on.
From logs, I am unable to read something suspicious.


Quote:
[email protected]:/usr/share/cacti/site/plugins/weathermap# ./weathermap --debug --config configs/test2.conf
PHP Deprecated: Non-static method PEAR::isError() should not be called statically, assuming $this from incompatible context in /usr/share/php/Console/Getopt.php on line 109
PHP Deprecated: Non-static method PEAR::isError() should not be called statically, assuming $this from incompatible context in /usr/share/php/Console/Getopt.php on line 154
PHP Deprecated: Non-static method PEAR::isError() should not be called statically, assuming $this from incompatible context in /usr/share/php/Console/Getopt.php on line 154
DEBUG: [@weathermap:200] ------------------------------------
DEBUG: [@weathermap:201] Starting PHP-Weathermap run, with config: configs/test2.conf
DEBUG: [@weathermap:202] ------------------------------------
DEBUG: [[email protected]:346] Creating ':: DEFAULT ::' DEFAULT LINK
DEBUG: [[email protected]:119] Resetting :: DEFAULT :: with :: DEFAULT ::
DEBUG: [[email protected]:355] Creating ':: DEFAULT ::' DEFAULT NODE
DEBUG: [[email protected]:737] Resetting :: DEFAULT :: with :: DEFAULT ::
DEBUG: [[email protected]:373] Creating actual DEFAULT NODE from :: DEFAULT ::
DEBUG: [[email protected]:737] Resetting DEFAULT with :: DEFAULT ::
DEBUG: [[email protected]:761] Initialising NODE DEFAULT from :: DEFAULT ::
DEBUG: [[email protected]:381] Creating actual DEFAULT LINK from :: DEFAULT ::
DEBUG: [[email protected]:119] Resetting DEFAULT with :: DEFAULT ::
DEBUG: [[email protected]:145] Initialising LINK DEFAULT from :: DEFAULT ::
DEBUG: [[email protected]:406] Adding default map colour set.
DEBUG: [[email protected]:688] Beginning to load data plugins from lib/datasources
DEBUG: [[email protected]:736] Skipping WeatherMapDataSource_external.php.disabled
DEBUG: [[email protected]:711] Loading data Plugin class from WeatherMapDataSource_cactihost.php
DEBUG: [[email protected]:723] Loaded data Plugin class WeatherMapDataSource_cactihost from WeatherMapDataSource_cactihost.php
DEBUG: [[email protected]:731] Instantiated WeatherMapDataSource_cactihost.
DEBUG: [[email protected]:711] Loading data Plugin class from WeatherMapDataSource_mrtg.php
DEBUG: [[email protected]:723] Loaded data Plugin class WeatherMapDataSource_mrtg from WeatherMapDataSource_mrtg.php
DEBUG: [[email protected]:731] Instantiated WeatherMapDataSource_mrtg.
DEBUG: [[email protected]:711] Loading data Plugin class from WeatherMapDataSource_snmp.php
DEBUG: [[email protected]:723] Loaded data Plugin class WeatherMapDataSource_snmp from WeatherMapDataSource_snmp.php
DEBUG: [[email protected]:731] Instantiated WeatherMapDataSource_snmp.
DEBUG: [[email protected]:711] Loading data Plugin class from WeatherMapDataSource_wmdata.php
DEBUG: [[email protected]:723] Loaded data Plugin class WeatherMapDataSource_wmdata from WeatherMapDataSource_wmdata.php
DEBUG: [[email protected]:731] Instantiated WeatherMapDataSource_wmdata.
DEBUG: [[email protected]:736] Skipping WeatherMapDataSource_skeleton.php.txt
DEBUG: [[email protected]:736] Skipping README.txt
DEBUG: [[email protected]:711] Loading data Plugin class from WeatherMapDataSource_dsstats.php
DEBUG: [[email protected]:723] Loaded data Plugin class WeatherMapDataSource_dsstats from WeatherMapDataSource_dsstats.php
DEBUG: [[email protected]:731] Instantiated WeatherMapDataSource_dsstats.
DEBUG: [[email protected]:736] Skipping .
DEBUG: [[email protected]:736] Skipping ..
DEBUG: [[email protected]:711] Loading data Plugin class from WeatherMapDataSource_static.php
DEBUG: [[email protected]:723] Loaded data Plugin class WeatherMapDataSource_static from WeatherMapDataSource_static.php
DEBUG: [[email protected]:731] Instantiated WeatherMapDataSource_static.
DEBUG: [[email protected]:711] Loading data Plugin class from WeatherMapDataSource_cactithold.php
DEBUG: [[email protected]:723] Loaded data Plugin class WeatherMapDataSource_cactithold from WeatherMapDataSource_cactithold.php
DEBUG: [[email protected]:731] Instantiated WeatherMapDataSource_cactithold.
DEBUG: [[email protected]:711] Loading data Plugin class from WeatherMapDataSource_fping.php
DEBUG: [[email protected]:723] Loaded data Plugin class WeatherMapDataSource_fping from WeatherMapDataSource_fping.php
DEBUG: [[email protected]:731] Instantiated WeatherMapDataSource_fping.
DEBUG: [[email protected]:711] Loading data Plugin class from WeatherMapDataSource_tabfile.php
DEBUG: [[email protected]:723] Loaded data Plugin class WeatherMapDataSource_tabfile from WeatherMapDataSource_tabfile.php
DEBUG: [[email protected]:731] Instantiated WeatherMapDataSource_tabfile.
DEBUG: [[email protected]:711] Loading data Plugin class from WeatherMapDataSource_rrd.php
DEBUG: [[email protected]:723] Loaded data Plugin class WeatherMapDataSource_rrd from WeatherMapDataSource_rrd.php
DEBUG: [[email protected]:731] Instantiated WeatherMapDataSource_rrd.
DEBUG: [[email protected]:711] Loading data Plugin class from WeatherMapDataSource_dbsample.php
DEBUG: [[email protected]:723] Loaded data Plugin class WeatherMapDataSource_dbsample from WeatherMapDataSource_dbsample.php
DEBUG: [[email protected]:731] Instantiated WeatherMapDataSource_dbsample.
DEBUG: [[email protected]:711] Loading data Plugin class from WeatherMapDataSource_time.php
DEBUG: [[email protected]:723] Loaded data Plugin class WeatherMapDataSource_time from WeatherMapDataSource_time.php
DEBUG: [[email protected]:731] Instantiated WeatherMapDataSource_time.
DEBUG: [[email protected]:688] Beginning to load pre plugins from lib/pre
DEBUG: [[email protected]:736] Skipping .
DEBUG: [[email protected]:736] Skipping ..
DEBUG: [[email protected]:711] Loading pre Plugin class from WeatherMapPreProcessorExample.php
DEBUG: [[email protected]:723] Loaded pre Plugin class WeatherMapPreProcessorExample from WeatherMapPreProcessorExample.php
DEBUG: [[email protected]:731] Instantiated WeatherMapPreProcessorExample.
DEBUG: [[email protected]:688] Beginning to load post plugins from lib/post
DEBUG: [[email protected]:736] Skipping .
DEBUG: [[email protected]:736] Skipping ..
DEBUG: [[email protected]:711] Loading post Plugin class from WeatherMapPostProcessorExample.php
DEBUG: [[email protected]:723] Loaded post Plugin class WeatherMapPostProcessorExample from WeatherMapPostProcessorExample.php
DEBUG: [[email protected]:731] Instantiated WeatherMapPostProcessorExample.
DEBUG: [[email protected]:438] WeatherMap class Reset() complete
DEBUG: [[email protected]:1803] configs/test2.conf: ReadConfig Detected that this is a config filename.
DEBUG: [[email protected]:139] configs/test2.conf: Adding hint key_hidezero_DEFAULT='1' to MAP
DEBUG: [[email protected]:737] configs/test2.conf: Resetting node02470 with DEFAULT
DEBUG: [[email protected]:761] configs/test2.conf: Initialising NODE node02470 from DEFAULT
DEBUG: [[email protected]:2862] configs/test2.conf: Saving Node: node02470
DEBUG: [[email protected]:737] configs/test2.conf: Resetting node02473 with DEFAULT
DEBUG: [[email protected]:761] configs/test2.conf: Initialising NODE node02473 from DEFAULT
DEBUG: [[email protected]:2862] configs/test2.conf: Saving Node: node02473
DEBUG: [[email protected]:1914] configs/test2.conf: New LINK node02470-node02473
DEBUG: [[email protected]:119] configs/test2.conf: Resetting node02470-node02473 with DEFAULT
DEBUG: [[email protected]:145] configs/test2.conf: Initialising LINK node02470-node02473 from DEFAULT
DEBUG: [[email protected]:2211] configs/test2.conf: TARGET: /usr/share/cacti/site/rra/global-ukfh-vgateway-vyos-0_uk_olivia_net_traffic_in_1069.rrd
DEBUG: [[email protected]:139] configs/test2.conf: Adding hint _tidied='1' to node02470-node02473
DEBUG: [[email protected]:2871] configs/test2.conf: Saving Link: node02470-node02473
DEBUG: [[email protected]:2677] configs/test2.conf: ReadConfig has finished reading the config (55 lines)
DEBUG: [[email protected]:2678] configs/test2.conf: ------------------------------------------
DEBUG: [[email protected]:2706] configs/test2.conf: Already have 9 scales, no defaults added.
DEBUG: [[email protected]:2716] configs/test2.conf: Building cache of z-layers and finalising bandwidth.
DEBUG: [[email protected]:2759] configs/test2.conf: Setting bandwidth on NODE :: DEFAULT :: (100 -> 100 bps, 100 -> 100 bps, KILO = 1000)
DEBUG: [[email protected]:2759] configs/test2.conf: Setting bandwidth on NODE DEFAULT (100 -> 100 bps, 100 -> 100 bps, KILO = 1000)
DEBUG: [[email protected]:2759] configs/test2.conf: Setting bandwidth on NODE node02470 (100 -> 100 bps, 100 -> 100 bps, KILO = 1000)
DEBUG: [[email protected]:2759] configs/test2.conf: Setting bandwidth on NODE node02473 (100 -> 100 bps, 100 -> 100 bps, KILO = 1000)
DEBUG: [[email protected]:2759] configs/test2.conf: Setting bandwidth on LINK :: DEFAULT :: (100M -> 100000000 bps, 100M -> 100000000 bps, KILO = 1000)
DEBUG: [[email protected]:2759] configs/test2.conf: Setting bandwidth on LINK DEFAULT (100M -> 100000000 bps, 100M -> 100000000 bps, KILO = 1000)
DEBUG: [[email protected]:2759] configs/test2.conf: Setting bandwidth on LINK node02470-node02473 (100M -> 100000000 bps, 100M -> 100000000 bps, KILO = 1000)
DEBUG: [[email protected]:2762] configs/test2.conf: Found 4 z-layers including builtins (0,100).
DEBUG: [[email protected]:2767] configs/test2.conf: Resolving relative positions for NODEs...
DEBUG: [[email protected]:2829] configs/test2.conf: Relative Positions Cycle 100 - set 0 and Skipped 0 for unresolved dependencies
DEBUG: [[email protected]:2838] configs/test2.conf: -----------------------------------
DEBUG: [[email protected]:2841] configs/test2.conf: Running Pre-Processing Plugins...
DEBUG: [[email protected]:2844] configs/test2.conf: Running WeatherMapPreProcessorExample->run()
DEBUG: [[email protected]:119] configs/test2.conf: Adding note test='TEST!' to MAP
DEBUG: [[email protected]:10] configs/test2.conf: Example Preprocessor in the hizouse
DEBUG: [ReadConfig@Weathermap.class.php:2847] configs/test2.conf: Finished Pre-Processing Plugins...
DEBUG: [add_hint@Weathermap.class.php:139] configs/test2.conf: Adding hint debugging='1' to MAP
DEBUG: [DatasourceInit@Weathermap.class.php:748] configs/test2.conf: Running Init() for Data Source Plugins...
DEBUG: [DatasourceInit@Weathermap.class.php:753] configs/test2.conf: Running WeatherMapDataSource_cactihost->Init()
DEBUG: [Init@WeatherMapDataSource_cactihost.php:20] configs/test2.conf: ReadData CactiHost: Can only run from Cacti environment.
DEBUG: [DatasourceInit@Weathermap.class.php:761] configs/test2.conf: Removing WeatherMapDataSource_cactihost from Data Source list, since Init() failed
DEBUG: [DatasourceInit@Weathermap.class.php:753] configs/test2.conf: Running WeatherMapDataSource_mrtg->Init()
DEBUG: [DatasourceInit@Weathermap.class.php:753] configs/test2.conf: Running WeatherMapDataSource_snmp->Init()
DEBUG: [DatasourceInit@Weathermap.class.php:753] configs/test2.conf: Running WeatherMapDataSource_wmdata->Init()
DEBUG: [DatasourceInit@Weathermap.class.php:753] configs/test2.conf: Running WeatherMapDataSource_dsstats->Init()
DEBUG: [DatasourceInit@Weathermap.class.php:761] configs/test2.conf: Removing WeatherMapDataSource_dsstats from Data Source list, since Init() failed
DEBUG: [DatasourceInit@Weathermap.class.php:753] configs/test2.conf: Running WeatherMapDataSource_static->Init()
DEBUG: [DatasourceInit@Weathermap.class.php:753] configs/test2.conf: Running WeatherMapDataSource_cactithold->Init()
DEBUG: [Init@WeatherMapDataSource_cactithold.php:74] configs/test2.conf: ReadData CactiTHold: Can only run from Cacti environment. [THOLD004]
DEBUG: [DatasourceInit@Weathermap.class.php:761] configs/test2.conf: Removing WeatherMapDataSource_cactithold from Data Source list, since Init() failed
DEBUG: [DatasourceInit@Weathermap.class.php:753] configs/test2.conf: Running WeatherMapDataSource_fping->Init()
DEBUG: [DatasourceInit@Weathermap.class.php:753] configs/test2.conf: Running WeatherMapDataSource_tabfile->Init()
DEBUG: [DatasourceInit@Weathermap.class.php:753] configs/test2.conf: Running WeatherMapDataSource_rrd->Init()
DEBUG: [DatasourceInit@Weathermap.class.php:753] configs/test2.conf: Running WeatherMapDataSource_dbsample->Init()
DEBUG: [DatasourceInit@Weathermap.class.php:753] configs/test2.conf: Running WeatherMapDataSource_time->Init()
DEBUG: [DatasourceInit@Weathermap.class.php:766] configs/test2.conf: Finished Initialising Plugins...
DEBUG: [ReadData@Weathermap.class.php:875] configs/test2.conf: ======================================
DEBUG: [ReadData@Weathermap.class.php:876] configs/test2.conf: ReadData: Updating link data for all links and nodes
DEBUG: [ProcessTargets@Weathermap.class.php:771] configs/test2.conf: Preprocessing targets
DEBUG: [ProcessTargets@Weathermap.class.php:776] configs/test2.conf: Preprocessing targets
DEBUG: [ProcessTargets@Weathermap.class.php:800] configs/test2.conf: ProcessTargets: New Target: /usr/share/cacti/site/rra/global-ukfh-vgateway-vyos-0_uk_olivia_net_traffic_in_1069.rrd
DEBUG: [ReadData@Weathermap.class.php:883] configs/test2.conf: ======================================
DEBUG: [ReadData@Weathermap.class.php:884] configs/test2.conf: Starting prefetch
DEBUG: [ReadData@Weathermap.class.php:890] configs/test2.conf: ======================================
DEBUG: [ReadData@Weathermap.class.php:891] configs/test2.conf: Starting main collection loop
DEBUG: [ReadData@Weathermap.class.php:912] configs/test2.conf:
DEBUG: [ReadData@Weathermap.class.php:913] configs/test2.conf: ReadData for LINK :: DEFAULT :::
DEBUG: [ReadData@Weathermap.class.php:994] configs/test2.conf: ReadData: Skipping LINK :: DEFAULT :: that looks like a template
.DEBUG: [NewColourFromPercent@Weathermap.class.php:1277] configs/test2.conf: NCFPC :: DEFAULT :: DEFAULT 0 '' 0_0 192 192 192
DEBUG: [NewColourFromPercent@Weathermap.class.php:1277] configs/test2.conf: NCFPC :: DEFAULT :: DEFAULT 0 '' 0_0 192 192 192
DEBUG: [add_note@Weathermap.class.php:119] configs/test2.conf: Adding note inscalekey='0_0' to :: DEFAULT ::
DEBUG: [add_note@Weathermap.class.php:119] configs/test2.conf: Adding note outscalekey='0_0' to :: DEFAULT ::
DEBUG: [add_note@Weathermap.class.php:119] configs/test2.conf: Adding note inscaletag='' to :: DEFAULT ::
DEBUG: [add_note@Weathermap.class.php:119] configs/test2.conf: Adding note outscaletag='' to :: DEFAULT ::
DEBUG: [add_note@Weathermap.class.php:119] configs/test2.conf: Adding note inscalecolor='#c0c0c0' to :: DEFAULT ::
DEBUG: [add_note@Weathermap.class.php:119] configs/test2.conf: Adding note outscalecolor='#c0c0c0' to :: DEFAULT ::
DEBUG: [ReadData@Weathermap.class.php:1052] configs/test2.conf: ReadData: Setting 0,0
DEBUG: [ReadData@Weathermap.class.php:912] configs/test2.conf:
DEBUG: [ReadData@Weathermap.class.php:913] configs/test2.conf: ReadData for LINK DEFAULT:
DEBUG: [ReadData@Weathermap.class.php:994] configs/test2.conf: ReadData: Skipping LINK DEFAULT that looks like a template
.DEBUG: [NewColourFromPercent@Weathermap.class.php:1277] configs/test2.conf: NCFPC DEFAULT DEFAULT 0 '' 0_0 192 192 192
DEBUG: [NewColourFromPercent@Weathermap.class.php:1277] configs/test2.conf: NCFPC DEFAULT DEFAULT 0 '' 0_0 192 192 192
DEBUG: [add_note@Weathermap.class.php:119] configs/test2.conf: Adding note inscalekey='0_0' to DEFAULT
DEBUG: [add_note@Weathermap.class.php:119] configs/test2.conf: Adding note outscalekey='0_0' to DEFAULT
DEBUG: [add_note@Weathermap.class.php:119] configs/test2.conf: Adding note inscaletag='' to DEFAULT
DEBUG: [add_note@Weathermap.class.php:119] configs/test2.conf: Adding note outscaletag='' to DEFAULT
DEBUG: [add_note@Weathermap.class.php:119] configs/test2.conf: Adding note inscalecolor='#c0c0c0' to DEFAULT
DEBUG: [add_note@Weathermap.class.php:119] configs/test2.conf: Adding note outscalecolor='#c0c0c0' to DEFAULT
DEBUG: [ReadData@Weathermap.class.php:1052] configs/test2.conf: ReadData: Setting 0,0
DEBUG: [ReadData@Weathermap.class.php:912] configs/test2.conf:
DEBUG: [ReadData@Weathermap.class.php:913] configs/test2.conf: ReadData for LINK node02470-node02473:
DEBUG: [ReadData@Weathermap.class.php:922] configs/test2.conf: ReadData: New Target: /usr/share/cacti/site/rra/global-ukfh-vgateway-vyos-0_uk_olivia_net_traffic_in_1069.rrd
DEBUG: [ReadData@WeatherMapDataSource_rrd.php:516] configs/test2.conf: SCALING result by 8
DEBUG: [ReadData@WeatherMapDataSource_rrd.php:574] configs/test2.conf: RRD ReadData: Target DS names are traffic_in and traffic_out
DEBUG: [wmrrd_read_from_real_rrdtool@WeatherMapDataSource_rrd.php:322] configs/test2.conf: RRD ReadData: traditional style
DEBUG: [wmrrd_read_from_real_rrdtool@WeatherMapDataSource_rrd.php:362] configs/test2.conf: RRD ReadData: Running: /usr/bin/rrdtool fetch /usr/share/cacti/site/rra/global-ukfh-vgateway-vyos-0_uk_olivia_net_traffic_in_1069.rrd AVERAGE --start now-800 --end now
DEBUG: [wmrrd_read_from_real_rrdtool@WeatherMapDataSource_rrd.php:382] configs/test2.conf: > 1483542600: 7.2395608684e+04 4.9488207155e+05
DEBUG: [wmrrd_read_from_real_rrdtool@WeatherMapDataSource_rrd.php:382] configs/test2.conf: > 1483542900: 7.3539657682e+04 4.8359623692e+05
DEBUG: [wmrrd_read_from_real_rrdtool@WeatherMapDataSource_rrd.php:382] configs/test2.conf: > 1483543200: 8.0149361929e+04 4.8302779443e+05
DEBUG: [wmrrd_read_from_real_rrdtool@WeatherMapDataSource_rrd.php:382] configs/test2.conf: > 1483543500: -nan -nan
DEBUG: [wmrrd_read_from_real_rrdtool@WeatherMapDataSource_rrd.php:382] configs/test2.conf: > DEBUG: [wmrrd_read_from_real_rrdtool@WeatherMapDataSource_rrd.php:390] configs/test2.conf: RRD ReadData: Read 5 lines from rrdtool
DEBUG: [wmrrd_read_from_real_rrdtool@WeatherMapDataSource_rrd.php:391] configs/test2.conf: RRD ReadData: Headings are: traffic_in traffic_out

DEBUG: [wmrrd_read_from_real_rrdtool@WeatherMapDataSource_rrd.php:400] configs/test2.conf: --
DEBUG: [wmrrd_read_from_real_rrdtool@WeatherMapDataSource_rrd.php:400] configs/test2.conf: --1483543500: -nan -nan

DEBUG: [wmrrd_read_from_real_rrdtool@WeatherMapDataSource_rrd.php:400] configs/test2.conf: --1483543200: 8.0149361929e+04 4.8302779443e+05

DEBUG: [wmrrd_read_from_real_rrdtool@WeatherMapDataSource_rrd.php:421] configs/test2.conf: 8.0149361929e+04 is OK value for traffic_in
DEBUG: [wmrrd_read_from_real_rrdtool@WeatherMapDataSource_rrd.php:421] configs/test2.conf: 4.8302779443e+05 is OK value for traffic_out
DEBUG: [wmrrd_read_from_real_rrdtool@WeatherMapDataSource_rrd.php:455] configs/test2.conf: RRD ReadDataFromRealRRD: Returning (8.0149361929e+04,4.8302779443e+05,1483543200)
DEBUG: [ReadData@WeatherMapDataSource_rrd.php:616] configs/test2.conf: RRD ReadData: Returning (641194.895432,3864222.35544,1483543200)
DEBUG: [ReadData@Weathermap.class.php:971] configs/test2.conf: Aggregate so far: 641194.895432 3864222.35544
DEBUG: [ReadData@Weathermap.class.php:978] configs/test2.conf: DataTime MINMAX: 1483543200 -> 1483543200
DEBUG: [ReadData@Weathermap.class.php:985] configs/test2.conf: ReadData complete for LINK node02470-node02473: 641194.895432 3864222.35544
DEBUG: [NewColourFromPercent@Weathermap.class.php:1277] configs/test2.conf: NCFPC node02470-node02473 DEFAULT 0.641194895432 '' 0_1 255 255 255
DEBUG: [NewColourFromPercent@Weathermap.class.php:1277] configs/test2.conf: NCFPC node02470-node02473 DEFAULT 3.86422235544 '' 1_10 140 0 255
DEBUG: [add_note@Weathermap.class.php:119] configs/test2.conf: Adding note inscalekey='0_1' to node02470-node02473
DEBUG: [add_note@Weathermap.class.php:119] configs/test2.conf: Adding note outscalekey='1_10' to node02470-node02473
DEBUG: [add_note@Weathermap.class.php:119] configs/test2.conf: Adding note inscaletag='' to node02470-node02473
DEBUG: [add_note@Weathermap.class.php:119] configs/test2.conf: Adding note outscaletag='' to node02470-node02473
DEBUG: [add_note@Weathermap.class.php:119] configs/test2.conf: Adding note inscalecolor='#ffffff' to node02470-node02473
DEBUG: [add_note@Weathermap.class.php:119] configs/test2.conf: Adding note outscalecolor='#8c00ff' to node02470-node02473
DEBUG: [ReadData@Weathermap.class.php:1052] configs/test2.conf: ReadData: Setting 641194.895432,3864222.35544
DEBUG: [ReadData@Weathermap.class.php:912] configs/test2.conf:
DEBUG: [ReadData@Weathermap.class.php:913] configs/test2.conf: ReadData for NODE :: DEFAULT :::
DEBUG: [ReadData@Weathermap.class.php:994] configs/test2.conf: ReadData: Skipping NODE :: DEFAULT :: that looks like a template
.DEBUG: [NewColourFromPercent@Weathermap.class.php:1277] configs/test2.conf: NCFPC :: DEFAULT :: DEFAULT 0 '' 0_0 192 192 192
DEBUG: [NewColourFromPercent@Weathermap.class.php:1277] configs/test2.conf: NCFPC :: DEFAULT :: DEFAULT 0 '' 0_0 192 192 192
DEBUG: [add_note@Weathermap.class.php:119] configs/test2.conf: Adding note inscalekey='0_0' to :: DEFAULT ::
DEBUG: [add_note@Weathermap.class.php:119] configs/test2.conf: Adding note outscalekey='0_0' to :: DEFAULT ::
DEBUG: [add_note@Weathermap.class.php:119] configs/test2.conf: Adding note inscaletag='' to :: DEFAULT ::
DEBUG: [add_note@Weathermap.class.php:119] configs/test2.conf: Adding note outscaletag='' to :: DEFAULT ::
DEBUG: [add_note@Weathermap.class.php:119] configs/test2.conf: Adding note inscalecolor='#c0c0c0' to :: DEFAULT ::
DEBUG: [add_note@Weathermap.class.php:119] configs/test2.conf: Adding note outscalecolor='#c0c0c0' to :: DEFAULT ::
DEBUG: [ReadData@Weathermap.class.php:1052] configs/test2.conf: ReadData: Setting 0,0
DEBUG: [ReadData@Weathermap.class.php:912] configs/test2.conf:
DEBUG: [ReadData@Weathermap.class.php:913] configs/test2.conf: ReadData for NODE DEFAULT:
DEBUG: [ReadData@Weathermap.class.php:994] configs/test2.conf: ReadData: Skipping NODE DEFAULT that looks like a template
.DEBUG: [NewColourFromPercent@Weathermap.class.php:1277] configs/test2.conf: NCFPC DEFAULT DEFAULT 0 '' 0_0 192 192 192
DEBUG: [NewColourFromPercent@Weathermap.class.php:1277] configs/test2.conf: NCFPC DEFAULT DEFAULT 0 '' 0_0 192 192 192
DEBUG: [add_note@Weathermap.class.php:119] configs/test2.conf: Adding note inscalekey='0_0' to DEFAULT
DEBUG: [add_note@Weathermap.class.php:119] configs/test2.conf: Adding note outscalekey='0_0' to DEFAULT
DEBUG: [add_note@Weathermap.class.php:119] configs/test2.conf: Adding note inscaletag='' to DEFAULT
DEBUG: [add_note@Weathermap.class.php:119] configs/test2.conf: Adding note outscaletag='' to DEFAULT
DEBUG: [add_note@Weathermap.class.php:119] configs/test2.conf: Adding note inscalecolor='#c0c0c0' to DEFAULT
DEBUG: [add_note@Weathermap.class.php:119] configs/test2.conf: Adding note outscalecolor='#c0c0c0' to DEFAULT
DEBUG: [ReadData@Weathermap.class.php:1052] configs/test2.conf: ReadData: Setting 0,0
DEBUG: [ReadData@Weathermap.class.php:912] configs/test2.conf:
DEBUG: [ReadData@Weathermap.class.php:913] configs/test2.conf: ReadData for NODE node02470:
DEBUG: [ReadData@Weathermap.class.php:989] configs/test2.conf: ReadData: No targets for NODE node02470
DEBUG: [NewColourFromPercent@Weathermap.class.php:1277] configs/test2.conf: NCFPC node02470 DEFAULT 0 '' 0_0 192 192 192
DEBUG: [NewColourFromPercent@Weathermap.class.php:1277] configs/test2.conf: NCFPC node02470 DEFAULT 0 '' 0_0 192 192 192
DEBUG: [add_note@Weathermap.class.php:119] configs/test2.conf: Adding note inscalekey='0_0' to node02470
DEBUG: [add_note@Weathermap.class.php:119] configs/test2.conf: Adding note outscalekey='0_0' to node02470
DEBUG: [add_note@Weathermap.class.php:119] configs/test2.conf: Adding note inscaletag='' to node02470
DEBUG: [add_note@Weathermap.class.php:119] configs/test2.conf: Adding note outscaletag='' to node02470
DEBUG: [add_note@Weathermap.class.php:119] configs/test2.conf: Adding note inscalecolor='#c0c0c0' to node02470
DEBUG: [add_note@Weathermap.class.php:119] configs/test2.conf: Adding note outscalecolor='#c0c0c0' to node02470
DEBUG: [ReadData@Weathermap.class.php:1052] configs/test2.conf: ReadData: Setting 0,0
DEBUG: [ReadData@Weathermap.class.php:912] configs/test2.conf:
DEBUG: [ReadData@Weathermap.class.php:913] configs/test2.conf: ReadData for NODE node02473:
DEBUG: [ReadData@Weathermap.class.php:989] configs/test2.conf: ReadData: No targets for NODE node02473
DEBUG: [NewColourFromPercent@Weathermap.class.php:1277] configs/test2.conf: NCFPC node02473 DEFAULT 0 '' 0_0 192 192 192
DEBUG: [NewColourFromPercent@Weathermap.class.php:1277] configs/test2.conf: NCFPC node02473 DEFAULT 0 '' 0_0 192 192 192
DEBUG: [add_note@Weathermap.class.php:119] configs/test2.conf: Adding note inscalekey='0_0' to node02473
DEBUG: [add_note@Weathermap.class.php:119] configs/test2.conf: Adding note outscalekey='0_0' to node02473
DEBUG: [add_note@Weathermap.class.php:119] configs/test2.conf: Adding note inscaletag='' to node02473
DEBUG: [add_note@Weathermap.class.php:119] configs/test2.conf: Adding note outscaletag='' to node02473
DEBUG: [add_note@Weathermap.class.php:119] configs/test2.conf: Adding note inscalecolor='#c0c0c0' to node02473
DEBUG: [add_note@Weathermap.class.php:119] configs/test2.conf: Adding note outscalecolor='#c0c0c0' to node02473
DEBUG: [ReadData@Weathermap.class.php:1052] configs/test2.conf: ReadData: Setting 0,0
DEBUG: [ReadData@Weathermap.class.php:1056] configs/test2.conf: ReadData Completed.
DEBUG: [ReadData@Weathermap.class.php:1057] configs/test2.conf: ------------------------------
DEBUG: [DrawMap@Weathermap.class.php:3160] configs/test2.conf: Trace: DrawMap()
DEBUG: [DrawMap@Weathermap.class.php:3172] configs/test2.conf: Running Post-Processing Plugins...
DEBUG: [DrawMap@Weathermap.class.php:3175] configs/test2.conf: Running WeatherMapPostProcessorExample->run()
DEBUG: [run@WeatherMapPostProcessorExample.php:23] configs/test2.conf: WeatherMapPostProcessorExample Not Enabled
DEBUG: [DrawMap@Weathermap.class.php:3180] configs/test2.conf: Finished Post-Processing Plugins...
DEBUG: [DrawMap@Weathermap.class.php:3182] configs/test2.conf: =====================================
DEBUG: [DrawMap@Weathermap.class.php:3183] configs/test2.conf: Start of Map Drawing
DEBUG: [AllocateScaleColours@Weathermap.class.php:3151] configs/test2.conf: AllocateScaleColours: DEFAULT/gdref1 KEYTEXT (0,0,0)
DEBUG: [AllocateScaleColours@Weathermap.class.php:3151] configs/test2.conf: AllocateScaleColours: DEFAULT/gdref1 KEYOUTLINE (0,0,0)
DEBUG: [AllocateScaleColours@Weathermap.class.php:3151] configs/test2.conf: AllocateScaleColours: DEFAULT/gdref1 KEYBG (255,255,255)
DEBUG: [AllocateScaleColours@Weathermap.class.php:3151] configs/test2.conf: AllocateScaleColours: DEFAULT/gdref1 BG (255,255,255)
DEBUG: [AllocateScaleColours@Weathermap.class.php:3151] configs/test2.conf: AllocateScaleColours: DEFAULT/gdref1 TITLE (0,0,0)
DEBUG: [AllocateScaleColours@Weathermap.class.php:3151] configs/test2.conf: AllocateScaleColours: DEFAULT/gdref1 TIME (0,0,0)
DEBUG: [AllocateScaleColours@Weathermap.class.php:3151] configs/test2.conf: AllocateScaleColours: DEFAULT/gdref1 0_0 (192,192,192)
DEBUG: [AllocateScaleColours@Weathermap.class.php:3151] configs/test2.conf: AllocateScaleColours: DEFAULT/gdref1 0_1 (255,255,255)
DEBUG: [AllocateScaleColours@Weathermap.class.php:3151] configs/test2.conf: AllocateScaleColours: DEFAULT/gdref1 1_10 (140,0,255)
DEBUG: [AllocateScaleColours@Weathermap.class.php:3151] configs/test2.conf: AllocateScaleColours: DEFAULT/gdref1 10_25 (32,32,255)
DEBUG: [AllocateScaleColours@Weathermap.class.php:3151] configs/test2.conf: AllocateScaleColours: DEFAULT/gdref1 25_40 (0,192,255)
DEBUG: [AllocateScaleColours@Weathermap.class.php:3151] configs/test2.conf: AllocateScaleColours: DEFAULT/gdref1 40_55 (0,240,0)
DEBUG: [AllocateScaleColours@Weathermap.class.php:3151] configs/test2.conf: AllocateScaleColours: DEFAULT/gdref1 55_70 (240,240,0)
DEBUG: [AllocateScaleColours@Weathermap.class.php:3151] configs/test2.conf: AllocateScaleColours: DEFAULT/gdref1 70_85 (255,192,0)
DEBUG: [AllocateScaleColours@Weathermap.class.php:3151] configs/test2.conf: AllocateScaleColours: DEFAULT/gdref1 85_100 (255,0,0)
DEBUG: [DrawMap@Weathermap.class.php:3262] configs/test2.conf: Pre-rendering :: DEFAULT :: to get bounding boxes.
DEBUG: [DrawMap@Weathermap.class.php:3262] configs/test2.conf: Pre-rendering DEFAULT to get bounding boxes.
DEBUG: [DrawMap@Weathermap.class.php:3262] configs/test2.conf: Pre-rendering node02470 to get bounding boxes.
DEBUG: [pre_render@WeatherMapNode.class.php:249] configs/test2.conf: Node->pre_render: node02470 Label Metrics are: 28 x 13 -> 32 x 17
DEBUG: [DrawMap@Weathermap.class.php:3262] configs/test2.conf: Pre-rendering node02473 to get bounding boxes.
DEBUG: [pre_render@WeatherMapNode.class.php:249] configs/test2.conf: Node->pre_render: node02473 Label Metrics are: 28 x 13 -> 32 x 17
DEBUG: [DrawMap@Weathermap.class.php:3272] configs/test2.conf: Drawing layer 0
DEBUG: [DrawMap@Weathermap.class.php:3272] configs/test2.conf: Drawing layer 300
DEBUG: [DrawMap@Weathermap.class.php:3309] configs/test2.conf: Drawing LINK node02470-node02473
DEBUG: [calc_offset@WeatherMap.functions.php:1401] configs/test2.conf: Numeric Offset found
DEBUG: [calc_offset@WeatherMap.functions.php:1401] configs/test2.conf: Numeric Offset found
DEBUG: [simplify_spine@WeatherMap.functions.php:1366] configs/test2.conf: Skipped 3 points of 3
DEBUG: [draw_straight@WeatherMap.functions.php:1161] configs/test2.conf: Adding Poly imagemap for LINK:L106:1
DEBUG: [simplify_spine@WeatherMap.functions.php:1366] configs/test2.conf: Skipped 3 points of 3
DEBUG: [draw_straight@WeatherMap.functions.php:1161] configs/test2.conf: Adding Poly imagemap for LINK:L106:0
DEBUG: [Draw@WeatherMapLink.class.php:486] configs/test2.conf: Bandwidth for label is 641194.895432
DEBUG: [DrawLabelRotated@Weathermap.class.php:1117] configs/test2.conf: Adding Rectangle imagemap for LINK:L106:2
DEBUG: [Draw@WeatherMapLink.class.php:486] configs/test2.conf: Bandwidth for label is 3864222.35544
DEBUG: [DrawLabelRotated@Weathermap.class.php:1117] configs/test2.conf: Adding Rectangle imagemap for LINK:L106:3
DEBUG: [DrawMap@Weathermap.class.php:3272] configs/test2.conf: Drawing layer 600
DEBUG: [DrawMap@Weathermap.class.php:3322] configs/test2.conf: Drawing NODE node02470
DEBUG: [DrawMap@Weathermap.class.php:3330] configs/test2.conf: Adding imagemap areaDEBUG: [DrawMap@Weathermap.class.php:3333] configs/test2.conf: Added 1 bounding boxes too
DEBUG: [DrawMap@Weathermap.class.php:3322] configs/test2.conf: Drawing NODE node02473
DEBUG: [DrawMap@Weathermap.class.php:3330] configs/test2.conf: Adding imagemap areaDEBUG: [DrawMap@Weathermap.class.php:3333] configs/test2.conf: Added 1 bounding boxes too
DEBUG: [DrawMap@Weathermap.class.php:3272] configs/test2.conf: Drawing layer 1000
DEBUG: [DrawMap@Weathermap.class.php:3278] configs/test2.conf: Drawing KEY for DEFAULT if necessary.
DEBUG: [DrawMap@Weathermap.class.php:3420] configs/test2.conf: Writing PNG file to weathermap.png


Top
 Profile  
 
 Post subject: Re: Unable to save some arguments, maps not working
PostPosted: Wed Jan 04, 2017 11:57 am 
Offline

Joined: Sat Feb 20, 2016 12:53 pm
Posts: 26
Also just spotted I am unable to chage link label value from % to bit/sec

Hmmm?


Top
 Profile  
 
 Post subject: Re: Unable to save some arguments, maps not working
PostPosted: Thu Jan 05, 2017 1:29 pm 
Offline

Joined: Sat Feb 20, 2016 12:53 pm
Posts: 26
any ideas ?


Top
 Profile  
 
 Post subject: Re: Unable to save some arguments, maps not working
PostPosted: Tue Jan 17, 2017 5:49 pm 
Offline

Joined: Sat Feb 20, 2016 12:53 pm
Posts: 26
????


Top
 Profile  
 
 Post subject: Re: Unable to save some arguments, maps not working
PostPosted: Tue Jan 17, 2017 6:03 pm 
Offline
Cacti Guru User
User avatar

Joined: Thu Sep 16, 2004 5:53 am
Posts: 5117
Location: United Kingdom
What does the map config look like?

_________________
Weathermap 0.98 is out! & QuickTree 0.2. Superlinks is over there now.
Some Other Cacti tweaks, including strip-graphs, icons and snmp/netflow stuff.
(Let me know if you have UK DevOps or Network Ops opportunities, too!)


Top
 Profile  
 
 Post subject: Re: Unable to save some arguments, maps not working
PostPosted: Tue Jan 17, 2017 6:10 pm 
Offline

Joined: Sat Feb 20, 2016 12:53 pm
Posts: 26
Howie wrote:
What does the map config look like?


Sure, let me paste conf here. One moment please.


Top
 Profile  
 
 Post subject: Re: Unable to save some arguments, maps not working
PostPosted: Tue Jan 17, 2017 6:13 pm 
Offline

Joined: Sat Feb 20, 2016 12:53 pm
Posts: 26
In this stage, problem has been moved to

issues with plug instalation

I have default configuration of weathermap. I am unable to go to weathermap, because i cant see it.
What happened ?


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 7 posts ] 

All times are UTC - 5 hours


Who is online

Users browsing this forum: Google [Bot] and 5 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  

Protected by Anti-Spam ACP Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group