Network weathermap on cacti 1.1.19

Support questions about the Network Weather Map plugin

Moderators: Moderators, Developers

Post Reply
Author
Message
markgiusti
Posts: 12
Joined: Fri Aug 25, 2017 7:39 am

Network weathermap on cacti 1.1.19

#1 Post by markgiusti » Tue Sep 19, 2017 4:46 am

Hello,

I am having an issue with weathermap on cacti 1.1.19. I am not sure if I installed the plugin incorrectly, missing a step or if its even compatible with this version of cacti.

The following issues are:

Once i go into the weathermap editor, I get the following error:"WARNING - Sorry, it's partly laziness on my part, but you really need JavaScript enabled and DOM support in your browser to use this editor. It's a visual tool, so accessibility is already an issue, if it is, and from a security viewpoint, you're already running my code on your server so either you trust it all having read it, or you're already screwed.
If it's a major issue for you, please feel free to complain. It's mainly laziness as I said, and there could be a fallback (not so smooth) mode for non-javascript browsers if it was seen to be worthwhile (I would take a bit of convincing, because I don't see a benefit, personally)."

I have done what was told (gave the appropriate writes to the folder), made sure that Javascript is running on my browser, i used multiple different browsers but unfortunately i am still having problems.

Any help would be appreciated.

Mark

User avatar
Howie
Cacti Guru User
Posts: 5336
Joined: Thu Sep 16, 2004 5:53 am
Location: United Kingdom
Contact:

Re: Network weathermap on cacti 1.1.19

#2 Post by Howie » Tue Sep 19, 2017 4:51 am

Interesting error - do you have javascript enabled?

However, the bigger issue is that there isn't currently a release version of weathermap that works with Cacti > 1.0. It does actually say this right next to the download link on the weathermap site.

It's being worked on: http://www.network-weathermap.com/blog/
Weathermap 0.98 is out! & QuickTree 1.0. Superlinks is over there now (and built-in to Cacti 1.x).
Some Other Cacti tweaks, including strip-graphs, icons and snmp/netflow stuff.
(Let me know if you have UK DevOps or Network Ops opportunities, too!)

markgiusti
Posts: 12
Joined: Fri Aug 25, 2017 7:39 am

Re: Network weathermap on cacti 1.1.19

#3 Post by markgiusti » Thu Sep 28, 2017 7:17 am

Hi,

Yes i do have Javascript enabled.

As you mentioned, it seems that there isn't a version compatible yet for 1.1.19.

Following forum was updated a couple of weeks ago.

Regards,
Mark

Post Reply