Weather map with packets flow

Support questions about the Network Weather Map plugin

Moderators: Moderators, Developers

Post Reply
Author
Message
krakazyabra
Posts: 1
Joined: Fri Mar 08, 2019 7:39 am

Weather map with packets flow

#1 Post by krakazyabra » Fri Mar 08, 2019 7:59 am

Hi everybody!
Trying to make the map with packets per second

Code: Select all

LINK DEFAULT
        WIDTH 3
        BWOUTLINECOLOR none
        BWLABEL unformatted
        BWSTYLE classic
        INBWFORMAT {link:this:bandwidth_in:%0.1d} pps
        OUTBWFORMAT {link:this:bandwidth_out:%0.1d} pps
        BANDWIDTH 10000000
and

Code: Select all

LINK Sitel_copy-10.28.0.58
        INFOURL /graphs/type=port_upkts/id=4572/
        OVERLIBGRAPH /graph.php?height=100&width=512&id=4572&type=port_upkts
        COMMENTPOS 70 30
        TARGET ./10.28.0.58/port-id4572.rrd:INUCASTPKTS:OUTUCASTPKTS
        OUTCOMMENT Et27/1
        NODES Sitel_copy 10.28.0.58
But on map i see wrong values: (see attachment, if the link is broken)
Image

I expect to see on line, where 1888893 pps value, correct one - 218.88k and

What am i doing wrong?
Attachments
Выделение_035.png
Выделение_035.png (34.6 KiB) Viewed 409 times

User avatar
Howie
Cacti Guru User
Posts: 5327
Joined: Thu Sep 16, 2004 5:53 am
Location: United Kingdom
Contact:

Re: Weather map with packets flow

#2 Post by Howie » Mon Apr 29, 2019 7:13 am

By default, Weathermap assumes it is looking at byte-counters, because that is what SNMP traffic is recorded as. So it multiplies the result by 8, to give bits/sec in the output.

When you are using other counters, you don't want that, so you need to use the gauge: prefix like this:

Code: Select all

           TARGET gauge:./10.28.0.58/port-id4572.rrd:INUCASTPKTS:OUTUCASTPKTS
That will disable the multiplication.
Weathermap 0.98 is out! & QuickTree 1.0. Superlinks is over there now (and built-in to Cacti 1.x).
Some Other Cacti tweaks, including strip-graphs, icons and snmp/netflow stuff.
(Let me know if you have UK DevOps or Network Ops opportunities, too!)

Post Reply