Cacti (home)ForumsDocumentation
Cacti: offical forums and support
It is currently Tue Jun 25, 2019 6:53 pm

All times are UTC - 5 hours




Post new topic Reply to topic  [ 4 posts ] 
Author Message
 Post subject: thold not honour high/low and InProcess showing in logs
PostPosted: Fri Apr 05, 2019 9:59 am 
Offline

Joined: Fri Apr 05, 2019 9:36 am
Posts: 2
Hi all,

I have a high/low threshold that isn't entering in to an alarm or warning state, even when the current value is above the threshold for the specified amount of time. With a high alarm of 80 and a current value of 110, the threshold remains in the green 'Ok' state.

I see this in the logs

# grep -i THOLD /var/log/cacti/cacti.log | tail
2019/04/05 09:58:52 - SYSTEM THOLD DAEMON STATS: TotalTime:0.000 MaxRuntime:0.000 Processed:0 InProcess:52 TotalDevices:347 DownDevices:5 NewDownDevices:0 MaxProcesses:1 Completed:0 Running:0 Broken:0
2019/04/05 10:03:54 - SYSTEM THOLD DAEMON STATS: TotalTime:0.000 MaxRuntime:0.000 Processed:0 InProcess:52 TotalDevices:347 DownDevices:5 NewDownDevices:0 MaxProcesses:1 Completed:0 Running:0 Broken:0
2019/04/05 10:08:56 - SYSTEM THOLD DAEMON STATS: TotalTime:0.000 MaxRuntime:0.000 Processed:0 InProcess:52 TotalDevices:347 DownDevices:5 NewDownDevices:0 MaxProcesses:1 Completed:0 Running:0 Broken:0
2019/04/05 10:13:58 - SYSTEM THOLD DAEMON STATS: TotalTime:0.000 MaxRuntime:0.000 Processed:0 InProcess:52 TotalDevices:347 DownDevices:5 NewDownDevices:0 MaxProcesses:1 Completed:0 Running:0 Broken:0
2019/04/05 10:18:52 - SYSTEM THOLD DAEMON STATS: TotalTime:0.000 MaxRuntime:0.000 Processed:0 InProcess:52 TotalDevices:347 DownDevices:5 NewDownDevices:0 MaxProcesses:1 Completed:0 Running:0 Broken:0

'InProcess' never changes and 'Processed' is always 0. Do you think this might be related? Does anyone have any insight in to what InProcess means and why it might get 'stuck'? Or is this a red herring?

Thanks for your time!

Versions:
Cacti 1.1.37
thold 1.0.6
SPINE 1.1.35
PHP 5.6.31
MySQL 5.6.34


Top
 Profile  
 
 Post subject: Re: thold not honour high/low and InProcess showing in logs
PostPosted: Sat Apr 06, 2019 9:53 am 
Offline
Cacti User

Joined: Tue Feb 07, 2017 1:55 pm
Posts: 63
Location: Venezuela
it´s only that specific threshold or none is working?

upload a capture of the config for this threshold to see if there is something wrong

_________________
Beast
GitHub: DoubleBeast


Top
 Profile  
 
 Post subject: Re: thold not honour high/low and InProcess showing in logs
PostPosted: Tue Apr 09, 2019 2:35 pm 
Offline

Joined: Fri Apr 05, 2019 9:36 am
Posts: 2
Hi Beast, thanks for the reply.

I spoke with my co-worker, who installed the plugin and created some test thresholds. He says that he did see a threshold alert trigger once, but he has since upgraded Cacti and hasn't had time to confirm that they still work. We aren't actually making use of thresholds yet, and it appears that none are working at this time.

As requested, I have attached captures of the threshold configuration, and a capture of the threshold as it appears under the tholds tab. Does the 'current' value make sense? Should it not be 532.6933 as shown in the capture?

Thanks again,


Attachments:
File comment: I'm not familiar enough with thold to know, but does the value for 'Current' make sense, given the Current value shown in the next pic?
thold_cap1.jpg
thold_cap1.jpg [ 42.87 KiB | Viewed 429 times ]
thold_cap2.jpg
thold_cap2.jpg [ 199.32 KiB | Viewed 429 times ]
thold_cap_3.jpg
thold_cap_3.jpg [ 142.29 KiB | Viewed 429 times ]
Top
 Profile  
 
 Post subject: Re: thold not honour high/low and InProcess showing in logs
PostPosted: Wed Apr 10, 2019 9:57 am 
Offline
Cacti User

Joined: Tue Feb 07, 2017 1:55 pm
Posts: 63
Location: Venezuela
according to the images it should work an it must be in warning state at that moment, what i see odd is that the current value should be present in 3 section of the images that you upload and it is only present into 1 of them, have you tried reinstalling the plugin?

_________________
Beast
GitHub: DoubleBeast


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 4 posts ] 

All times are UTC - 5 hours


Who is online

Users browsing this forum: No registered users and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  

Protected by Anti-Spam ACP Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group