Problem when installing Thold 0.4.9 on 0.8.8a

Support questions about the Threshold plugin

Moderators: Moderators, Developers

Post Reply
Author
Message
frdrk
Cacti User
Posts: 55
Joined: Fri Jul 06, 2007 2:27 pm

Problem when installing Thold 0.4.9 on 0.8.8a

#1 Post by frdrk » Fri Aug 10, 2012 3:31 am

Just installed Ubuntu Quantal with Cacti 0.8.8a-3, when I install (not activate) the Thold plugin my Settings page stop to work (HTTP Error 500). When I activate it, also the Notification Lists Thresholds and Thold tab gives Error 500.

Anyone seen this behavior?

pier62350
Posts: 15
Joined: Thu Aug 02, 2012 9:12 am

Re: Problem when installing Thold 0.4.9 on 0.8.8a

#2 Post by pier62350 » Fri Aug 10, 2012 5:00 am

Hi,

I was having the same problem.

The thold plugin seems to use "define_syslog_variables()" but this function was deleted in php 5.4

you can comment the line 132 (define_syslog_variables()) in the following path

path-to-your-cacti-install/plugins/plugins/thold/includes/settings.php

for comment this line you have just to put "//" at the start of them
before:

Code: Select all

define_syslog_variables()
after:

Code: Select all

//define_syslog_variables()

frdrk
Cacti User
Posts: 55
Joined: Fri Jul 06, 2007 2:27 pm

Re: Problem when installing Thold 0.4.9 on 0.8.8a

#3 Post by frdrk » Fri Aug 10, 2012 8:26 am

Thanks! That fixed the Settings error, but I still get Error 500 when trying to use any of the Thold links. Commented out the define_syslog_variables(); from thold_functions.php also, but that made no difference.


edit: fixed, had to add the symlinks as described in #33 here: https://bugs.launchpad.net/precise-back ... ug/1018693

Post Reply