Cacti (home)ForumsDocumentation
Cacti: offical forums and support
It is currently Mon Jul 24, 2017 12:04 am

All times are UTC - 5 hours




Post new topic Reply to topic  [ 3 posts ] 
Author Message
 Post subject: No down Host email no Threshold triggered
PostPosted: Fri Nov 11, 2016 3:18 pm 
Offline

Joined: Mon Dec 05, 2011 11:31 am
Posts: 13
Ubuntu 16.04, Cacti 0.8.8f, PHP 5.6.27
Fixed various issues with this setup MYSQL strict etc. etc. all working now except thold.

The only odd message I get in the logs is this:

PHP Warning: mysql_query(): A link to the server could not be established in /usr/share/cacti/site/plugins/discovery/setup.php on line 349
PHP Stack trace:
PHP 1. {main}() /usr/share/cacti/site/poller.php:0
PHP 2. api_plugin_hook() /usr/share/cacti/site/poller.php:511
PHP 3. discovery_poller_bottom() /usr/share/cacti/site/lib/plugins.php:60
PHP 4. mysql_query() /usr/share/cacti/site/plugins/discovery/setup.php:349

As this is the discovery plugin.. and it's seems to be working I've been ignoring it. It seems to be the spot where discovery logs a successful run in the database.

I've turned on debug logging in Thresholds and don't see anything odd:
11/11/2016 12:10:02 PM - THOLD: Checking Threshold:'Tyler NetHatchet - VDC Measurement [snmp_vdc]', Graph:'5'
11/11/2016 12:10:05 PM - THOLD: Checking Threshold:'TyconSoda - [snmp_oid]', Graph:'1793'
11/11/2016 12:10:05 PM - THOLD: Checking Threshold:'TyconSoda - [snmp_oid]', Graph:'1792'
However the Thresholds display never triggers.


Attachments:
cacti-threshold-fail.png
cacti-threshold-fail.png [ 38.99 KiB | Viewed 2824 times ]
Top
 Profile  
 
 Post subject: Re: No down Host email no Threshold triggered
PostPosted: Wed Jan 25, 2017 1:00 am 
Offline

Joined: Wed Jan 25, 2017 12:56 am
Posts: 2
Same problems here. Same configuration with host. Does anyone can help??
Thanks for any advice. :cry:


Top
 Profile  
 
 Post subject: Re: No down Host email no Threshold triggered
PostPosted: Wed Jan 25, 2017 8:59 pm 
Offline

Joined: Wed Jan 25, 2017 12:56 am
Posts: 2
I just inherit this system from a resigned colleague, it works fine but only threshold.
After my investigation, I have had change the sql_mode, replaced the split() function and reset the sendmail service but no luck.
At last, I dumped the database and install the cacti again. Finally, it works. And now I need to add around 40 devices again. :o


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 3 posts ] 

All times are UTC - 5 hours


Who is online

Users browsing this forum: No registered users and 3 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  

Protected by Anti-Spam ACP Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group