Cacti (home)ForumsDocumentation
Cacti: offical forums and support
It is currently Sun Dec 16, 2018 5:25 am

All times are UTC - 5 hours




Post new topic Reply to topic  [ 15 posts ] 
Author Message
 Post subject: Cacti is not sending alerts
PostPosted: Thu Mar 29, 2018 3:59 am 
Offline

Joined: Thu Mar 01, 2018 5:24 am
Posts: 8
Cacti is not sending alert if device is breaching defined threshold , I can tried sending test mail its getting delivered to my mailbox.
Cacti version is :1.1.36

Please help thanks in advance.


Top
 Profile  
 
 Post subject: Re: Cacti is not sending alerts
PostPosted: Thu Mar 29, 2018 5:55 am 
Offline
Cacti Guru User

Joined: Sun Aug 27, 2017 12:05 am
Posts: 1818
Are there any errors in the cacti log? Can you provide a description of the threshold settings you have in place? When you are viewing the Threshold under Console -> Management -> Thresholds -> Edit Threshold, does the graph show the breach? If you look at the Thresholds tab -> Logs and filter by the device/template in question, does this show the breaches?

_________________
Official Cacti Developer

Cacti Resources:
Cacti Website (including releases)
Cacti Issues
Cacti Development Releases
Cacti Development Documentation

My resources:
How to submit Pull Requests
Development Wiki and How To's
Updated NetSNMP Memory template for Cacti 1.x
Cisco SFP template for Cacti 0.8.8


Top
 Profile  
 
 Post subject: Re: Cacti is not sending alerts
PostPosted: Thu Mar 29, 2018 6:39 am 
Offline

Joined: Thu Mar 01, 2018 5:24 am
Posts: 8
Yes I can see some error in cacti log when I logged to server doing SSH , I have attached for your ref.

When you are viewing the Threshold under Console -> Management -> Thresholds -> Edit Threshold, does the graph show the breach?:
No graph is not showing breach.

I am also attaching screenshot of threshold template which I have defined.

Regards,
Rahul


Attachments:
Capture.PNG
Capture.PNG [ 31.58 KiB | Viewed 542 times ]
Threshold template.PNG
Threshold template.PNG [ 30.01 KiB | Viewed 542 times ]
Top
 Profile  
 
 Post subject: Re: Cacti is not sending alerts
PostPosted: Thu Mar 29, 2018 6:50 am 
Offline
Cacti Guru User

Joined: Sun Aug 27, 2017 12:05 am
Posts: 1818
You will find it easier viewing the logs via the Logs tab within Cacti. That also has the advantage in that it converts the numbers to names with links back to the devices/graphs/data sources so you can navigate with ease through them.

On your thresholds, I can see you've set a low threshold. Are you expecting your CPU's to be constantly over 20% in usage?

Do you have any entries in the Thresholds tab -> Log for the device/threshold in question?

_________________
Official Cacti Developer

Cacti Resources:
Cacti Website (including releases)
Cacti Issues
Cacti Development Releases
Cacti Development Documentation

My resources:
How to submit Pull Requests
Development Wiki and How To's
Updated NetSNMP Memory template for Cacti 1.x
Cisco SFP template for Cacti 0.8.8


Top
 Profile  
 
 Post subject: Re: Cacti is not sending alerts
PostPosted: Thu Mar 29, 2018 8:14 am 
Offline

Joined: Thu Mar 01, 2018 5:24 am
Posts: 8
On your thresholds, I can see you've set a low threshold. Are you expecting your CPU's to be constantly over 20% in usage? : I have done it for testing purpose but later on will change it

Also I have attached cacti log please check and suggest.


Attachments:
Cactilog.PNG
Cactilog.PNG [ 18.31 KiB | Viewed 533 times ]
Top
 Profile  
 
 Post subject: Re: Cacti is not sending alerts
PostPosted: Thu Mar 29, 2018 9:59 am 
Offline
Cacti Guru User

Joined: Sun Aug 27, 2017 12:05 am
Posts: 1818
it wasn't the cacti log I was after, I merely pointed you at that so you were aware you can do it via the GUI. I asked for the Threshold Logs.

_________________
Official Cacti Developer

Cacti Resources:
Cacti Website (including releases)
Cacti Issues
Cacti Development Releases
Cacti Development Documentation

My resources:
How to submit Pull Requests
Development Wiki and How To's
Updated NetSNMP Memory template for Cacti 1.x
Cisco SFP template for Cacti 0.8.8


Top
 Profile  
 
 Post subject: Re: Cacti is not sending alerts
PostPosted: Fri Mar 30, 2018 9:35 am 
Offline

Joined: Thu Mar 01, 2018 5:24 am
Posts: 8
attaching same for your ref, cant see anything in threshold logs.


Attachments:
Threshold logs.PNG
Threshold logs.PNG [ 28.88 KiB | Viewed 522 times ]
Top
 Profile  
 
 Post subject: Re: Cacti is not sending alerts
PostPosted: Fri Mar 30, 2018 10:42 am 
Offline
Cacti Guru User

Joined: Sun Aug 27, 2017 12:05 am
Posts: 1818
That would suggest no breaches have actually occurred then. Interesting.

_________________
Official Cacti Developer

Cacti Resources:
Cacti Website (including releases)
Cacti Issues
Cacti Development Releases
Cacti Development Documentation

My resources:
How to submit Pull Requests
Development Wiki and How To's
Updated NetSNMP Memory template for Cacti 1.x
Cisco SFP template for Cacti 0.8.8


Top
 Profile  
 
 Post subject: Re: Cacti is not sending alerts
PostPosted: Fri Mar 30, 2018 10:50 am 
Offline

Joined: Thu Mar 01, 2018 5:24 am
Posts: 8
Thanks ,

But you can see I have set threshold on servers for test like this lowest 20% and highest 50% and in graphs I can see server is going beyond the value and breaching the defined threshold but not generating alerts.

Would be great if you can share any article or document regarding setting up threshold in cacti then I can refer that to identify the problem


Top
 Profile  
 
 Post subject: Re: Cacti is not sending alerts
PostPosted: Fri Mar 30, 2018 11:08 am 
Offline
Cacti Guru User

Joined: Sun Aug 27, 2017 12:05 am
Posts: 1818
Do you actually have any data in these data sources? I must be missing the part which shows the value going above, even after re-reading.

_________________
Official Cacti Developer

Cacti Resources:
Cacti Website (including releases)
Cacti Issues
Cacti Development Releases
Cacti Development Documentation

My resources:
How to submit Pull Requests
Development Wiki and How To's
Updated NetSNMP Memory template for Cacti 1.x
Cisco SFP template for Cacti 0.8.8


Top
 Profile  
 
 Post subject: Re: Cacti is not sending alerts
PostPosted: Fri Mar 30, 2018 12:02 pm 
Offline

Joined: Thu Mar 01, 2018 5:24 am
Posts: 8
I am attaching one screenshot here which shows server is breaching defined threshold today afternoon.


Attachments:
CPU Utilisation.png
CPU Utilisation.png [ 8.76 KiB | Viewed 516 times ]
Top
 Profile  
 
 Post subject: Re: Cacti is not sending alerts
PostPosted: Fri Mar 30, 2018 1:07 pm 
Offline
Cacti Guru User

Joined: Sun Aug 27, 2017 12:05 am
Posts: 1818
OK, so the graph shows the breach, which means you must have a value. When you edit the threshold in Console -> Management -> Thresholds, you should see the same graph. Can you post a screen shot of that, include the small tabs that appear beneath the graph?

_________________
Official Cacti Developer

Cacti Resources:
Cacti Website (including releases)
Cacti Issues
Cacti Development Releases
Cacti Development Documentation

My resources:
How to submit Pull Requests
Development Wiki and How To's
Updated NetSNMP Memory template for Cacti 1.x
Cisco SFP template for Cacti 0.8.8


Top
 Profile  
 
 Post subject: Re: Cacti is not sending alerts
PostPosted: Fri Mar 30, 2018 1:40 pm 
Offline

Joined: Thu Mar 01, 2018 5:24 am
Posts: 8
I am attaching screenshot of another server on which I had defined threshold for hardisk usage but its not generating alert


Attachments:
storage threshold.png
storage threshold.png [ 21.5 KiB | Viewed 510 times ]
Top
 Profile  
 
 Post subject: Re: Cacti is not sending alerts
PostPosted: Fri Mar 30, 2018 2:44 pm 
Offline
Cacti Guru User

Joined: Sun Aug 27, 2017 12:05 am
Posts: 1818
I'm not sure how that helps, it wasn't what I asked for, but I'll keep it in mind :)

_________________
Official Cacti Developer

Cacti Resources:
Cacti Website (including releases)
Cacti Issues
Cacti Development Releases
Cacti Development Documentation

My resources:
How to submit Pull Requests
Development Wiki and How To's
Updated NetSNMP Memory template for Cacti 1.x
Cisco SFP template for Cacti 0.8.8


Top
 Profile  
 
 Post subject: Re: Cacti is not sending alerts
PostPosted: Fri Mar 30, 2018 3:34 pm 
Offline

Joined: Thu Mar 01, 2018 5:24 am
Posts: 8
Ok thanks, if required I can share the screenshot of that server as well, please suggest.
I can also share other logs as well if required to identify the issue.


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 15 posts ] 

All times are UTC - 5 hours


Who is online

Users browsing this forum: No registered users and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  

Protected by Anti-Spam ACP Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group