Thold plugin error in Cacti 1.1.28

Support questions about the Threshold plugin

Moderators: Moderators, Developers

Post Reply
Author
Message
Nadee1
Posts: 28
Joined: Thu Oct 04, 2018 11:43 pm

Thold plugin error in Cacti 1.1.28

#1 Post by Nadee1 » Fri Oct 05, 2018 12:01 am

Hi,

Im new to cacti... :cry:

I have installed cacti 1.1.28 and placed Thold plugin in cacti/plugin folder
(https://github.com/Cacti/plugin_thold) .
Rename unzip Thold file as "Thold" as described in previous posts.
Do I need to do any other this after place this?

But my web interface shows "Not Compatible, Legacy Plugin"(Screen shot attached)
when I delete all Thold files from plugin folder and refresh web interface , It showing same ...
What Can I do ?

Appreciate your quick Response ...
Attachments
cacti.png
cacti.png (40.66 KiB) Viewed 926 times
cacti.png
cacti.png (40.66 KiB) Viewed 926 times

netniV
Cacti Guru User
Posts: 2682
Joined: Sun Aug 27, 2017 12:05 am

Re: Thold plugin error in Cacti 1.1.28

#2 Post by netniV » Fri Oct 05, 2018 8:50 pm

First, make sure the directory name is 'thold' not 'Thold' on the disk. Then make sure you have INFO and setup.php files in that thold folder. Also, make sure that the plugin folder is readable by the website user. If you have selinux on, maybe set the status to passive and se if it works.

Nadee1
Posts: 28
Joined: Thu Oct 04, 2018 11:43 pm

Re: Thold plugin error in Cacti 1.1.28

#3 Post by Nadee1 » Mon Oct 08, 2018 12:14 am

I have changed " Thold" to "thold", but no change in web interface :(

[[email protected] plugins]# ls
capacityreport cereusreporting-3.01-linux-x64-installer.run ioncube_loaders_lin_x86-64.tar.gz settings-v0.71-1.tgz
capacityreport-0.1.zip index.php p7zip_16.02_src_all.tar.bz2 thold


[[email protected] www]# find -name "Thold" (No any file named as "Thold")
[[email protected] www]#


should i restart after placing thold folder ? (this is virtual server...)
Attachments
rrr.png
rrr.png (30.96 KiB) Viewed 915 times

netniV
Cacti Guru User
Posts: 2682
Joined: Sun Aug 27, 2017 12:05 am

Re: Thold plugin error in Cacti 1.1.28

#4 Post by netniV » Mon Oct 08, 2018 2:12 am

That is correct, the web interface title cases the name to make it look "pretty". However, you appear to have the older version of the plugins, hence they are reporting non-compatibility. You need to download later version of the plugins.

Nadee1
Posts: 28
Joined: Thu Oct 04, 2018 11:43 pm

Re: Thold plugin error in Cacti 1.1.28

#5 Post by Nadee1 » Tue Oct 09, 2018 12:54 am

I downloaded from here..
https://github.com/Cacti/plugin_thold

This is latest version.Isn't it ?

netniV
Cacti Guru User
Posts: 2682
Joined: Sun Aug 27, 2017 12:05 am

Re: Thold plugin error in Cacti 1.1.28

#6 Post by netniV » Tue Oct 09, 2018 6:07 am

Can you list the contents of the plugin folder and the thold folder.

Nadee1
Posts: 28
Joined: Thu Oct 04, 2018 11:43 pm

Re: Thold plugin error in Cacti 1.1.28

#7 Post by Nadee1 » Fri Oct 12, 2018 12:26 am

[[email protected] plugins]# ls
capacityreport cereusreporting-3.01-linux-x64-installer.run ioncube_loaders_lin_x86-64.tar.gz settings
capacityreport-0.1.zip index.php p7zip_16.02_src_all.tar.bz2 thold



[[email protected] thold]# ls
CACTI-THOLD-MIB images INFO notify_lists.php setup.php thold_daemon.service thold.php thold_webapi.php
cli_thresholds.php includes LICENSE README.md themes thold_functions.php thold_process.php
extras index.php locales service thold_daemon.php thold_graph.php thold_templates.php

netniV
Cacti Guru User
Posts: 2682
Joined: Sun Aug 27, 2017 12:05 am

Re: Thold plugin error in Cacti 1.1.28

#8 Post by netniV » Mon Oct 15, 2018 5:34 pm

OK, so at this point, this would suggest that the user under which your website runs, does not have permissions to the folders to be able to read the files. This may happen if you, for example, download and extract using the root user.

Nadee1
Posts: 28
Joined: Thu Oct 04, 2018 11:43 pm

Re: Thold plugin error in Cacti 1.1.28

#9 Post by Nadee1 » Thu Mar 14, 2019 9:58 am

SOLVED !!

In my server cacti installed in 2 locations

1. /var/www/html/cacti/cacti-1.1.28/plugins

2.cd /usr/share/cacti/plugins

I have tried first location.

After placing plugin in 2nd location it installed correctly...


THANKS for Your help!!!

Post Reply