Dataquery (ex cactiquery) 1.0a released

Announcements concerning Plugins for Cacti

Moderators: Moderators, Developers

Author
Message
torstentfk
Cacti User
Posts: 367
Joined: Tue Apr 05, 2005 9:52 am
Location: Munich, Germany

#31 Post by torstentfk » Thu Nov 16, 2006 3:22 am

upss...who have the wrong function found.

The error message is created by the plugin killspike/removespike
my setup.php looks like this:

....

Code: Select all

....
function killspike_draw_navigation_text ($nav) {
        $nav["killspike.php:"] = array("title" => "killspike", "mapping" => "graph_view.php:,?,graph.php:view", "level" => "3");
return $nav;
}
The last line "return...." is new.
[/code]

Ahuber
Cacti User
Posts: 56
Joined: Thu Nov 16, 2006 1:57 pm
Location: BC, kootenays

#32 Post by Ahuber » Thu Nov 16, 2006 4:12 pm

I have the same error (Notice: Undefined index: data in C:\Inetpub\wwwroot\cacti\plugins\dataquery\view\queryview.php on line 61) etc ...
A clue for you guys, my apache error log says that it cannot find the file C\:/inetpub\wwroot\... etc.. (rrd graph of queried item)
Notice the C\
Now I have no clue where to find what would have C\
I did a text search in http.conf, and through all the cacti folders.. nothing found.

Ahuber
Cacti User
Posts: 56
Joined: Thu Nov 16, 2006 1:57 pm
Location: BC, kootenays

#33 Post by Ahuber » Thu Nov 16, 2006 4:14 pm

Sorry, forgot to mention, I don't have killspike, so the above mention of the funtion requireing the return does not apply. My functions.php does not contain anything about killspike.

Thanks in advance!

Ahuber
Cacti User
Posts: 56
Joined: Thu Nov 16, 2006 1:57 pm
Location: BC, kootenays

#34 Post by Ahuber » Thu Nov 16, 2006 7:20 pm

Hey blackakashi, and anyone else with the line 61 error,
look for a line in class_cactiquery.php (search) that goes like

str_replace(":", "\:", $data_source_path);

And replace the "\:" with just ":"

That is what fixed me up.

Good luck!

blackakashi
Posts: 11
Joined: Mon Feb 13, 2006 7:51 am

#35 Post by blackakashi » Fri Nov 17, 2006 4:55 am

Thanks a lot !!! it works :D
Sweeeeeeeeeeeeet!!!!!!

airwalk
Cacti User
Posts: 103
Joined: Fri Aug 18, 2006 11:22 am
Location: MSK, RU

#36 Post by airwalk » Fri Nov 17, 2006 6:33 am

thank you for another handy plugin

User avatar
TFC
Cacti Pro User
Posts: 722
Joined: Wed Apr 09, 2003 2:17 am
Location: Izmir/Turkey

#37 Post by TFC » Fri Nov 17, 2006 6:37 am

where can ı download?
I tray to download from cactiusers.org but unsuccessful

User avatar
TFC
Cacti Pro User
Posts: 722
Joined: Wed Apr 09, 2003 2:17 am
Location: Izmir/Turkey

#38 Post by TFC » Fri Nov 17, 2006 7:33 am

hi,
finally i can downloaded.
But after installation and changing permissions, i go to settings ,enable csv, then I give permission to admin to view dataqueries.
Then I can see nothing?
Nothing changes in my cacti..
Why?

fonseca
Posts: 6
Joined: Wed Nov 01, 2006 5:39 am

Plugin not working on windows

#39 Post by fonseca » Sun Nov 19, 2006 1:37 pm

Hello This Plugin not working on windows :
error is :
Notice: Undefined index: data in c:\Inetpub\wwwroot\cacti\plugins\dataquery\view\queryview.php on line 61
Query for Datasource: '
Thanks

airwalk
Cacti User
Posts: 103
Joined: Fri Aug 18, 2006 11:22 am
Location: MSK, RU

Re: Plugin not working on windows

#40 Post by airwalk » Mon Nov 20, 2006 4:43 am

fonseca wrote:Hello This Plugin not working on windows :
error is :
Notice: Undefined index: data in c:\Inetpub\wwwroot\cacti\plugins\dataquery\view\queryview.php on line 61
Query for Datasource: '
Thanks
Ahuber wrote:Hey blackakashi, and anyone else with the line 61 error,
look for a line in class_cactiquery.php (search) that goes like

str_replace(":", "\:", $data_source_path);

And replace the "\:" with just ":"

That is what fixed me up.

Good luck!

User avatar
TFC
Cacti Pro User
Posts: 722
Joined: Wed Apr 09, 2003 2:17 am
Location: Izmir/Turkey

#41 Post by TFC » Tue Nov 21, 2006 10:31 am

TFC wrote:hi,
finally i can downloaded.
But after installation and changing permissions, i go to settings ,enable csv, then I give permission to admin to view dataqueries.
Then I can see nothing?
Nothing changes in my cacti..
Why?
Can anybody help me?

Ahuber
Cacti User
Posts: 56
Joined: Thu Nov 16, 2006 1:57 pm
Location: BC, kootenays

#42 Post by Ahuber » Tue Nov 21, 2006 3:21 pm

TFC Are you sure there isn't an error message at the top of the page that shows nothing?

I'm assuming you did your $plugin []

double check to see if CSV export path exists. I don't think it self creates.
Also, enable viewing permission for the users which will use this.

User avatar
TFC
Cacti Pro User
Posts: 722
Joined: Wed Apr 09, 2003 2:17 am
Location: Izmir/Turkey

#43 Post by TFC » Wed Nov 22, 2006 1:53 am

Ahuber wrote:TFC Are you sure there isn't an error message at the top of the page that shows nothing?

I'm assuming you did your $plugin []

double check to see if CSV export path exists. I don't think it self creates.
Also, enable viewing permission for the users which will use this.
Ahuber wrote:TFC Are you sure there isn't an error message at the top of the page that shows nothing?

I'm assuming you did your $plugin []

double check to see if CSV export path exists. I don't think it self creates.
Also, enable viewing permission for the users which will use this.
Here is the config.php output:
$plugins = array();
//$plugins[] = 'thold';
$plugins[] = 'weathermap';
$plugins[] = 'hostinfo';
$plugins[] = 'thold';
$plugins[] = 'reports';
$plugins[] = 'devices';
$plugins[] = 'links';
$plugins[] = 'dataquery';
And plugins directory is:
[[email protected] plugins]# ls -la
...
drwxr-xr-x 6 root nobody 4096 Nov 17 13:47 dataquery
...
this is the user that run httpd:
[[email protected] plugins]# ps -ef |grep httpd
root 2110 1 0 Oct19 ? 00:00:03 /usr/sbin/httpd
apache 27523 2110 0 Nov21 ? 00:00:11 /usr/sbin/httpd
...
...
apache 23962 2110 0 Nov21 ? 00:00:02 /usr/sbin/httpd
apache 24065 2110 0 Nov21 ? 00:00:01 /usr/sbin/httpd
apache 24074 2110 0 Nov21 ? 00:00:01 /usr/sbin/httpd
...
...
And finally this is the csv directory permissions:
[[email protected] dataquery]# ls -la
total 80
drwxr-xr-x 6 root nobody 4096 Nov 17 13:47 .
drwxr-xr-x 9 root root 4096 Nov 17 13:47 ..
-rw-r--r-- 1 root root 11604 Nov 3 16:57 class_cactiquery.php
drwxr-xr-x 2 root root 4096 Nov 17 13:47 css
drwxrwxr-x 2 root apache 4096 Nov 17 13:47 csv
-rw-r--r-- 1 root root 4052 Nov 3 16:58 dataquery.php
drwxr-xr-x 2 root root 4096 Nov 17 13:47 images
-rw-r--r-- 1 root root 26925 Jul 25 10:15 LICENSE
-rw-r--r-- 1 root root 3880 Nov 3 16:57 README
-rw-r--r-- 1 root root 5222 Nov 3 16:58 setup.php
drwxr-xr-x 2 root root 4096 Nov 17 14:02 view
As you see permission is adjusted as README describe.
But dataquery icon not shown. I can give the realm permissions thats all.

Ahuber
Cacti User
Posts: 56
Joined: Thu Nov 16, 2006 1:57 pm
Location: BC, kootenays

#44 Post by Ahuber » Wed Nov 22, 2006 3:26 pm

I don't know if this counts, but i'm using cacti 0.8.6i (on windows with apache)
Is there a dataquery tab in your settings page in cacti?
your other post makes it sound like you do..
when you veiw your graph, under the graphs tab, the icon does NOT show up, correct?

Also, what version of dataquery are you trying to install?

User avatar
TFC
Cacti Pro User
Posts: 722
Joined: Wed Apr 09, 2003 2:17 am
Location: Izmir/Turkey

#45 Post by TFC » Thu Nov 23, 2006 1:06 am

Hi,
I give the permission for nobody to csv dir. also.
There is no dataquery tab (also there isno tab image in downloaded source)
And finally there is no icon shown.
The version of dataquery is Dataquery (dataquery - v0.1.2a)

Post Reply