Cacti (home)ForumsDocumentation
Cacti: offical forums and support
It is currently Mon Jul 24, 2017 3:46 am

All times are UTC - 5 hours




Post new topic Reply to topic  [ 46 posts ]  Go to page Previous  1, 2, 3, 4  Next
Author Message
 Post subject:
PostPosted: Fri Mar 30, 2007 1:57 pm 
Offline
Cacti User

Joined: Fri Feb 16, 2007 11:37 am
Posts: 372
Location: Emeryville, CA
I see the first two lines PollPerf STARTING and PollPerf ENDING, but i do not see the parser running.

My settings on the Misc tab are as follows:

Enable automatic Log Verbosity Management for PollPerf==Yes
Starting Time (Log Verbosity will be switched to DEBUG)==15:25
Number of DEBUG Cycles==10

Those are the only settings that i have. Also, since enabling the PollerPerf Plugin, i get the following at the top of EVERY cacti page visit:

Code:
Notice: Undefined index: settings.php: in E:\cacti\lib\functions.php on line 1422

If i comment out the PollPerf plugin, that message goes away.

Thanks again

app

_________________
Cacti Version - 0.8.7b
Plugin Architecture - 2.2 Beta
Poller Type - CMD.php
Server Info - Linux 2.6.9-78.0.1.ELsmp
Web Server - Apache/2.0.52 (Red Hat)
PHP - 4.3.9
MySQL - 4.1.22
RRDTool - 1.2.23
SNMP - 5.1.2
Plugins
    Global Plugin Settings (settings - v0.5)
    SuperLinks (superlinks - v0.72)
    Host Info (hostinfo - v0.2)
    Report Creator (reports - v0.3)
    Update Checker (update - v0.4)
    Realtime for Cacti (realtime - v0.35)
    Cacti Log View (clog - v1.1)
    RRD File Cleaner (rrdclean - v0.36)
    Network Discovery (discovery - v0.9)
    Uptime (uptime - v0.4)


Top
 Profile  
 
 Post subject:
PostPosted: Fri Mar 30, 2007 3:45 pm 
Offline
Developer
User avatar

Joined: Thu Dec 02, 2004 2:46 am
Posts: 22461
Location: Muenster, Germany
I've found an error. Please find the newest version attached to first post
Reinhard

_________________
Official Cacti Documentation
Official Debugging Help
Central Plugin Repository
Central Templates Repository


Top
 Profile  
 
 Post subject:
PostPosted: Sat Mar 31, 2007 8:01 am 
Offline
Developer
User avatar

Joined: Thu Dec 02, 2004 2:46 am
Posts: 22461
Location: Muenster, Germany
apperrault wrote:
... Also, since enabling the PollerPerf Plugin, i get the following at the top of EVERY cacti page visit:

Code:
Notice: Undefined index: settings.php: in E:\cacti\lib\functions.php on line 1422

If i comment out the PollPerf plugin, that message goes away.
I can't understand this one. I double checked to have the correct $nav code in my plugin. And the error message seems to tell us, that the $nav["settings.php"] is missing. But this is part of default cacti 0.8.6j code. Please check file ./lib/functions.php line 1403 to read
Code:
      "settings.php:" => array("title" => "Cacti Settings", "mapping" => "index.php:", "url" => "settings.php", "level" => "1"),

Reinhard

_________________
Official Cacti Documentation
Official Debugging Help
Central Plugin Repository
Central Templates Repository


Top
 Profile  
 
 Post subject:
PostPosted: Mon Apr 02, 2007 11:09 am 
Offline
Cacti User

Joined: Fri Feb 16, 2007 11:37 am
Posts: 372
Location: Emeryville, CA
Thanks for the help Gandolf. With the new version you posted, i got the poller performance numbers.

As for the other issue, my functions.php file is the same as what you posted it should be. I will probably keep the performance plugin disabled for the most part, and just enable it and run it once a week to make sure that things are still running OK.

Thanks for the help.

app

_________________
Cacti Version - 0.8.7b
Plugin Architecture - 2.2 Beta
Poller Type - CMD.php
Server Info - Linux 2.6.9-78.0.1.ELsmp
Web Server - Apache/2.0.52 (Red Hat)
PHP - 4.3.9
MySQL - 4.1.22
RRDTool - 1.2.23
SNMP - 5.1.2
Plugins
    Global Plugin Settings (settings - v0.5)
    SuperLinks (superlinks - v0.72)
    Host Info (hostinfo - v0.2)
    Report Creator (reports - v0.3)
    Update Checker (update - v0.4)
    Realtime for Cacti (realtime - v0.35)
    Cacti Log View (clog - v1.1)
    RRD File Cleaner (rrdclean - v0.36)
    Network Discovery (discovery - v0.9)
    Uptime (uptime - v0.4)


Top
 Profile  
 
 Post subject:
PostPosted: Mon Apr 02, 2007 1:56 pm 
Offline
Developer
User avatar

Joined: Thu Dec 02, 2004 2:46 am
Posts: 22461
Location: Muenster, Germany
apperrault wrote:
As for the other issue, my functions.php file is the same as what you posted it should be. I will probably keep the performance plugin disabled for the most part, and just enable it and run it once a week to make sure that things are still running OK.
I tried to figure it out to no avail. I can't imagine why this occurs; sorry
Reinhard

_________________
Official Cacti Documentation
Official Debugging Help
Central Plugin Repository
Central Templates Repository


Top
 Profile  
 
 Post subject: SQL Tables Missing
PostPosted: Tue Apr 03, 2007 10:56 am 
Offline

Joined: Wed Apr 20, 2005 1:21 pm
Posts: 4
I've been searching the forums with no luck on this one.

I have the poller installed, and it runs, but it does not update the MySQL Database with a table.

Here are the errors
Code:
04/03/2007 11:19:55 AM - CMDPHP: Poller[0] ERROR: SQL Exec Failed "REPLACE INTO plugin_pollperf_data ( `id`, `lstart`, `lend`, `ds_count`, `diff`, `rate`, `ds_per_run`, `dur_per_run`) VALUES ('124', '2007-04-03 00:00:00', '2007-04-03 00:00:00', '', '', 'None', 'None', 'None')"
04/03/2007 11:19:55 AM - CMDPHP: Poller[0] ERROR: SQL Exec Failed "REPLACE INTO plugin_pollperf_data ( `id`, `lstart`, `lend`, `ds_count`, `diff`, `rate`, `ds_per_run`, `dur_per_run`) VALUES ('123', '2007-04-03 00:00:00', '2007-04-03 00:00:00', '', '', 'None', 'None', 'None')"
04/03/2007 11:19:55 AM - CMDPHP: Poller[0] ERROR: SQL Exec Failed "REPLACE INTO plugin_pollperf_data ( `id`, `lstart`, `lend`, `ds_count`, `diff`, `rate`, `ds_per_run`, `dur_per_run`) VALUES ('121', '2007-04-03 00:00:00', '2007-04-03 00:00:00', '', '', 'None', 'None', 'None')"
04/03/2007 11:19:55 AM - CMDPHP: Poller[0] ERROR: SQL Exec Failed "REPLACE INTO plugin_pollperf_data ( `id`, `lstart`, `lend`, `ds_count`, `diff`, `rate`, `ds_per_run`, `dur_per_run`) VALUES ('120', '2007-04-03 00:00:00', '2007-04-03 00:00:00', '', '', 'None', 'None', 'None')"




Quote:
Cacti Version - 0.8.6j
Plugin Architecture - 1.1
Poller Type - CMD.php
Server Info - Linux 2.6.9-1.667smp
Web Server - Apache/2.0.52 (Fedora)
PHP - 4.3.9
PHP Extensions - yp, xml, wddx, tokenizer, sysvshm, sysvsem, standard, sockets, shmop, session, pspell, posix, pcre, overload, mime_magic, iconv, gmp, gettext, ftp, exif, dio, dbx, dba, curl, ctype, calendar, bz2, bcmath, zlib, openssl, apache2handler, mysql, snmp
MySQL - 3.23.58
RRDTool - 1.0.49
SNMP - 5.2.1.2
Plugins
    Host Info (hostinfo - v0.1)
    Poller Performance Report (pollperf - v0.32)
    rrdclean (RRD Cleaner - v1.2 (Hack Gilles Boulon))


Top
 Profile  
 
 Post subject:
PostPosted: Tue Apr 03, 2007 10:58 am 
Offline
Developer
User avatar

Joined: Thu Dec 02, 2004 2:46 am
Posts: 22461
Location: Muenster, Germany
Please perform and check:
Code:
$ grep POLLPERF ./log/cacti.log
03/30/2007 06:35:03 PM - POLLPERF: Poller[0] PollPerf STARTING
03/30/2007 07:25:04 PM - POLLPERF: Poller[0] PollPerf ENDING: 2
03/30/2007 07:25:37 PM - POLLPERF: Poller[0] Poller Performance Parser is now running
03/30/2007 07:25:37 PM - POLLPERF: Poller[0] Poller Performance Parser has finished
You should see exactly this result, timestamps will vary. And please report your "Settings -> Misc" for this plugin.
Reinhard

_________________
Official Cacti Documentation
Official Debugging Help
Central Plugin Repository
Central Templates Repository


Top
 Profile  
 
 Post subject: how to install a lot of plugins including Reports
PostPosted: Mon Apr 16, 2007 9:43 am 
Offline

Joined: Wed Apr 04, 2007 11:15 pm
Posts: 19
hlep me
I can see now report menu on consloe but it doesn't work properly
Do I need to do something with Mysql server. I cann't figure it out..


Top
 Profile  
 
 Post subject:
PostPosted: Mon Apr 16, 2007 1:12 pm 
Offline
Developer
User avatar

Joined: Thu Dec 02, 2004 2:46 am
Posts: 22461
Location: Muenster, Germany
Please perform the command shown in the previous post and post the results. Then, please show us the list of all tables in database "cacti"
Reinhard

_________________
Official Cacti Documentation
Official Debugging Help
Central Plugin Repository
Central Templates Repository


Top
 Profile  
 
 Post subject:
PostPosted: Tue Apr 17, 2007 4:46 pm 
Offline

Joined: Wed Feb 02, 2005 5:26 pm
Posts: 22
Location: Zurich, Switzerland
gandalf:

Thank you so much for this really wonderful plugin. Finally I'm able to trace down my bottlenecks in the polling-cycle!

cheers :lol:


Top
 Profile  
 
 Post subject:
PostPosted: Thu Nov 08, 2007 8:02 am 
Offline

Joined: Wed Feb 21, 2007 10:26 am
Posts: 17
I am not seeing any posted stats.

My server is configure as

Cacti Version 0.8.7
Plugin Architecture 1.3
Poller Type Cactid v
Server Info Linux 2.6.18-8.el5
Web Server Apache/2.2.3 (Red Hat)
PHP Version 5.1.6
MySQL Version 5.0.22
RRDTool Version 1.2.23

Poller Performance Report (pollperf - v0.32)


And "grep POLLPERF cacti.log" show only

11/07/2007 02:54:18 PM - POLLPERF: Poller[0] PollPerf cycles:
11/07/2007 02:59:17 PM - POLLPERF: Poller[0] PollPerf cycles:
11/07/2007 03:04:17 PM - POLLPERF: Poller[0] PollPerf cycles:

It is not shwoing me the starting and finishing messages.

Dose this version work for 0.8.7?

Thanks


Top
 Profile  
 
 Post subject:
PostPosted: Thu Nov 08, 2007 3:15 pm 
Offline

Joined: Wed Feb 21, 2007 10:26 am
Posts: 17
I ran this command and I get follwing messages.
-------------------------------------------------------------------
# php pollperf_parse.php

PHP Fatal error: Call to undefined function cacti_log() in /cacti/plugins/pollperf/pollperf_parse.php on line 339


Line 339 is
cacti_log("Poller Performance Parser is now running", true, "POLLPERF");
-----------------------------------------------------------------------------
Can some one tell me how fix this problem?


Top
 Profile  
 
 Post subject:
PostPosted: Fri Nov 09, 2007 10:15 am 
Offline

Joined: Wed Feb 21, 2007 10:26 am
Posts: 17
I found out that "plugin_pollperf_debug_cycles" was missing from seetings table.
After I add plugin_pollperf_debug_cycles into settings table, I see the PollPerf cysles number is decreasing but no other information on log file.

11/09/2007 10:04:19 AM - POLLPERF: Poller[0] PollPerf cycles: 4
11/09/2007 10:04:19 AM - POLLPERF: Poller[0] PollPerf cycles: 3
11/09/2007 10:04:19 AM - POLLPERF: Poller[0] PollPerf cycles: 2


Top
 Profile  
 
 Post subject:
PostPosted: Sat Nov 10, 2007 5:36 pm 
Offline
Developer
User avatar

Joined: Thu Dec 02, 2004 2:46 am
Posts: 22461
Location: Muenster, Germany
Did you import the provided SQL file? To be honest, I did not check with 087 and PIA1.3 yet
Reinhard

_________________
Official Cacti Documentation
Official Debugging Help
Central Plugin Repository
Central Templates Repository


Top
 Profile  
 
 Post subject:
PostPosted: Mon Nov 12, 2007 11:23 am 
Offline

Joined: Wed Feb 21, 2007 10:26 am
Posts: 17
/cacti/plugins/pollperf]# ls -lrt
-rw-r--r-- 1 cactiuser cacti 15237 Dec 11 2006 LICENSE
-rw-r--r-- 1 cactiuser cacti 679 Mar 13 2007 inc_pollperf_filter_table.php
-rw-r--r-- 1 cactiuser cacti 8485 Mar 14 2007 pollperf.php
-rw-r--r-- 1 cactiuser cacti 7843 Mar 30 2007 setup.php
-rw-r--r-- 1 cactiuser cacti 2714 Mar 30 2007 README
-rw-r--r-- 1 cactiuser cacti 11339 Nov 9 14:37 pollperf_parse.php
**
I do not see any sql files


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 46 posts ]  Go to page Previous  1, 2, 3, 4  Next

All times are UTC - 5 hours


Who is online

Users browsing this forum: No registered users and 4 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  

Protected by Anti-Spam ACP Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group