How to install Plugins on Cacti 8.8a

Announcements concerning Plugins for Cacti

Moderators: Moderators, Developers

Author
Message
bushrat
Posts: 6
Joined: Tue Jul 30, 2013 11:10 pm

Re: How to install Plugins on Cacti 8.8a

#16 Post by bushrat » Thu Aug 01, 2013 11:25 am

yes .. my apologies ... so we have :
/usr/share/cacti/site/plugins/monitoring
/usr/share/cacti/site/plugins/mactrack
/usr/share/cacti/site/plugins/settings

invotec
Posts: 8
Joined: Thu Aug 01, 2013 8:06 am

Re: How to install Plugins on Cacti 8.8a

#17 Post by invotec » Thu Aug 01, 2013 11:51 am

/usr/share/cacti/site/plugins/settings
/usr/share/cacti/site/plugins/monitor
etc...

enyap
Posts: 32
Joined: Mon Jun 24, 2013 3:37 am
Location: UK

Re: How to install Plugins on Cacti 8.8a

#18 Post by enyap » Thu Aug 01, 2013 12:30 pm

Hmm, that appears to be OK. If we focus on Monitor at the moment, what happens if you check the "show icon legend" box under Settings|Misc?
settings - Misc.PNG
settings - Misc.PNG (30.01 KiB) Viewed 3856 times
If that displays the legend, can you check that you have monitor enable on some devices.
Devices monitor.PNG
Devices monitor.PNG (4.53 KiB) Viewed 3856 times

invotec
Posts: 8
Joined: Thu Aug 01, 2013 8:06 am

Re: How to install Plugins on Cacti 8.8a

#19 Post by invotec » Thu Aug 01, 2013 12:39 pm

No legend. Still a blank screen. Do you still have to do some manual config that I may have overlooked?

bushrat
Posts: 6
Joined: Tue Jul 30, 2013 11:10 pm

Re: How to install Plugins on Cacti 8.8a

#20 Post by bushrat » Thu Aug 01, 2013 12:48 pm

Same here .. nothing happens when I enable that button .. besides it had always been set like that. I unchecked it, saved and checked it again just to be on the safe side

enyap
Posts: 32
Joined: Mon Jun 24, 2013 3:37 am
Location: UK

Re: How to install Plugins on Cacti 8.8a

#21 Post by enyap » Thu Aug 01, 2013 2:36 pm

I'm running Ubunto as well, with Cacti 0.8.8a and mine works fine.

Is there anything in the Cacti logs that might give an indication of what may be going on?

invotec
Posts: 8
Joined: Thu Aug 01, 2013 8:06 am

Re: How to install Plugins on Cacti 8.8a

#22 Post by invotec » Thu Aug 01, 2013 2:47 pm

I also installed thold plugin and the only thing that is in the log file is system stats. About the time I installed the thold plugin, I started to get thold stats in the log as well. I dont know what else to look for.

enyap
Posts: 32
Joined: Mon Jun 24, 2013 3:37 am
Location: UK

Re: How to install Plugins on Cacti 8.8a

#23 Post by enyap » Thu Aug 01, 2013 3:29 pm

What do you get in the Cacti log every time the poller runs? In my case, I get something like this...

08/01/2013 09:25:05 PM - SYSTEM THOLD STATS: Time:0.0043 Tholds:0 TotalHosts:35 DownHosts:0 NewDownHosts:0
08/01/2013 09:25:05 PM - SYSTEM STATS: Time:3.1968 Method:cmd.php Processes:1 Threads:N/A Hosts:36 HostsPerProcess:36 DataSources:43 RRDsProcessed:41

invotec
Posts: 8
Joined: Thu Aug 01, 2013 8:06 am

Re: How to install Plugins on Cacti 8.8a

#24 Post by invotec » Thu Aug 01, 2013 3:49 pm

I get the attached.
Attachments
cacti.log.png
cacti.log.png (199.88 KiB) Viewed 3855 times

enyap
Posts: 32
Joined: Mon Jun 24, 2013 3:37 am
Location: UK

Re: How to install Plugins on Cacti 8.8a

#25 Post by enyap » Thu Aug 01, 2013 4:03 pm

All very odd. Once again that looks fine and it's clearly picking up Thold as a plugin.

What do you get on the Thold tab under "Host Status" with Status set to "All"? Hopefully 5 devices.

enyap
Posts: 32
Joined: Mon Jun 24, 2013 3:37 am
Location: UK

Re: How to install Plugins on Cacti 8.8a

#26 Post by enyap » Thu Aug 01, 2013 6:06 pm

I think this may help...
http://forums.cacti.net/viewtopic.php?f=17&t=50263
I've just checked my Thold .php files as recommended and yes, I did change them and it works. Looking at monitor it has the same chdir, so worth a go. Looks like its something Ubunto specific.
Please let me know how you get on.

invotec
Posts: 8
Joined: Thu Aug 01, 2013 8:06 am

Re: How to install Plugins on Cacti 8.8a

#27 Post by invotec » Fri Aug 02, 2013 6:56 am

I altered the line in /usr/local/share/cacti/plugins/settings/email-test.php that the forum you mentioned suggested and the test email worked. I will try the other recommend files.

Thanks so much!

invotec
Posts: 8
Joined: Thu Aug 01, 2013 8:06 am

Re: How to install Plugins on Cacti 8.8a

#28 Post by invotec » Fri Aug 02, 2013 7:07 am

I also modified cli_thresholds.php, listthold.php, thold_add.php, thold_graph.php, thold.php, and thold_templates for the thold plugin, and it now works.

I modified monitor.php in the monitor plugin and it is working as well.

It looks like it is a symbolic link problem, and I will have to do this for every plugin I install.

Thanks for the all the help.

enyap
Posts: 32
Joined: Mon Jun 24, 2013 3:37 am
Location: UK

Re: How to install Plugins on Cacti 8.8a

#29 Post by enyap » Fri Aug 02, 2013 7:19 am

My pleasure :) Let's hope it fixes the problem for bushrat as will.

datboy
Posts: 1
Joined: Wed Aug 09, 2017 11:17 pm

Re: How to install Plugins on Cacti 8.8a

#30 Post by datboy » Thu Dec 28, 2017 5:56 am

Hi Hi Gentlemen,
i'm using ubuntu 16.04 and cacti 0.8.8f, and now facing the same problem
i changed

Code: Select all

chdir('../../');
(that still work on centOS)
to

Code: Select all

chdir('/usr/share/cacti/site');
but still cannot show any thing on the monitor tab, please make more detail what you modified
Thanks

Post Reply