Weathermap plugin for Cacti 1.1.30?

Announcements concerning Plugins for Cacti

Moderators: Moderators, Developers

Post Reply
Author
Message
shonaran
Cacti User
Posts: 59
Joined: Thu May 04, 2017 8:49 am

Weathermap plugin for Cacti 1.1.30?

#1 Post by shonaran » Thu Jan 18, 2018 7:49 pm

Can someone confirm that the weathermap plugin does not work for Cacti 1.1.30? Also, if yes, is there any estimate on when this might be available? Due to the heavy request for this plugin, I am considering rolling back to the earlier version of Cacti that supported this. Not sure if that is a good idea.


shonaran
Cacti User
Posts: 59
Joined: Thu May 04, 2017 8:49 am

Re: Weathermap plugin for Cacti 1.1.30?

#3 Post by shonaran » Fri Jan 19, 2018 11:09 am

Thank you for all the great work. If I wanted to use a stable version of weathermap (sounds that that is 0.98), which version of Cacti should I use?

User avatar
Osiris
Cacti Pro User
Posts: 834
Joined: Mon Jan 05, 2015 10:10 am

Re: Weathermap plugin for Cacti 1.1.30?

#4 Post by Osiris » Mon Jan 29, 2018 7:04 am

Database refactor I think.
Before history, there was a paradise, now dust.

netniV
Cacti Guru User
Posts: 2656
Joined: Sun Aug 27, 2017 12:05 am

Re: Weathermap plugin for Cacti 1.1.30?

#5 Post by netniV » Mon Jan 29, 2018 7:40 am

Cacti 0.8.x will work with Weathermaps 0.98 (see the branches on Howard Jones' GitHub repo https://github.com/howardjones/network- ... p/branches).

Cacti 1.x will work with the master branch once all work is completed, but it's not fully operational yet. If I recall the latest was that it displays maps in Cacti, but there are still errors and no editor yet.

If you have already updated to Cacti 1.x, going back isn't really an option without starting over because of the numerous database upgrades that take place during the upgrade. There is no downgrade code written so you'd either have to do it all manually or just wipe and start over (safer).

Post Reply