trouble with CPU (system) graphing

Post support questions that directly relate to Linux/Unix operating systems.

Moderators: Moderators, Developers

Post Reply
Author
Message
User avatar
mokeybrains
Posts: 42
Joined: Mon Aug 22, 2005 9:39 pm
Location: San Francisco, CA
Contact:

trouble with CPU (system) graphing

#1 Post by mokeybrains » Fri Jun 13, 2008 11:37 pm

The system CPU % is whack. I upped the maximum to 200 for CPU info (gandalf - your second link in your sig) and am getting values over 100% (???)

I ran top for 5 minutes and watched the CPU line... it stayed more or less like this:

Code: Select all

CPU:  0.0% user,  0.0% nice,  0.1% system, 16.4% interrupt, 83.6% idle
Also, I ran an snmpwalk every 15 seconds from the monitoring box:

Code: Select all

# while 1; snmpwalk -c secret -v2c mango .1.3.6.1.4.1.2021.11.52.0; sleep 15; 
while? end
UCD-SNMP-MIB::ssCpuRawSystem.0 = Counter32: 17125251
UCD-SNMP-MIB::ssCpuRawSystem.0 = Counter32: 17127127
UCD-SNMP-MIB::ssCpuRawSystem.0 = Counter32: 17128982
UCD-SNMP-MIB::ssCpuRawSystem.0 = Counter32: 17130911
UCD-SNMP-MIB::ssCpuRawSystem.0 = Counter32: 17132729
UCD-SNMP-MIB::ssCpuRawSystem.0 = Counter32: 17134501
UCD-SNMP-MIB::ssCpuRawSystem.0 = Counter32: 17136201
UCD-SNMP-MIB::ssCpuRawSystem.0 = Counter32: 17137955
UCD-SNMP-MIB::ssCpuRawSystem.0 = Counter32: 17139775
UCD-SNMP-MIB::ssCpuRawSystem.0 = Counter32: 17141607
UCD-SNMP-MIB::ssCpuRawSystem.0 = Counter32: 17143392
UCD-SNMP-MIB::ssCpuRawSystem.0 = Counter32: 17145186
UCD-SNMP-MIB::ssCpuRawSystem.0 = Counter32: 17147013
UCD-SNMP-MIB::ssCpuRawSystem.0 = Counter32: 17148990
UCD-SNMP-MIB::ssCpuRawSystem.0 = Counter32: 17150804
UCD-SNMP-MIB::ssCpuRawSystem.0 = Counter32: 17152707
UCD-SNMP-MIB::ssCpuRawSystem.0 = Counter32: 17154571
UCD-SNMP-MIB::ssCpuRawSystem.0 = Counter32: 17156442
UCD-SNMP-MIB::ssCpuRawSystem.0 = Counter32: 17158148
UCD-SNMP-MIB::ssCpuRawSystem.0 = Counter32: 17160031
UCD-SNMP-MIB::ssCpuRawSystem.0 = Counter32: 17160240
UCD-SNMP-MIB::ssCpuRawSystem.0 = Counter32: 17160248
UCD-SNMP-MIB::ssCpuRawSystem.0 = Counter32: 17160258
UCD-SNMP-MIB::ssCpuRawSystem.0 = Counter32: 17160268
UCD-SNMP-MIB::ssCpuRawSystem.0 = Counter32: 17160274
UCD-SNMP-MIB::ssCpuRawSystem.0 = Counter32: 17160302
UCD-SNMP-MIB::ssCpuRawSystem.0 = Counter32: 17160306
UCD-SNMP-MIB::ssCpuRawSystem.0 = Counter32: 17160332
UCD-SNMP-MIB::ssCpuRawSystem.0 = Counter32: 17161291
UCD-SNMP-MIB::ssCpuRawSystem.0 = Counter32: 17163080
UCD-SNMP-MIB::ssCpuRawSystem.0 = Counter32: 17164655
UCD-SNMP-MIB::ssCpuRawSystem.0 = Counter32: 17166290
UCD-SNMP-MIB::ssCpuRawSystem.0 = Counter32: 17168062
UCD-SNMP-MIB::ssCpuRawSystem.0 = Counter32: 17169778
UCD-SNMP-MIB::ssCpuRawSystem.0 = Counter32: 17171606
UCD-SNMP-MIB::ssCpuRawSystem.0 = Counter32: 17173508
UCD-SNMP-MIB::ssCpuRawSystem.0 = Counter32: 17175340
UCD-SNMP-MIB::ssCpuRawSystem.0 = Counter32: 17177205
UCD-SNMP-MIB::ssCpuRawSystem.0 = Counter32: 17179068
UCD-SNMP-MIB::ssCpuRawSystem.0 = Counter32: 17180836
UCD-SNMP-MIB::ssCpuRawSystem.0 = Counter32: 17182567
UCD-SNMP-MIB::ssCpuRawSystem.0 = Counter32: 17184476
UCD-SNMP-MIB::ssCpuRawSystem.0 = Counter32: 17186271
UCD-SNMP-MIB::ssCpuRawSystem.0 = Counter32: 17187997
UCD-SNMP-MIB::ssCpuRawSystem.0 = Counter32: 17189811
UCD-SNMP-MIB::ssCpuRawSystem.0 = Counter32: 17191677
UCD-SNMP-MIB::ssCpuRawSystem.0 = Counter32: 17193540
UCD-SNMP-MIB::ssCpuRawSystem.0 = Counter32: 17195415
UCD-SNMP-MIB::ssCpuRawSystem.0 = Counter32: 17197280
UCD-SNMP-MIB::ssCpuRawSystem.0 = Counter32: 17199173
box is FreeBSD 7, using net-snmp-5.4.1. What is going on? Is the proper OID being queried? Why am I seeing 100% + but not in top? (load is near 0).
Attachments
mango-cpu-system.png
over 100% :(
mango-cpu-system.png (30.87 KiB) Viewed 3188 times

User avatar
mokeybrains
Posts: 42
Joined: Mon Aug 22, 2005 9:39 pm
Location: San Francisco, CA
Contact:

going to try the hrProcessor...

#2 Post by mokeybrains » Sat Jun 14, 2008 12:07 am

Just noticed this new query...
http://forums.cacti.net/viewtopic.php?t=27099

Eager to see what it graphs. :)

User avatar
gandalf
Developer
Posts: 22375
Joined: Thu Dec 02, 2004 2:46 am
Location: Muenster, Germany
Contact:

Re: trouble with CPU (system) graphing

#3 Post by gandalf » Sat Jun 14, 2008 2:33 pm

mokeybrains wrote:The system CPU % is whack. I upped the maximum to 200 for CPU info (gandalf - your second link in your sig) and am getting values over 100% (???)
Pre net-snmp 5.4.x reports 100% for each CPU. With 5.4, this changed. But unfortunately, I've not got the chance to use that very version until now.
Reinhard

User avatar
mokeybrains
Posts: 42
Joined: Mon Aug 22, 2005 9:39 pm
Location: San Francisco, CA
Contact:

Thanks

#4 Post by mokeybrains » Sat Jun 14, 2008 2:46 pm

I thought the machine was going bonkers -- then I thought I'd done something wrong -- then I remembered I'd installed the newest net-snmp... I was suspecting that. :)
Attachments
maybe-bunk-system-value.png
maybe-bunk-system-value.png (25.75 KiB) Viewed 3154 times

Post Reply