Debian Over 80Mbps Problem

Post support questions that directly relate to Linux/Unix operating systems.

Moderators: Moderators, Developers

Post Reply
Author
Message
VanDaMe
Posts: 7
Joined: Wed Aug 27, 2008 10:35 pm

Debian Over 80Mbps Problem

#1 Post by VanDaMe » Sun Apr 18, 2010 10:07 pm

I have a debian servers with over 100Mbps
I already used 64bit counter when creating graph, as well as my servers is installed using 64bit OS. I also using snmp version 2 already

Is there any other way to fix this?
Attachments
graph_image.png
graph_image.png (45.95 KiB) Viewed 1125 times

User avatar
gandalf
Developer
Posts: 22375
Joined: Thu Dec 02, 2004 2:46 am
Location: Muenster, Germany
Contact:

#2 Post by gandalf » Wed Apr 21, 2010 3:24 pm

Please verify the rrd files MAX value. See e.g. related chapter in 2nd link of my sig. This tells you how to extaned the MAX if this turns out to be the problem
R.

User avatar
mokeybrains
Posts: 42
Joined: Mon Aug 22, 2005 9:39 pm
Location: San Francisco, CA
Contact:

Re: Debian Over 80Mbps Problem

#3 Post by mokeybrains » Tue Apr 22, 2014 12:10 pm

Yep, "rrdtool tune" fixes this... I've noticed setting the RRD max on existing data sources via the cacti web interface doesn't seem to fixup the RRD file. Here is a nifty way to recalibrate all your traffic graphs to handle up to 10Gbps:

Code: Select all

#!/usr/bin/perl
#
# raise-max-for-traffic.pl
#
# Set your RRA path
chdir('/usr/local/share/cacti/rra') || die "Set the path for your RRA files\n";
for (<*traffic_*>) {
        print "Tuning: $_\n";
        `rrdtool tune $_  -a traffic_out:1250000000 -a traffic_in:1250000000`;
}

Post Reply