ERROR: Installed RRDTool version does not match configured

Post support questions that directly relate to Linux/Unix operating systems.

Moderators: Moderators, Developers

Post Reply
Author
Message
doiggl
Cacti User
Posts: 222
Joined: Wed Dec 16, 2009 6:32 am

ERROR: Installed RRDTool version does not match configured

#1 Post by doiggl » Mon May 03, 2010 6:15 pm

I see this error message in the Technical Support | General Information page
ERROR: Installed RRDTool version does not match configured version.

This version is installed.
# rpm -qa | grep -i RRD
rrdtool-1.4.3-2.4.x86_64


In the Configuration Settings the RRDTool Utility Version dropdown list only shows
RRDTool 1.1x
RRDTool 1.2x
RRDTool 1.3x

Will that cause problems because there is no 1.4x
Thanks

User avatar
Sirup
Cacti Moderator
Posts: 348
Joined: Tue Mar 02, 2010 9:03 am

#2 Post by Sirup » Tue May 04, 2010 5:01 am

Ignore it
[size=67]Cacti version: 0.8.7e5
OS: FreeBSD 7.2
Plugin Architecture: 2.6
Plugins: aggregate 0.74, autom8 0.33, loginmod 1.0

[url=http://docs.cacti.net/manual:087]Official Cacti Documentation[/url]
[url=http://docs.cacti.net/manual:087:4_help.2_debugging#debugging]Gandalfs Official Debugging Help[/url]
[/size]

User avatar
gandalf
Developer
Posts: 22375
Joined: Thu Dec 02, 2004 2:46 am
Location: Muenster, Germany
Contact:

#3 Post by gandalf » Tue May 04, 2010 2:41 pm

Sirup wrote:Ignore it
... until 087f is out :wink:
R.

russian.qwerty
Posts: 12
Joined: Wed Nov 25, 2009 9:08 am

#4 Post by russian.qwerty » Tue May 25, 2010 5:12 am

Hello.

Despite the fact that the menu item will appear for RRDTool 1.4.x. I have the same problem with the latest version 0.8.7f on EL5.

rpm -q rrdtool rrdtool-devel rrdutils
rrdtool-1.4.3-2.el5.rf
rrdtool-devel-1.4.3-2.el5.rf
rrdutils-5.2.1-1.el5.rf

Is there any patch for this?

dzm
Posts: 12
Joined: Thu May 20, 2010 6:44 pm

#5 Post by dzm » Tue May 25, 2010 7:35 pm

I'm using Cacti 0.8.7f and am seeing this error. It comes from a copy/paste bug in utilities.php.

On line 246 you'll find this:

Code: Select all

                       if (ereg("^RRDtool 1\.4", $out_array[0])) {
                                $rrdtool_version = "rrd-1.3.x";
                        }else if (ereg("^RRDtool 1\.3\.", $out_array[0])) {
                                $rrdtool_version = "rrd-1.3.x";
                        }else if (ereg("^RRDtool 1\.2\.", $out_array[0])) {
                                $rrdtool_version = "rrd-1.2.x";
                        }else if (ereg("^RRDtool 1\.0\.", $out_array[0])) {
                                $rrdtool_version = "rrd-1.0.x";
Edit the second line so it looks like this:

Code: Select all

                        if (ereg("^RRDtool 1\.4", $out_array[0])) {
                                $rrdtool_version = "rrd-1.4.x";
                        }else if (ereg("^RRDtool 1\.3\.", $out_array[0])) {
                                $rrdtool_version = "rrd-1.3.x";
                        }else if (ereg("^RRDtool 1\.2\.", $out_array[0])) {
                                $rrdtool_version = "rrd-1.2.x";
                        }else if (ereg("^RRDtool 1\.0\.", $out_array[0])) {
                                $rrdtool_version = "rrd-1.0.x";
Last edited by dzm on Wed May 26, 2010 12:05 pm, edited 1 time in total.

User avatar
Sirup
Cacti Moderator
Posts: 348
Joined: Tue Mar 02, 2010 9:03 am

#6 Post by Sirup » Wed May 26, 2010 1:55 am

If not already done, please file a bug report: http://www.cacti.net/bugs.php
[size=67]Cacti version: 0.8.7e5
OS: FreeBSD 7.2
Plugin Architecture: 2.6
Plugins: aggregate 0.74, autom8 0.33, loginmod 1.0

[url=http://docs.cacti.net/manual:087]Official Cacti Documentation[/url]
[url=http://docs.cacti.net/manual:087:4_help.2_debugging#debugging]Gandalfs Official Debugging Help[/url]
[/size]

dzm
Posts: 12
Joined: Thu May 20, 2010 6:44 pm

#7 Post by dzm » Wed May 26, 2010 12:11 pm

Sirup wrote:If not already done, please file a bug report: http://www.cacti.net/bugs.php
http://bugs.cacti.net/view.php?id=1765

User avatar
Sirup
Cacti Moderator
Posts: 348
Joined: Tue Mar 02, 2010 9:03 am

#8 Post by Sirup » Thu May 27, 2010 2:57 am

Thanks - Bug is now already assigned :)
[size=67]Cacti version: 0.8.7e5
OS: FreeBSD 7.2
Plugin Architecture: 2.6
Plugins: aggregate 0.74, autom8 0.33, loginmod 1.0

[url=http://docs.cacti.net/manual:087]Official Cacti Documentation[/url]
[url=http://docs.cacti.net/manual:087:4_help.2_debugging#debugging]Gandalfs Official Debugging Help[/url]
[/size]

User avatar
gandalf
Developer
Posts: 22375
Joined: Thu Dec 02, 2004 2:46 am
Location: Muenster, Germany
Contact:

#9 Post by gandalf » Thu May 27, 2010 2:18 pm

... and resolved. Stupid me :cry:
R.

Post Reply