spine SNMP Timeouts

Post support questions that directly relate to Linux/Unix operating systems.

Moderators: Moderators, Developers

Post Reply
Author
Message
jgrohol
Posts: 26
Joined: Wed Sep 22, 2010 3:55 pm

spine SNMP Timeouts

#1 Post by jgrohol » Fri Oct 29, 2010 9:54 am

I'm working on moving to spine from cmd.php. cmd.php works fine and collects data fine, it is just hogging CPU and resources and taking close to 250 seconds to poll all of our devices.

I've compiled spine and selected it in settings. It collects data, however for several hosts I am getting: SPINE: Poller[0] Host[146] TH[1] DS[6812] WARNING: SNMP timeout detected [5000 ms], ignoring host '<IP>'

I've read all of the posts I can on that error, and I've made all of the SNMP timeout changes, changes to the processes and threads of spine, but still get this error.

Any clues?

cacti 0.8.7g
spine 0.8.7g
RHEL 5 32bit

yuval_ba
Posts: 32
Joined: Mon Oct 13, 2008 6:19 am

Re: spine SNMP Timeouts

#2 Post by yuval_ba » Sun Nov 14, 2010 1:53 pm

Check the problematic device's settings, what value do you have for "Maximum OID's Per Get Request"?
This controls the use of snmpbulkwalk request.
Try reducing the number for this devices and see if it helps.
Some devices are too weak to handle massive bulkwalk requests, I noticed this problem with Cisco 3750's

Post Reply