Spine 1 Minute Polling Problem

Post support questions that directly relate to Linux/Unix operating systems.

Moderators: Moderators, Developers

Post Reply
Author
Message
shoelessfarmer
Posts: 11
Joined: Sun Mar 21, 2010 6:35 pm

Spine 1 Minute Polling Problem

#1 Post by shoelessfarmer » Mon Nov 08, 2010 5:40 pm

Hello,

I am currently having a problem with a Spine when trying to do a 1 minute interval. When I use cmd.php the 1 minute polling works perfectly...as soon as I switch to Spine, it immediately breaks.

Specifics:
CentOS 5.5
cacti-0.8.7g-2.el5.rf (RPM from RPM Forge)
cacti-spine-0.8.7g (built from source)

Logs show the following (this effectively repeats every minute):
11/07/2010 07:05:01 AM - POLLER: Poller[0] NOTE: Poller Int: '60', Cron Int: '60', Time Since Last: '60', Max Runtime '58', Poller Runs: '1'
11/07/2010 07:05:01 AM - POLLER: Poller[0] DEBUG: About to Spawn a Remote Process [CMD: /usr/local/spine/spine, ARGS: 0 3]
11/07/2010 07:06:00 AM - POLLER: Poller[0] Maximum runtime of 58 seconds exceeded. Exiting.
11/07/2010 07:06:00 AM - SYSTEM STATS: Time:58.7854 Method:spine Processes:1 Threads:30 Hosts:4 HostsPerProcess:4 DataSources:22 RRDsProcessed:0

I found a bug, 1815 (http://bugs.cacti.net/view.php?id=1815) which looks like it addressed this problem...what I can't seem to find out is if the version of code they mentioned in the bug has been rolled into 0.8.7g. Anybody have any insight into this?

TIA!!!!

yuval_ba
Posts: 32
Joined: Mon Oct 13, 2008 6:19 am

Re: Spine 1 Minute Polling Problem

#2 Post by yuval_ba » Sun Nov 14, 2010 1:31 pm

You don't need to change your cron job interval to 1 min in order to get 1 min polling.
Try leaving your cron job at 5 min interval and only setting poller interval to 1 min inside Cacti settings.
There is a great thread about 1 min polling you can check out here:
http://forums.cacti.net/viewtopic.php?f ... 85&start=0

Post Reply