does cacti works with php5-mysqlnd ?

Post support questions that directly relate to Linux/Unix operating systems.

Moderators: Moderators, Developers

Author
Message
c3226026
Cacti User
Posts: 87
Joined: Mon Jan 17, 2011 12:15 pm

Re: does cacti works with php5-mysqlnd ?

#16 Post by c3226026 » Fri Feb 24, 2012 4:10 am

noname wrote: Probably that error is not recorded by the above test code. Then there is no clue..
Yes I think also, in fact it's not a php error but a mysql connection error, so I think it's for that than there is nothing on "errors" php log.

Many thanks for your help.

noname
Cacti Guru User
Posts: 1566
Joined: Thu Aug 05, 2010 2:04 am
Location: Japan

Re: does cacti works with php5-mysqlnd ?

#17 Post by noname » Fri Feb 24, 2012 4:20 am

c3226026 wrote:Yes I think also, in fact it's not a php error but a mysql connection error, so I think it's for that than there is nothing on "errors" php log.
Ah, I see.
If the following lines are added after ADONewConnection(), probably you may see them. (But why it fails..?)

Code: Select all

if (!$conn) {
        print "ADONewConnection() failed\n";
        exit;
}

c3226026
Cacti User
Posts: 87
Joined: Mon Jan 17, 2011 12:15 pm

Re: does cacti works with php5-mysqlnd ?

#18 Post by c3226026 » Fri Feb 24, 2012 9:46 am

I've try with this

.
.
$dsn = 'mysql://cactiuser:[email protected]/cacti?persist&port=3306';
$conn = ADONewConnection($dsn);
if (!$conn) {
print "ADONewConnection() failed\n";
exit;
}
.
.


but result is same only :
FATAL: Cannot connect to MySQL server on 'localhost'. Please make sure you have specified a valid MySQL database name in 'include/config.php'

noname
Cacti Guru User
Posts: 1566
Joined: Thu Aug 05, 2010 2:04 am
Location: Japan

Re: does cacti works with php5-mysqlnd ?

#19 Post by noname » Wed Mar 07, 2012 1:16 am

Changes in new PHP 5.4 (01 March 2012):

http://www.php.net/manual/en/migration54.extensions-other.php
The MySQL extensions mysql, mysqli and PDO_mysql use mysqlnd as the default library now. It is still possible to use libmysql by specifying a path to the configure options.
I'm not sure whether it affects the issue of this topic..

User avatar
rony
Developer/Forum Admin
Posts: 6016
Joined: Mon Nov 17, 2003 6:35 pm
Location: Michigan, USA
Contact:

Re: does cacti works with php5-mysqlnd ?

#20 Post by rony » Wed Mar 07, 2012 8:57 am

We have yet to test and confirm that Cacti works with PHP 5.4.

We are planning a release to address some issues in 0.8.7. If it's found that we need to change Cacti to work with PHP 5.4, those changes will be included in the next point release.
[size=117][i][b]Tony Roman[/b][/i][/size]
[size=84][i]Experience is what causes a person to make new mistakes instead of old ones.[/i][/size]
[size=84][i]There are only 3 way to complete a project: Good, Fast or Cheap, pick two.[/i][/size]
[size=84][i]With age comes wisdom, what you choose to do with it determines whether or not you are wise.[/i][/size]

c3226026
Cacti User
Posts: 87
Joined: Mon Jan 17, 2011 12:15 pm

Re: does cacti works with php5-mysqlnd ?

#21 Post by c3226026 » Wed Mar 07, 2012 1:00 pm

Many thanks for your answer rony, do you've some news for cacti 1.0.0 ?

I've some trouble with libmysqlclent-dev for mysql 5.5 and spine :

with libmysqlclient-dev for mysql 5.1 => spine file result compil size => 284 Ko

with libmysqlclient-dev for mysql 5.5 => spine file result compil size => 6 Mo .... :cry:

Post Reply