[Solved] ERROR: can't parse argument '-'

Post support questions that directly relate to Linux/Unix operating systems.

Moderators: Moderators, Developers

Post Reply
Author
Message
User avatar
blackstrip
Posts: 16
Joined: Tue Sep 10, 2013 10:45 pm

[Solved] ERROR: can't parse argument '-'

#1 Post by blackstrip » Thu Sep 12, 2013 2:15 am

Hi guys, I defined a data source, but i get follow message, how to fix it?
I think is "DS:traffic_in:COUNTER:600:0:10000000 - 5m" problem, but how to modify it?
thx :)

# rrdtool create \
> /usr/local/apache/htdocs/cacti/rra/dalian-mr01_traffic_in_5546.rrd \
> --step 300 \
> DS:traffic_in:COUNTER:600:0:10000000 - 5m \
> DS:traffic_out:COUNTER:600:0:10000000 - 5m \
> RRA:AVERAGE:0.5:1:500 \
> RRA:AVERAGE:0.5:1:600 \
> RRA:AVERAGE:0.5:6:700 \
> RRA:AVERAGE:1:6:2016 \
> RRA:AVERAGE:0.5:24:775 \
> RRA:AVERAGE:0.5:288:797 \
> RRA:AVERAGE:0.5:24:11000 \
> RRA:MAX:0.5:1:500 \
> RRA:MAX:0.5:1:600 \
> RRA:MAX:0.5:6:700 \
> RRA:MAX:1:6:2016 \
> RRA:MAX:0.5:24:775 \
> RRA:MAX:0.5:288:797 \
> RRA:MAX:0.5:24:11000 \
>
ERROR: can't parse argument '-'
Last edited by blackstrip on Wed Sep 25, 2013 12:38 am, edited 1 time in total.

User avatar
blackstrip
Posts: 16
Joined: Tue Sep 10, 2013 10:45 pm

Re: ERROR: can't parse argument '-'

#2 Post by blackstrip » Thu Sep 12, 2013 2:24 am

it's fixed.
go to 'Data Template', and edit "Data Source" - "Name", well done.
but i got problem again.
:x

#rrdtool create \
> /usr/local/apache/htdocs/cacti/rra/dalian-mr01_traffic_in_5546.rrd \
> --step 300 \
> DS:traffic_in:COUNTER:600:0:U \
> DS:traffic_out:COUNTER:600:0:U \
> RRA:AVERAGE:0.5:1:500 \
> RRA:AVERAGE:0.5:1:600 \
> RRA:AVERAGE:0.5:6:700 \
> RRA:AVERAGE:1:6:2016 \
> RRA:AVERAGE:0.5:24:775 \
> RRA:AVERAGE:0.5:288:797 \
> RRA:AVERAGE:0.5:24:11000 \
> RRA:MAX:0.5:1:500 \
> RRA:MAX:0.5:1:600 \
> RRA:MAX:0.5:6:700 \
> RRA:MAX:1:6:2016 \
> RRA:MAX:0.5:24:775 \
> RRA:MAX:0.5:288:797 \
> RRA:MAX:0.5:24:11000 \
>
ERROR: Invalid xff: must be between 0 and 1

What's wrong? isn't 0.5 not allow?

User avatar
blackstrip
Posts: 16
Joined: Tue Sep 10, 2013 10:45 pm

Re: ERROR: can't parse argument '-'

#3 Post by blackstrip » Thu Sep 12, 2013 2:32 am

8) got it.

change My RRAs all "X-Files Factor" to 0.5, it's work.

:lol:

Post Reply