Cacti (home)ForumsDocumentation
Cacti: offical forums and support
It is currently Thu Dec 14, 2017 11:56 am

All times are UTC - 5 hours




Post new topic Reply to topic  [ 30 posts ]  Go to page Previous  1, 2
Author Message
 Post subject: Re: Install cacti 1.0.2 with apt-get
PostPosted: Wed Jul 26, 2017 5:51 am 
Offline
Cacti User

Joined: Fri Feb 10, 2017 12:41 pm
Posts: 50
Paul,
I'm not sure but maybe there is something wrong with the Graph Templates.
When I add a switch and add the graphs for the interfaces, cacti produces that: (cacti1.jpg)
It doesn't name the graph "Gi1/0/7". Instead it is replaced with the description of the interface.
In my cacti 0.8.8 that works fine.
Do you think that's an issue of your package?

Maybe that's related to the other graph issue with the colours.


Last edited by Axel90 on Tue Aug 01, 2017 2:58 am, edited 1 time in total.

Top
 Profile  
 
 Post subject: Re: Install cacti 1.0.2 with apt-get
PostPosted: Thu Jul 27, 2017 9:49 am 
Offline
Cacti Pro User

Joined: Tue Aug 29, 2006 4:09 pm
Posts: 541
Location: NL
Axel90 wrote:
Do you think that's an issue of your package?

It may, but I don't think so as I don't do anything on that front in the package. However, I did see some other thread on the forum (or in a Debian bug) about snmp behavior having changed. Did you update anything else between your cacti 0.8.8h and now as well?

I suggest starting a new thread with a proper title.

_________________
Maintainer of cacti in Debian (and Ubuntu).
Cacti 1.* is now officially supported on Debian Stretch via Debian backports
My PPA for cacti backports in Ubuntu
FAQ Ubuntu and Debian differences
Generic cacti debugging


Top
 Profile  
 
 Post subject: Re: Install cacti 1.0.2 with apt-get
PostPosted: Sat Jul 29, 2017 6:34 pm 
Offline
Cacti Pro User
User avatar

Joined: Mon Jan 05, 2015 10:10 am
Posts: 542
Sync you template from the graph template menu.

_________________
Before history, there was a paradise, now dust.


Top
 Profile  
 
 Post subject: Re: Install cacti 1.0.2 with apt-get
PostPosted: Mon Jul 31, 2017 9:08 am 
Offline
Cacti User

Joined: Fri Feb 10, 2017 12:41 pm
Posts: 50
@Osiris How?


Top
 Profile  
 
 Post subject: Re: Install cacti 1.0.2 with apt-get
PostPosted: Mon Jul 31, 2017 10:16 pm 
Offline
Cacti Pro User
User avatar

Joined: Mon Jan 05, 2015 10:10 am
Posts: 542
Goto Graph Templates and look at action dropdown.

_________________
Before history, there was a paradise, now dust.


Top
 Profile  
 
 Post subject: Re: Install cacti 1.0.2 with apt-get
PostPosted: Tue Aug 01, 2017 2:54 am 
Offline
Cacti User

Joined: Fri Feb 10, 2017 12:41 pm
Posts: 50
ah, there!

that doesn't solve it, but it works when I recreate the single graphs of a device.

So I'm fine with that. Thanks.



paulgevers wrote:
It may, but I don't think so as I don't do anything on that front in the package. However, I did see some other thread on the forum (or in a Debian bug) about snmp behavior having changed. Did you update anything else between your cacti 0.8.8h and now as well?

I suggest starting a new thread with a proper title.


Never mind me asking! Was a mistake of mine.



I installed the current cacti 1.1.13 on a parallel system so I can test everything. But it looks very good.

I will try the inplace upgrade from my current 0.8.8f to 1.1.13 soon.


Top
 Profile  
 
 Post subject: Re: Install cacti 1.0.2 with apt-get
PostPosted: Mon Sep 18, 2017 4:49 am 
Offline
Cacti User

Joined: Fri Feb 10, 2017 12:41 pm
Posts: 50
Hey Paul,

I noticed that you created version 1.1.21. Works great!

Can you tell me when you intend to create 1.1.22 or above?

Don't want to rush, just informational.

Thank you.


Top
 Profile  
 
 Post subject: Re: Install cacti 1.0.2 with apt-get
PostPosted: Mon Sep 18, 2017 12:17 pm 
Offline
Cacti Pro User

Joined: Tue Aug 29, 2006 4:09 pm
Posts: 541
Location: NL
Axel90 wrote:
I noticed that you created version 1.1.21. Works great!

Thanks for the feedback.
Axel90 wrote:
Can you tell me when you intend to create 1.1.22 or above?

I am automatically notified of new releases. If I spot that serious bugs are reported I hold off. If that is not the case I may follow or skip a release. I'll probably update at least once a month (no promises).

_________________
Maintainer of cacti in Debian (and Ubuntu).
Cacti 1.* is now officially supported on Debian Stretch via Debian backports
My PPA for cacti backports in Ubuntu
FAQ Ubuntu and Debian differences
Generic cacti debugging


Top
 Profile  
 
 Post subject: Re: Install cacti 1.0.2 with apt-get
PostPosted: Tue Sep 19, 2017 1:40 am 
Offline
Cacti User

Joined: Fri Feb 10, 2017 12:41 pm
Posts: 50
Quote:
I'll probably update at least once a month (no promises).


That would be great.

I had issues with the cycle plugin, the new version of the plugin only works with >= 1.1.22 though.


Top
 Profile  
 
 Post subject: Re: Install cacti 1.0.2 with apt-get
PostPosted: Mon Oct 30, 2017 5:35 am 
Offline
Cacti User

Joined: Fri Feb 10, 2017 12:41 pm
Posts: 50
Hey Paul,

want to give you some feedback.

The upgrade to 1.1.25 went fine.

Everything is working, but there is one thing:

The legend font of all graphs became worse.

Do you know what could be the problem?

before:

Attachment:
before.JPG
before.JPG [ 38.36 KiB | Viewed 121 times ]


after:

Attachment:
after.JPG
after.JPG [ 36.99 KiB | Viewed 121 times ]


Top
 Profile  
 
 Post subject: Re: Install cacti 1.0.2 with apt-get
PostPosted: Mon Oct 30, 2017 1:46 pm 
Offline
Cacti Pro User

Joined: Tue Aug 29, 2006 4:09 pm
Posts: 541
Location: NL
Axel90 wrote:
The legend font of all graphs became worse.

Do you know what could be the problem?

I don't recognize the issue (doesn't happen on my system). Maybe start a new tread with a good title.

To be honest, font handling may be slightly different in Debian/Ubuntu. It is still on my TODO list to check if I am doing the best I can.

_________________
Maintainer of cacti in Debian (and Ubuntu).
Cacti 1.* is now officially supported on Debian Stretch via Debian backports
My PPA for cacti backports in Ubuntu
FAQ Ubuntu and Debian differences
Generic cacti debugging


Top
 Profile  
 
 Post subject: Re: Install cacti 1.0.2 with apt-get
PostPosted: Wed Nov 01, 2017 3:18 am 
Offline
Cacti User

Joined: Fri Feb 10, 2017 12:41 pm
Posts: 50
It's very strange because the other fonts of the graphs are the same.

I don't know why only the legend graph changed.

But It was good before, so it definitely has to do with the new cacti version.

Maybe it has to do with my Ubuntu 17.04.

Am I lacking fonts?


I mean it's not a big problem for now. I think the best thing to do is waiting for a new version in your repo. And hope everything is normal again.

And maybe you figure something out in the meanwhile.


Top
 Profile  
 
 Post subject: Re: Install cacti 1.0.2 with apt-get
PostPosted: Wed Nov 15, 2017 3:26 am 
Offline
Cacti User

Joined: Fri Feb 10, 2017 12:41 pm
Posts: 50
Hey Paul,

just installed your new version.

The upgrade process worked fine, as always!

I want to give you an update to the fonts:

Attachment:
cacti3.JPG
cacti3.JPG [ 36.07 KiB | Viewed 77 times ]


The headline is now bold; the axis font, too.

Additionally, the axis font changed.

But that's totally okay!

But the legend font is still lousy; it's so hard to read.

Do you have any idea / hint / suggestion?

I started a new thread but don't get any reply.

I don't know what I can do..


Top
 Profile  
 
 Post subject: Re: Install cacti 1.0.2 with apt-get
PostPosted: Wed Nov 15, 2017 1:44 pm 
Offline
Cacti Pro User

Joined: Tue Aug 29, 2006 4:09 pm
Posts: 541
Location: NL
I see a font option in the settings [http://localhost/cacti/settings.php?tab=visual]. Have you tried playing with that? If you go for the theme option, have you tried switching themes? Which theme are you using?

_________________
Maintainer of cacti in Debian (and Ubuntu).
Cacti 1.* is now officially supported on Debian Stretch via Debian backports
My PPA for cacti backports in Ubuntu
FAQ Ubuntu and Debian differences
Generic cacti debugging


Top
 Profile  
 
 Post subject: Re: Install cacti 1.0.2 with apt-get
PostPosted: Thu Nov 16, 2017 4:32 am 
Offline
Cacti User

Joined: Fri Feb 10, 2017 12:41 pm
Posts: 50
Interesting!
I tested various things.

I'm using the modern theme, and my Font Selection Method is Theme.

When I choose another theme, for example dark, there isn't any difference in the graphs.

However, when I change the Font Selection Method to System and leave all options default (don't define anything), the graphs and legend font are good. They are as they are supposed to be.

So there is definitely an issue with the Font Selection Method "Theme"

(but first since the update; 1.1.21 was fine)

Something changed.

But I'm okay now, since it's okay with "System"

But it's strange anyway, maybe you find something out for the next version.


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 30 posts ]  Go to page Previous  1, 2

All times are UTC - 5 hours


Who is online

Users browsing this forum: No registered users and 3 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  

Protected by Anti-Spam ACP Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group