Cacti (home)ForumsDocumentation
Cacti: offical forums and support
It is currently Mon Dec 18, 2017 12:28 am

All times are UTC - 5 hours




Post new topic Reply to topic  [ 2 posts ] 
Author Message
 Post subject: Problem with upgrading to 1.1.27 from 0.8.8b
PostPosted: Thu Nov 09, 2017 3:31 pm 
Offline

Joined: Thu Nov 09, 2017 3:06 pm
Posts: 1
When trying to do the step of ./configure I receive the following error below:
And ideas? I'm new to Cacti and this was installed originally by someone that is no longer with the company.


[[email protected] cacti-spine-1.1.27]# ./configure --with-reentrant
checking build system type... x86_64-unknown-linux-gnu
checking host system type... x86_64-unknown-linux-gnu
checking for a BSD-compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
checking for a thread-safe mkdir -p... /bin/mkdir -p
checking for gawk... gawk
checking whether make sets $(MAKE)... yes
checking for gawk... (cached) gawk
checking for gcc... gcc
checking for C compiler default output file name...
configure: error: in `/tmp/cacti-spine-1.1.27':
configure: error: C compiler cannot create executables
See `config.log' for more details.[/color][/b]

This what the config.log says:

This file contains any messages produced by compilers while
running configure, to aid debugging if configure makes a mistake.

It was created by Spine Poller configure 1.1.27, which was
generated by GNU Autoconf 2.63. Invocation command line was

$ ./configure --with-reentrant

## --------- ##
## Platform. ##
## --------- ##

hostname = XXXXXXXXXXXXX
uname -m = x86_64
uname -r = 2.6.32-696.6.3.el6.x86_64
uname -s = Linux
uname -v = #1 SMP Wed Jul 12 14:17:22 UTC 2017

/usr/bin/uname -p = unknown
/bin/uname -X = unknown

/bin/arch = x86_64
/usr/bin/arch -k = unknown
/usr/convex/getsysinfo = unknown
/usr/bin/hostinfo = unknown
/bin/machine = unknown
/usr/bin/oslevel = unknown
/bin/universe = unknown

PATH: /usr/local/sbin
PATH: /usr/local/bin
PATH: /sbin
PATH: /bin
PATH: /usr/sbin
PATH: /usr/bin
PATH: /root/bin


## ----------- ##
## Core tests. ##
## ----------- ##

configure:2096: checking build system type
configure:2114: result: x86_64-unknown-linux-gnu
configure:2136: checking host system type
configure:2151: result: x86_64-unknown-linux-gnu
configure:2198: checking for a BSD-compatible install
configure:2266: result: /usr/bin/install -c
configure:2277: checking whether build environment is sane
configure:2337: result: yes
configure:2478: checking for a thread-safe mkdir -p
configure:2517: result: /bin/mkdir -p
configure:2530: checking for gawk
configure:2546: found /bin/gawk
configure:2557: result: gawk
configure:2568: checking whether make sets $(MAKE)
configure:2590: result: yes
configure:2749: checking for gawk
configure:2776: result: gawk
configure:2835: checking for gcc
configure:2851: found /usr/bin/gcc
configure:2862: result: gcc
configure:3094: checking for C compiler version
configure:3102: gcc --version >&5
gcc (GCC) 4.4.7 20120313 (Red Hat 4.4.7-18)
Copyright (C) 2010 Free Software Foundation, Inc.
This is free software; see the source for copying conditions. There is NO
warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

configure:3106: $? = 0
configure:3113: gcc -v >&5
Using built-in specs.
Target: x86_64-redhat-linux
Configured with: ../configure --prefix=/usr --mandir=/usr/share/man --infodir=/usr/share/info --with-bugurl=http://bugzilla.redhat.com/bugzilla --enable-bootstrap --enable-shared --enable-threads=posix --enable-checking=release --with-system-zlib --enable-__cxa_atexit --disable-libunwind-exceptions --enable-gnu-unique-object --enable-languages=c,c++,objc,obj-c++,java,fortran,ada --enable-java-awt=gtk --disable-dssi --with-java-home=/usr/lib/jvm/java-1.5.0-gcj-1.5.0.0/jre --enable-libgcj-multifile --enable-java-maintainer-mode --with-ecj-jar=/usr/share/java/eclipse-ecj.jar --disable-libjava-multilib --with-ppl --with-cloog --with-tune=generic --with-arch_32=i686 --build=x86_64-redhat-linux
Thread model: posix
gcc version 4.4.7 20120313 (Red Hat 4.4.7-18) (GCC)
configure:3117: $? = 0
configure:3124: gcc -V >&5
gcc: '-V' option must have argument
configure:3128: $? = 1
configure:3151: checking for C compiler default output file name
configure:3173: gcc -lpthread -lssl -lm conftest.c >&5
/usr/bin/ld: cannot find -lssl
collect2: ld returned 1 exit status
configure:3177: $? = 1
configure:3215: result:
configure: failed program was:
| /* confdefs.h. */
| #define PACKAGE_NAME "Spine Poller"
| #define PACKAGE_TARNAME "spine-poller"
| #define PACKAGE_VERSION "1.1.27"
| #define PACKAGE_STRING "Spine Poller 1.1.27"
| #define PACKAGE_BUGREPORT "http://www.cacti.net/issues.php"
| #define PACKAGE "spine-poller"
| #define VERSION "1.1.27"
| /* end confdefs.h. */
|
| int
| main ()
| {
|
| ;
| return 0;
| }
configure:3221: error: in `/tmp/cacti-spine-1.1.27':
configure:3224: error: C compiler cannot create executables
See `config.log' for more details.

## ---------------- ##
## Cache variables. ##
## ---------------- ##

ac_cv_build=x86_64-unknown-linux-gnu
ac_cv_env_CC_set=
ac_cv_env_CC_value=
ac_cv_env_CFLAGS_set=
ac_cv_env_CFLAGS_value=
ac_cv_env_CPPFLAGS_set=
ac_cv_env_CPPFLAGS_value=
ac_cv_env_CPP_set=
ac_cv_env_CPP_value=
ac_cv_env_LDFLAGS_set=
ac_cv_env_LDFLAGS_value=
ac_cv_env_LIBS_set=
ac_cv_env_LIBS_value=
ac_cv_env_build_alias_set=
ac_cv_env_build_alias_value=
ac_cv_env_host_alias_set=
ac_cv_env_host_alias_value=
ac_cv_env_target_alias_set=
ac_cv_env_target_alias_value=
ac_cv_host=x86_64-unknown-linux-gnu
ac_cv_path_install='/usr/bin/install -c'
ac_cv_path_mkdir=/bin/mkdir
ac_cv_prog_AWK=gawk
ac_cv_prog_ac_ct_CC=gcc
ac_cv_prog_make_make_set=yes

## ----------------- ##
## Output variables. ##
## ----------------- ##

ACLOCAL='${SHELL} /tmp/cacti-spine-1.1.27/config/missing --run aclocal-1.11'
AMDEPBACKSLASH=''
AMDEP_FALSE=''
AMDEP_TRUE=''
AMTAR='${SHELL} /tmp/cacti-spine-1.1.27/config/missing --run tar'
AR=''
AUTOCONF='${SHELL} /tmp/cacti-spine-1.1.27/config/missing --run autoconf'
AUTOHEADER='${SHELL} /tmp/cacti-spine-1.1.27/config/missing --run autoheader'
AUTOMAKE='${SHELL} /tmp/cacti-spine-1.1.27/config/missing --run automake-1.11'
AWK='gawk'
CC='gcc'
CCDEPMODE=''
CFLAGS=''
CPP=''
CPPFLAGS=''
CYGPATH_W='echo'
DEFS=''
DEPDIR=''
DSYMUTIL=''
DUMPBIN=''
ECHO_C=''
ECHO_N='-n'
ECHO_T=''
EGREP=''
EXEEXT=''
FGREP=''
GREP=''
HAVE_HELP2MAN_FALSE=''
HAVE_HELP2MAN_TRUE=''
HELP2MAN=''
INSTALL_DATA='${INSTALL} -m 644'
INSTALL_PROGRAM='${INSTALL}'
INSTALL_SCRIPT='${INSTALL}'
INSTALL_STRIP_PROGRAM='$(install_sh) -c -s'
LD=''
LDFLAGS='-lpthread -lssl -lm '
LIBOBJS=''
LIBS=''
LIBTOOL=''
LIPO=''
LN_S=''
LTLIBOBJS=''
MAKEINFO='${SHELL} /tmp/cacti-spine-1.1.27/config/missing --run makeinfo'
MKDIR_P='/bin/mkdir -p'
NM=''
NMEDIT=''
OBJDUMP=''
OBJEXT=''
OTOOL64=''
OTOOL=''
PACKAGE='spine-poller'
PACKAGE_BUGREPORT='http://www.cacti.net/issues.php'
PACKAGE_NAME='Spine Poller'
PACKAGE_STRING='Spine Poller 1.1.27'
PACKAGE_TARNAME='spine-poller'
PACKAGE_VERSION='1.1.27'
PATH_SEPARATOR=':'
RANLIB=''
SED=''
SET_MAKE=''
SHELL='/bin/sh'
STRIP=''
VERSION='1.1.27'
ac_aux_dir='config'
ac_ct_CC='gcc'
ac_ct_DUMPBIN=''
am__EXEEXT_FALSE=''
am__EXEEXT_TRUE=''
am__fastdepCC_FALSE=''
am__fastdepCC_TRUE=''
am__include=''
am__isrc=''
am__leading_dot='.'
am__quote=''
am__tar='${AMTAR} chof - "$$tardir"'
am__untar='${AMTAR} xf -'
bindir='${exec_prefix}/bin'
build='x86_64-unknown-linux-gnu'
build_alias=''
build_cpu='x86_64'
build_os='linux-gnu'
build_vendor='unknown'
datadir='${datarootdir}'
datarootdir='${prefix}/share'
docdir='${datarootdir}/doc/${PACKAGE_TARNAME}'
dvidir='${docdir}'
exec_prefix='NONE'
host='x86_64-unknown-linux-gnu'
host_alias=''
host_cpu='x86_64'
host_os='linux-gnu'
host_vendor='unknown'
htmldir='${docdir}'
includedir='${prefix}/include'
infodir='${datarootdir}/info'
install_sh='${SHELL} /tmp/cacti-spine-1.1.27/config/install-sh'
libdir='${exec_prefix}/lib'
libexecdir='${exec_prefix}/libexec'
localedir='${datarootdir}/locale'
localstatedir='${prefix}/var'
lt_ECHO='echo'
mandir='${datarootdir}/man'
mkdir_p='/bin/mkdir -p'
oldincludedir='/usr/include'
pdfdir='${docdir}'
prefix='NONE'
program_transform_name='s,x,x,'
psdir='${docdir}'
sbindir='${exec_prefix}/sbin'
sharedstatedir='${prefix}/com'
sysconfdir='${prefix}/etc'
target_alias=''

## ----------- ##
## confdefs.h. ##
## ----------- ##

#define PACKAGE_NAME "Spine Poller"
#define PACKAGE_TARNAME "spine-poller"
#define PACKAGE_VERSION "1.1.27"
#define PACKAGE_STRING "Spine Poller 1.1.27"
#define PACKAGE_BUGREPORT "http://www.cacti.net/issues.php"
#define PACKAGE "spine-poller"
#define VERSION "1.1.27"

configure: exit 77


Top
 Profile  
 
 Post subject: Re: Problem with upgrading to 1.1.27 from 0.8.8b
PostPosted: Wed Nov 15, 2017 4:34 am 
Offline

Joined: Sun Aug 27, 2017 12:05 am
Posts: 40
I had this problem. You need to make sure that you have all the compiler pre-requesites installed such as autoconf, and some libraries. Assuming that you are using ubuntu, I think this was what I had to do:
apt install net-snmp* help2man libsnmp-dev libc6-dev gcc make libtool autoconf

Once you have all that, you need to run the ./bootstrap, ./configure and it should now move on. The error isn't that it can't create an executable, but that the test program it wants to compile won't work. The mysql headers should already be installed when you installed the MySQL server.


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 2 posts ] 

All times are UTC - 5 hours


Who is online

Users browsing this forum: phalek and 4 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  

Protected by Anti-Spam ACP Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group